qemu-kvm-spice doesn't support spice/qxl installs

Reported by Boris Derzhavets on 2012-05-12
74
This bug affects 14 people
Affects Status Importance Assigned to Milestone
QEMU
Undecided
Unassigned
qemu-kvm-spice (Ubuntu)
High
Unassigned

Bug Description

Been setup as follows :-

boris@boris-P5Q-E:~$ dpkg -l | grep spice
ii gir1.2-spice-client-glib-2.0 0.9-0ubuntu1 GObject for communicating with Spice servers (GObject-Introspection)
ii gir1.2-spice-client-gtk-2.0 0.9-0ubuntu1 GTK2 widget for SPICE clients (GObject-Introspection)
ii gir1.2-spice-client-gtk-3.0 0.9-0ubuntu1 GTK3 widget for SPICE clients (GObject-Introspection)
ii libspice-client-glib-2.0-1 0.9-0ubuntu1 GObject for communicating with Spice servers (runtime library)
ii libspice-client-glib-2.0-dev 0.9-0ubuntu1 GObject for communicating with Spice servers (development files)
ii libspice-client-gtk-2.0-1 0.9-0ubuntu1 GTK2 widget for SPICE clients (runtime library)
ii libspice-client-gtk-2.0-dev 0.9-0ubuntu1 GTK2 widget for SPICE clients (development files)
ii libspice-client-gtk-3.0-1 0.9-0ubuntu1 GTK3 widget for SPICE clients (runtime library)
ii libspice-client-gtk-3.0-dev 0.9-0ubuntu1 GTK3 widget for SPICE clients (development files)
ii libspice-protocol-dev 0.10.1-1 SPICE protocol headers
ii libspice-server-dev 0.10.0-1 Header files and development documentation for spice-server
ii libspice-server1 0.10.0-1 Implements the server side of the SPICE protocol
ii python-spice-client-gtk 0.9-0ubuntu1 GTK2 widget for SPICE clients (Python binding)
ii qemu-kvm-spice 1.0.50-2012.03-0ubuntu2 Full virtualization on amd64 hardware

Spice/QXL install doesn't work on Ubuntu 12.04 . View also https://bugs.launchpad.net/ubuntu/+source/seabios/+bug/823494
It doesn't look like duplicate of bug mentioned above.

Boris Derzhavets (bderzhavets) wrote :

Spice/VGA install doesn't work as well . It's not duplicate https://bugs.launchpad.net/ubuntu/+source/seabios/+bug/823494

Alon Levy (alonlevy1) wrote :

Hi Boris,

 I don't get it - what is the error exactly? I don't use qemu-kvm-spice on ubuntu, but maybe I could help if you provided more details, like the qemu command line, the output on stdout/stderr, for both cases, spice+qxl and spice+not-qxl

Thanks,
Alon

Boris Derzhavets (bderzhavets) wrote :

Alon,

 I tested F16 and W7. Installs attempted via VIrtManager (spice/qx l, spice/vga) poped up black screen for ever.
F17 (beta) requires several minutes to activate SPICE/QXL install window, and behaves same way during runtime.
Any Spice-Gtk build mentioned in #1 does it in few seconds doing F17 (beta) install ( runtime).

   As wrote MikeB ( view https://bugs.launchpad.net/ubuntu/+source/seabios/+bug/823494)
just spice/cirrus work for install and runtime in case of W7.

    I also believe there is an issue in spice-gtk 0.9 build via Debian Unstable.
 It has nothing to do with spice enabled qemu version.

All my spice-gtk builds for ubuntu 12.04 mentioned in #1 are done in different way and work fine.

Thanks,
Boris

Boris Derzhavets (bderzhavets) wrote :

>It has nothing to do with spice enabled qemu version.

Not exactly :-

boris@boris-P5Q-E:~$ sudo /usr/bin/kvm-spice -cpu host -enable-kvm -name W7 -m 2048 -drive file=/dev/sda7,if=virtio,media=disk,aio=native,cache=off -net nic,model=rtl8139 -net user -localtime -usb -vga qxl -spice port=5900,disable-ticketing -cdrom /home/boris/win7.iso -boot d

do_spice_init: starting 0.10.0
spice_server_add_interface: SPICE_INTERFACE_MIGRATION
spice_server_add_interface: SPICE_INTERFACE_KEYBOARD
spice_server_add_interface: SPICE_INTERFACE_MOUSE
Could not open option rom 'kvmvapic.bin': No such file or directory
spice_server_add_interface: SPICE_INTERFACE_QXL
red_worker_main: begin
ensure_display_channel_created: create display channel
ensure_cursor_channel_created: create cursor channel

Boris Derzhavets (bderzhavets) wrote :

Normal start in my system :-

boris@boris-System-Product-P5Q3:~$ sudo /usr/bin/kvm -cpu host -enable-kvm -name WIN7 -m 2048 -drive file=/dev/sda7,if=ide,media=disk,aio=native,cache=off -net nic,model=rtl8139 -net user -localtime -usb -vga qxl -spice port=5900,disable-ticketing -cdrom /home/boris/win7.iso -boot d
do_spice_init: starting 0.10.1
spice_server_add_interface: SPICE_INTERFACE_MIGRATION
spice_server_add_interface: SPICE_INTERFACE_KEYBOARD
spice_server_add_interface: SPICE_INTERFACE_MOUSE
spice_server_add_interface: SPICE_INTERFACE_QXL
red_worker_main: begin
display_channel_create: create display channel
cursor_channel_create: create cursor channel

Fantu (fantonifabio) on 2012-05-15
Changed in qemu:
status: New → Confirmed
Changed in qemu-kvm-spice (Ubuntu):
status: New → Confirmed
Serge Hallyn (serge-hallyn) wrote :

Thanks, Boris. I suspect this was meant to only affect the ubuntu qemu-kvm-spice (and related) packages, not upstream qemu, right? If so I'll mark as invalid for QEMU project.

I'll take a look at the debdiffs, and will talk to the debian maintainers to see if they're willing to take these, and go from there.

Boris Derzhavets (bderzhavets) wrote :

Serge,

> I suspect this was meant to only affect the ubuntu qemu-kvm-spice (and related) packages,
> not upstream qemu, right?

I believe it's not a problem to verify.

lequeux1 (elequeux) wrote :

Confirmed for winXP guest:
qemu-kvm-spice doesn't support spice/qxl (bugs: 100%CPU, vdservice doesnt start, no guest screen at boot)

Boris's recipe works ( http://bderzhavets.wordpress.com/2012/05/22/set-up-qemu-kvm-1-0noroms-as-spice-enabled-qemu-server/)

NB: used guest winXP drivers from spice-guest-tools-0.1.exe (http://spice-space.org/download/binaries/)

Same here. I was trying to install Win7 64-bit on 12.04 with qemu-kvm-spice and neither qxl nor vga graphics would work--both showed a black screen. Configuring the display as VNC instead of SPICE made no difference. But choosing cirrus graphics made it work.

Possibly related to bug 958549.

TJ (tj) wrote :

This is a show-stopper and regression for many VM scenarios on Precise. A year later we should have a fix for this.

Changed in qemu-kvm-spice (Ubuntu):
importance: Undecided → High
Serge Hallyn (serge-hallyn) wrote :

Where exactly is the bug - in the spice libs, or in qemu source itself?

This should be fixed in raring, if not please shout.

If someone attaches a minimal debdiff to fix the bug in precise, I'll attempt to SRU it.

Serge Hallyn (serge-hallyn) wrote :

Not valid in qemu upstreaqm project IIUC.

Changed in qemu:
status: Confirmed → Invalid
Serge Hallyn (serge-hallyn) wrote :

Thsi shoudl be fixed in raring. If it is not, please shout and I'll re-mark it Confirmed.

Changed in qemu-kvm-spice (Ubuntu):
status: Confirmed → Fix Released
Michael Adam (obnox) wrote :

I was not able to confirm yet,
but since 12.04 is a LTS release, are there any chances to get this fixed in 12.04?

Our virt server is running 12.04, and we would not like to do do an upgrade before 14.04.

Thanks - Michael

Michael Adam (obnox) wrote :

Sorry, I meant to say: I was not yet able to confirm that it is fixed in raring.

I am able to confirm that the bug persists in 12.04:
kvm-spice won't work with any other graphics card than cirrus.

Cheers - Michael

Ilya G. Ryabinkin (ileyka) wrote :

Bug still exist in 12.04.

BIOS messages are not visible with qxl driver; however, with installed guest addiations it is possible to log in to guest OS (tried with Windows)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers