QEMU 0.12.0-rc1 does not support KQEMU

Bug #493519 reported by rowa on 2009-12-07
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
QEMU
Undecided
Unassigned

Bug Description

Hi,

I've compiled QEMU 0.12.0-rc1 on Linux Ubuntu Intrepid and Mac OS X.

I tryed to use KQEMU but I can't found KQEMU support. This options and commands don't work.

 qemu -kernel-kqemu
 qemu: invalid option -- '-kernel-kqemu'

 qemu -enable-kqemu
 qemu: invalid option -- '-enable-kqemu'

 qemu -monitor stdio
 QEMU 0.11.91 monitor - type 'help' for more information
 (qemu) info kqemu

kqemu support has been removed for 0.12. I will make sure to make this very clear in the release notes.

Changed in qemu:
status: New → Won't Fix
rowa (robertwa) wrote :

Does it mean QEMU on Mac OS X, BSD and Windows will have not an accelator any more?

Correct.

kqemu has been unmaintained for the past 3-4 years. It's causing difficult to resolve functional regressions in qemu. We put out a call for someone to step up as maintainer and no one has. We deprecated it over the course of the 0.11 series (disabling it by default). After fair warning, we removed it as part of the 0.12 development cycle.

Unfortunately, it requires a lot of work and no one has expressed any interest in maintaining it.

rowa (robertwa) wrote :

Oh, what a surprise (I think not only for me). I've never read something about this.

Where do you post this call and warning?

In http://www.qemu.org or http://www.nongnu.org/qemu/ ? (Which is the less oldest one? ;-)

I think that the support of QEMU for Windows, BSD and Mac OS X will end soon. Without an accelator only few people will use it. I think many people will disappointed.

Maybe this requires a lot of work. But a bit better communication is not a hard work (The contents of http://www.qemu.org or http://www.nongnu.org/qemu/ are out-of-date, links are broken, ...).
 :-(

Which Features are gone too?

http://www.qemu.org is our official site.

There hasn't been announcement on the website because we haven't released 0.12. It's been announced and discussed repeatedly on the mailing list.

rowa (robertwa) wrote :

But http://www.qemu.org is out-of-date.

http://www.qemu.org/qemu-doc.html is from March, 8 2009.
The qemu-doc.html of QEMU 0.12.0 rc1 is not correct.

How can we find bugs when we have not a right documentation?

The doc reflects the 0.11.1 release which is the most current stable release.

When 0.12.0 is released, the documentation will be updated.

rowa (robertwa) wrote :

Do you mean the file qemu-doc.html in http://download.savannah.gnu.org/releases/qemu/qemu-0.12.0-rc1.tar.gz ?

I can't understand why this doc don't reflect to the source code of 0.12.0-rc1 and why it have a lot of broken links.

There are a lot of differences to
qemu --help
help in QEMU-Monitor

For example

-rtc-td-hack
-localtime
-startdate
-netdev
-mem-path
-mem-prealloc
-tdf
-nvram
-enable-nesting
-no-kvm-irqchip
-no-kvm-pit
-no-kvm-pit-reinjection
-xen-domid id
-xen-create
-xen-attach
-readconfig <file>
-writeconfig <file>
(qemu) host_net_redir
(qemu) acl_reset

Please see also

http://qemu-buch.de/d/Anhang/_Startoptionen_von_QEMU_und_KVM

http://qemu-buch.de/d/Anhang/_QEMU-Monitor

rowa (robertwa) wrote :

@Anthony Liguori : You wrote this in #1

"kqemu support has been removed for 0.12. I will make sure to make this very clear in the release notes."

QEMU 0.12.1 is out but where is your statement in http://www.qemu.org or http://www.nongnu.org/qemu/ ?

Changed in qemu:
status: Won't Fix → New
Changed in qemu:
status: New → Won't Fix
rowa (robertwa) wrote :

Please don't close bug reports without a comment.

Again:

QEMU 0.12.2 is out but where is your statement in http://www.qemu.org or http://www.nongnu.org/qemu/ ?

Changed in qemu:
status: Won't Fix → New
assignee: nobody → Anthony Liguori (anthony-codemonkey)
Dustin Kirkland  (kirkland) wrote :

Rowa-

Your usage of Launchpad Bugs is rapidly crossing the border of abusiveness.

Anthony is the maintainer of QEMU. If he closes a bug as "Won't Fix", you should really respect his decision. And if QEMU is not meeting your needs as a system emulator, hypervisor, or driver model, then you should look for other solutions.

With respect to the current bug, this bug tracker is intended for the code that is released in the qemu upstream release tarball, and the code that's tracked and developed in the qemu git repositories. This does not cover typos, omissions, or errors on the qemu.org website.

Finally, KQEMU is no longer part of QEMU. Period. If you still want KQEMU, then you should grab an older copy of QEMU, and either fork the project (as others have done, like VirtualBox), or step up and maintain the KQEMU (which has been abandoned).

This bug is hereby closed. If you reopen it again, we will get the Launchpad Administrators involved.

Changed in qemu:
status: New → Won't Fix
assignee: Anthony Liguori (anthony-codemonkey) → nobody
rowa (robertwa) wrote :

Hi Dustin,

here a text of your official documentation http://www.qemu.org/qemu-doc.html

----
‘-kernel-kqemu’

    Enable KQEMU full virtualization (default is user mode only).
‘-no-kqemu’

    Disable KQEMU kernel module usage. KQEMU options are only available if KQEMU support is enabled when compiling.
----

My (and not only my) wish is: Please update this text.

Robert

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers