Comment 6 for bug 1652317

Steve Martinelli (stevemar) wrote :

To summarize:

We're going to block SDK v0.9.11 for now, since the following commands will fail:

 - quota_set
 - quota show
 - network agent set
 - network agent show
 - network qos *
 - network qos rule *
 - port *
 - security group *
 - security group rule *

With SDK v0.9.10 installed, the following commands will fail:

 - qos_rule_type_list
 - network_service_provider_list
 - ip_availability_show

The latter seems more acceptable since it won't block any gates, and fewer impacted commands overall. We're going to re-work the commands to work with both versions of the SDK.

This was unfortunately not caught by our functional tests as they were not running (problem in the test hook), they are running now. See https://review.openstack.org/#/c/414652/.