Comment 2 for bug 1006553

Hi Maris. When I try this with the latest juju on precise, I don't get a runaway process. Mine just reconnects every few seconds...

[pid 1090] poll([{fd=4, events=POLLIN}, {fd=10, events=POLLIN|POLLOUT}], 2, 3333) = 1 ([{fd=10, revents=POLLIN|POLLOUT|POLLERR|POLLHUP}])
[pid 1090] getsockopt(10, SOL_SOCKET, SO_ERROR, [111], [4]) = 0
[pid 1090] close(10) = 0
[pid 1090] poll([{fd=4, events=POLLIN}], 1, 3333) = 0 (Timeout)
[pid 1090] socket(PF_INET, SOCK_STREAM, IPPROTO_IP) = 10
[pid 1090] setsockopt(10, SOL_TCP, TCP_NODELAY, [1], 4) = 0
[pid 1090] fcntl(10, F_GETFL) = 0x2 (flags O_RDWR)
[pid 1090] fcntl(10, F_SETFL, O_RDWR|O_NONBLOCK) = 0
[pid 1090] connect(10, {sa_family=AF_INET, sin_port=htons(55429), sin_addr=inet_addr("192.168.122.1")}, 16) = -1 EINPROGRESS (Operation now in progress)
[pid 1090] poll([{fd=4, events=POLLIN}, {fd=10, events=POLLIN|POLLOUT}], 2, 3333) = 1 ([{fd=10, revents=POLLIN|POLLOUT|POLLERR|POLLHUP}])
[pid 1090] getsockopt(10, SOL_SOCKET, SO_ERROR, [111], [4]) = 0
[pid 1090] close(10) = 0
[pid 1090] poll([{fd=4, events=POLLIN}], 1, 3333) = 0 (Timeout)
[pid 1090] socket(PF_INET, SOCK_STREAM, IPPROTO_IP) = 10
[pid 1090] setsockopt(10, SOL_TCP, TCP_NODELAY, [1], 4) = 0
[pid 1090] fcntl(10, F_GETFL) = 0x2 (flags O_RDWR)
[pid 1090] fcntl(10, F_SETFL, O_RDWR|O_NONBLOCK) = 0
[pid 1090] connect(10, {sa_family=AF_INET, sin_port=htons(55429), sin_addr=inet_addr("192.168.122.1")}, 16) = -1 EINPROGRESS (Operation now in progress)
[pid 1090] poll([{fd=4, events=POLLIN}, {fd=10, events=POLLIN|POLLOUT}], 2, 3333) = 1 ([{fd=10, revents=POLLIN|POLLOUT|POLLERR|POLLHUP}])
[pid 1090] getsockopt(10, SOL_SOCKET, SO_ERROR, [111], [4]) = 0
[pid 1090] close(10) = 0
[pid 1090] poll([{fd=4, events=POLLIN}], 1, 3333

Can you strace the runaway process for a while with

strace -f -o /tmp/strace-machine-agent.log -p $PID_OF_MACHINE_AGENT

And then attach that as well?

Thanks!