Can't upgrade to 0.3 on Centos 6.4

Bug #1218063 reported by Stephan Tual on 2013-08-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
PyGPGME
Undecided
Unassigned

Bug Description

Python 2.6.7 - running pip install --upgrade pygpgme returns :

In file included from src/gpgme.c:22:
src/pygpgme.h:24:19: error: gpgme.h: No such file or directory
In file included from src/gpgme.c:22:
src/pygpgme.h:32: error: expected specifier-qualifier-list before ‘gpgme_ctx_t’
src/pygpgme.h:37: error: expected specifier-qualifier-list before ‘gpgme_key_t’
src/pygpgme.h:42: error: expected specifier-qualifier-list before ‘gpgme_subkey_t’
src/pygpgme.h:48: error: expected specifier-qualifier-list before ‘gpgme_user_id_t’
src/pygpgme.h:54: error: expected specifier-qualifier-list before ‘gpgme_key_sig_t’
src/pygpgme.h:124: error: expected ‘)’ before ‘err’
src/pygpgme.h:125: error: expected ‘)’ before ‘err’
src/pygpgme.h:126: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘pygpgme_check_pyerror’
src/pygpgme.h:130: error: expected ‘)’ before ‘*’ token
src/pygpgme.h:131: error: expected ‘)’ before ‘key’
src/pygpgme.h:132: error: expected ‘)’ before ‘siglist’
src/pygpgme.h:133: error: expected ‘)’ before ‘siglist’
src/pygpgme.h:134: error: expected ‘)’ before ‘ctx’
src/pygpgme.h:135: error: expected ‘)’ before ‘ctx’
src/gpgme.c: In function ‘create_module’:
src/gpgme.c:92: warning: implicit declaration of function ‘gpgme_check_version’
src/gpgme.c:92: warning: assignment makes pointer from integer without a cast
error: command 'gcc' failed with exit status 1

William Grant (wgrant) wrote :

You need to have the GPGME library and headers installed (probably the 'gpgme-devel' package on Red Hat derivatives).

Changed in pygpgme:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers