[Lucid] Doesn't start

Bug #648930 reported by bhm on 2010-09-27
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Popper
Medium
Ralf Hersel

Bug Description

Lucid 32
Popper v 0.19

this is output for python /usr/share/popper/popper.py

-----------------------------
checking email accounts at: Mon Sep 27 15:30:09 2010
Traceback (most recent call last):
  File "/usr/share/popper/popper.py", line 758, in <module>
    if __name__ == '__main__': main()
  File "/usr/share/popper/popper.py", line 748, in main
    indicator.timeout() # immediate check, firstcheck=True
  File "/usr/share/popper/popper.py", line 363, in timeout
    self.mail_list = get_mail(self.sort_order) # get all mails from all inboxes
  File "/usr/share/popper/popper.py", line 153, in get_mail
    typ, data = srv.search(None, 'UNSEEN') # ALL or UNSEEN
  File "/usr/lib/python2.6/imaplib.py", line 620, in search
    typ, dat = self._simple_command(name, *criteria)
  File "/usr/lib/python2.6/imaplib.py", line 1060, in _simple_command
    return self._command_complete(name, self._command(name, *args))
  File "/usr/lib/python2.6/imaplib.py", line 818, in _command
    ', '.join(Commands[name])))
imaplib.error: command SEARCH illegal in state AUTH, only allowed in states SELECTED

--------------------

Test in config tool goes ok for all acounts (4 Gmail ones on IMAP).

Changed in popper:
status: New → Incomplete
assignee: nobody → Ralf Hersel (ralf.hersel)
Ralf Hersel (ralf.hersel) wrote :

Sorry, but I don't know what it is. Requires some IMAP specialist to contribute.

tamalet (tamalet) wrote :

I get the same error.
In Popper Configurator I configured a gmail IMAP account and my work IMAP account. Both pass the test.

tamalet (tamalet) wrote :

Oh, and I am testing it in Maverick.

bhm (bhm) wrote :

I think I narrowed it down.
After googling for "imaplib.error: command SEARCH illegal in state AUTH, only allowed in states SELECTED"
I stumbled up this
http://stackoverflow.com/questions/3267234/i-cannot-search-sent-emails-in-gmail-with-python

At first I got IMAP folders configured. First account got them written as
iNBOX,ARCHIVE,[Gmail]/Trash
On other one
INBOX,ARCHIVE,[Gmail]/Trash,[Gmail]/Instructables
and few others reported in test tab.

INBOX,ARCHIVE doesn't work. Separating them after coma doesn't work either. It reports same error as in my first post.

After deleting and leaving INBOX popper final started up.
It's seems like parsing of names into search via IMAP for folders problem to me.

Ralf Hersel (ralf.hersel) wrote :

Well, that seems to be a good hint on what may cause the problems. I will investigate further. Please be patient.

Changed in popper:
status: Incomplete → Triaged
importance: Undecided → Medium
Ralf Hersel (ralf.hersel) wrote :

Unfortunately I cannot confirm your suggestion. I have these folders in my Gmail account:

Folder:
"INBOX"
"Personal"
"Receipts"
"Travel"
"Work"
"[Gmail]"
Nachrichten"
"[Gmail]/Entw&APw-rfe"
"[Gmail]/Gesendet"
"[Gmail]/Markiert"
"[Gmail]/Papierkorb"
"[Gmail]/Spam"

I put this in the folder field in Popper_Configurator: "INBOX,[Gmail]/Entw&APw-rfe,[Gmail]/Gesendet,[Gmail]/Papierkorb" and it works fine. Popper selects and reads from all four folders. Anyway, I put some debug code in Popper 0.20 that lists the folder which it tries to access. This may tell us at which folder it crashes.

Changed in popper:
status: Triaged → Incomplete
tamalet (tamalet) wrote :

I can confirm that removing ARCHIVE from the gmail account solves the problem.

bhm (bhm) wrote :

I just checked out 0.20. I'm still sick.
Putting custom folders ( [Gmail]/ ) doesn't prevent from starting( which strangely was an issue 0.19).
That Archive folder that causes the problem( at least for two of us here) is after installation as default one for test account. It's not present in every gmail account it seems (my guess is it's either created by email clients since most of them have archive option or localization issue). ARCHIVE is certainly present in my Postbox and Thunderbird clients but not directly on gmail account.

Maybe parsing reported folders would be a good feature? Just so make it dumb/confusion proof.

Changed in popper:
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers