Plank doesn't automatically appear after login

Bug #1256626 reported by Simon Langley on 2013-12-01
100
This bug affects 21 people
Affects Status Importance Assigned to Milestone
Plank
High
Rico Tzschichholz

Bug Description

plank worked fine until the latest update (yesterday 30/11/13) to version 0.5.0. Running on Mint 15 with Cinnamon.

At start up plank remains invisible (normally I keep it permanently showing). As soon as I start any program plank appears and from there on works normally. Starting a program means it appears among plank's items so, I imagine, triggering a redraw.

Source of problem: thunderbird is set to run at system start. It is also on the plank menu. If I remove it from plank, everything works fine. Is this a timing problem? What happens if, when plank starts up, apps from its list are already running?

Related branches

Robert Dyer (psybers) wrote :

I'm having problems reproducing this. Plank should behave fine if apps are already running (does for me).

This might be specific to Mint, and I am on Ubuntu.

Changed in plank:
importance: Undecided → Medium
status: New → Incomplete
Richard Lindner (riclin54) wrote :

I can replicate this bug under Mint Cinnamon, Plank 0.5.0.950

Richard Lindner (riclin54) wrote :

$ plank -V
[INFO 22:07:09.783981] [AbstractMain:174] Plank version: 0.5.0.950
[INFO 22:07:09.784081] [AbstractMain:175] Kernel version: 3.11.0-12-generic
[INFO 22:07:09.784153] [AbstractMain:176] GLib version: 2.38.1
[INFO 22:07:09.784233] [AbstractMain:177] GTK+ version: 3.8.4
[INFO 22:07:09.784300] [AbstractMain:178] Wnck version: 3.4.7
[INFO 22:07:09.784379] [AbstractMain:179] Cairo version: 1.12.16
[INFO 22:07:09.784451] [AbstractMain:180] Pango version: 1.32.5

motley (motley-slate) wrote :

Same issue on Arch Linux using latest Gnome 3.10.2.

Configured dock to show all the time and reduced icon size to 36. Configured dock to run at startup using gnome-session-properties. Dock is not visible when gnome session starts. I have to either move the cursor to the bottom of the screen or start an application from gnome to have plank become visible.

After it shows, everything is fine. If set to show all the time, it should not start minimized/hidden. This recently worked on another machine I no longer have access to, but it was likely a different version.

$ plank -v
[INFO 18:16:49.098090] [AbstractMain:174] Plank version: 0.5.0
[INFO 18:16:49.098223] [AbstractMain:175] Kernel version: 3.12.9-1-ARCH
[INFO 18:16:49.098308] [AbstractMain:176] GLib version: 2.38.2
[INFO 18:16:49.098397] [AbstractMain:177] GTK+ version: 3.10.7
[INFO 18:16:49.098472] [AbstractMain:178] Wnck version: 3.4.7
[INFO 18:16:49.098554] [AbstractMain:179] Cairo version: 1.12.16
[INFO 18:16:49.098637] [AbstractMain:180] Pango version: 1.36.2

Launchpad Janitor (janitor) wrote :

[Expired for Plank because there has been no activity for 60 days.]

Changed in plank:
status: Incomplete → Expired

Unfortunately this bug is still present;

Way to reproduce:
Running Gnome-Shell 3.12 and creating a plank.desktop file in ~./config/autostart with "Exec=/usr/bin/plank"
When booting into Gnome 3.12, plank is autostarting, but not visible. When moving the cursor to the bottom or starting an application plank is becoming visible and works just as it is supposed to.

Changed in plank:
status: Expired → New
Changed in plank:
importance: Medium → High
Rico Tzschichholz (ricotz) wrote :

Please try to reproduce with r1060. r1059 and r1060 might have an impact on this problem.

Rudolf Reuter (reuterr) wrote :

Thank you for the very good program.

Under Ubuntu 14-04, after a system update, Plank does also have this behavior.
Plank version 0.61+bzr1067-0ubuntu1~ricotz1
I have Plank on the right side.

In the process list I can see Plank as running, but it is not visible at startup.

If I start a program which is in the dock, Plank does not show up.

If I start a program which in NOT in the dock, Plank does show up, and stays/works.

I hope, that my description will help in the trouble shooting.

Pedro Jimenez (pedrojimenezp) wrote :

Hi everyone.

Thomas Hoeltke, Do you have tried to add these 2 lines? in your plank.desktop file?

NoDisplay=false
Hidden=false

My current plank.desktop file has these lines and work very well when my laptop starts.

[Desktop Entry]
Encoding=UTF-8
Name=Plank
Exec=plank
Terminal=false
Icon=plank
NoDisplay=false
Hidden=false

Maybe this can help you.

Rudolf Reuter (reuterr) wrote :

Hello Pedro,

After an update my Plank version is now 0.7.

I have checked my file /home/<user>/.config/autostart/plank.desktop.
It has the two items:
  NoDisplay=false
  Hidden=false

Then I have checked file /usr/share/applications/plank.desktop.
There I could add the line:
  Hidden=false
After a system restart the Plank dock is still missing.

Still, if start a program which in NOT in the dock, Plank does show up, and stays/works.

KlausMaier (klausmaier) wrote :

I also having this issue. It does not occur on my desktop PC but only on my laptop. My PC is way faster than my Laptop, so I guess this is somehow related to this issue. Both share the same setup: Arch Linux, Plank 0.7 and Xfce 4.11.

meda (ademcal) wrote :

I solved. I am using on the Arch Linux, Plank 0.7.1.
 /usr/share/applications/plank copy to .config/autostart/

cristian (elescristian) wrote :

Hello, I also affects the error. I'm on linux mint 17.1. Version 0.7.1.1136 plank. probe solution to replace the previous config / autostart / to / usr / share / applications / plank without results

Heimen Stoffels (vistaus) wrote :

Also affects AmiWM 0.21 on Antergos (based on Arch). I have to click the bottom edge of the screen (kinda like GNOME's message tray at the bottom) to get Plank to show itself.

Changed in plank:
status: New → Confirmed
bapoumba (bapoumba) wrote :

Same here on ubuntu-mate 15.04.

summary: - plank not visible at startup
+ Plank not visible at startup
summary: - Plank not visible at startup
+ Plank doesn't automatically appear after login
Rico Tzschichholz (ricotz) wrote :

Fixed in r1258

Changed in plank:
status: Confirmed → Fix Committed
assignee: nobody → Rico Tzschichholz (ricotz)
milestone: none → 0.9.1
Changed in plank:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers