Plank theme not updating

Reported by Kathen Brewster on 2012-08-09
62
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Plank
Low
Robert Dyer
elementary OS
Undecided
Unassigned

Bug Description

It seems a lot of people have complained about the look of the new "white" plank theme but it won't even update on my system! I'd like to try it but can't figure out a way to do so.

Related branches

zeeeeee (miesogeno) wrote :

I'm experiencing the same problem, but I already had the new theme (I applied it manually). now it reversed to the old one, the thin cartoonish line beneath the icons.

I've tried changing it again through switchboard appearance plug and manually (inserting the files into the ~/.config/plank/theme folder), but the theme won't change.

I believe this first happened when I installed the new desktop plug, but removing that plug wont help either.

Kathen Brewster (booiscute) wrote :

Do you know how I can get the files to insert them manually? I don't even have the new Appearance plug so I don't know if that would be the problem.

zeeeeee (miesogeno) wrote :

I got them by fetching the bzr in launchpad.

but if you don't know how to do that, you have a lot of plank themes in deviant art: http://browse.deviantart.com/?order=9&q=plank+theme&offset=24

but has I said, that's also not working for me.

Kathen Brewster (booiscute) wrote :

I tried to manually install one of those themes from dA, but no effect. So there probably is a bug somewhere. I don't have the new appearance plug in switchboard so I can't confirm if that has anything to do with it.

Robert Dyer (psybers) wrote :

That theme is not part of Plank. Plank does not provide a Switchboard plugin. There is nothing we can do about that. The people providing the theme or the people providing the Switchboard plugin have to figure out what they are doing wrong.

Changed in plank:
status: New → Incomplete
status: Incomplete → Invalid
zeeeeee (miesogeno) wrote :

But doesn't plank support theme changing by switching the theme files in the specified folder? Maybe I got it wrong.
Even without the switchboard plugin installed I'm not able to change the theme manually, not just that particular theme, any theme, except the default one.

Kathen Brewster (booiscute) wrote :

Yeah it's not Switchboard that appears to be the problem because manually changing the theme files just has no effect on Plank.

Kathen Brewster (booiscute) wrote :

I managed to find a temporary workaround since nothing else was doing anything.

Download the bzr and instead of just copying the theme files into the plank directory, open up those files and copy and paste the content inside them directly over to the existing files. The theme should then update when you save it. For some reason just swapping out the files has no effect but you can still change the content within them.

zeeeeee (miesogeno) wrote :

that's not a temporary workaround, that's a full workaround :)
I don't get it either, but it worked here too, thank you.

Mark Castle (mark-c-f) wrote :

When copy-pasting the content from the new theme files I had to make sure I didn't copy-paste the section headings [PlankDrawingTheme], [PlankDrawingDockTheme] and [PlankDrawingTheme], otherwise an overwrite would be triggered upon saving.

Savannah King Norton (sln45) wrote :

There is an official switchboard plugin for plank's theme and it is not functioning correctly.

Changed in plank:
status: Invalid → Confirmed
Robert Dyer (psybers) wrote :

I'm going to say this once more: the Switchboard plugin is *NOT* provided by or supported by Plank or Plank's developers.

Savannah King Norton (sln45) wrote :

How have we downloaded it from Elementary's PPA if it is unofficial? Are plank's developers NOT working with ElementaryOS?

Robert Dyer (psybers) wrote :

Officially, that is correct. Plank is not an Elementary project.

Savannah King Norton (sln45) wrote :

I see. Then we've reported this bug in the wrong place.

Changed in plank:
status: Confirmed → Invalid
Vistaus (djmusic121) wrote :

I can confirm this bug.

Changed in plank:
status: Invalid → Confirmed
Changed in elementaryos:
status: New → Invalid
Savannah King Norton (sln45) wrote :

I tried to report this to plank's page and the guy marked it as a duplicate of THIS bug even though elementary isn't involved in the project. In any case, nothing is broken. The themes themselves are broken. In /usr/share/plank/themes, check the themes you have added. Their .theme files use [titles] that end in "renderer," but the current plank no longer recognizes them so it always reverts back to the default.

Delete "renderer" from all [titles] and then manually change the theme. That should work.

Changed in plank:
status: Confirmed → Invalid
Robert Dyer (psybers) wrote :

Fixed (for Plank's shipped themes) in trunk rev 693.

Changed in plank:
status: Invalid → Fix Released
importance: Undecided → Low
assignee: nobody → Robert Dyer (psybers)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers