Media keys aren't working (Ubuntu 11.10, Pithos latest daily)

Bug #902322 reported by RJP Computing on 2011-12-09
24
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Pithos
Fix Released
Medium
Kevin Mehall
pithos (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

Not sure if you have seen this, but the Play/Pause media key does not work anymore for Pithos.

It seems the solution is to call GrabMediaPlayerKeys method. I am only summarizing what others have said, but really miss this feature and hope it is easy for you to fix.

References:
https://bugs.launchpad.net/gnome-settings-daemon/+bug/860600

https://bugzilla.gnome.org/show_bug.cgi?id=660549#c4

https://bugzilla.gnome.org/show_bug.cgi?id=660706#c4

Thanks for such a great application.

Kevin Mehall (kevin-mehall) wrote :

Thanks for pointing me to those posts. Several other users have reported this, but I didn't have a chance to look into it.

Can you test bzr r177 and see if it solves this problem?

Quit Pithos, then in a terminal,
bzr branch lp:pithos pithos
cd pithos
./bin/pithos

Changed in pithos:
status: New → Fix Committed
importance: Undecided → Medium
assignee: nobody → Kevin Mehall (kevin-mehall)
RJP Computing (rpusztai) wrote :

I tried your changes and they worked great. Can't wait for a release.

Again thanks for being so prompt and for such a great application.

JC Hulce (soaringsky) wrote :

This has now been released in 0.3.14

Changed in pithos:
status: Fix Committed → Fix Released
Luke Faraone (lfaraone) on 2012-01-08
Changed in pithos (Ubuntu):
status: New → Fix Released

Hello RJP, or anyone else affected,

Accepted pithos into oneiric-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in pithos (Ubuntu Oneiric):
status: New → Fix Committed
tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pithos - 0.3.10-1ubuntu3

---------------
pithos (0.3.10-1ubuntu3) oneiric-proposed; urgency=low

  * Sync clock to avoid "You have no chance to survive make your time"
    error from Pandora on start (LP: #743198)
  * Fix media key support, broken in Oneiric (LP: #902322)
 -- Luke Faraone <email address hidden> Sun, 08 Jan 2012 16:13:45 -0500

Changed in pithos (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers