Media keys aren't working (Ubuntu 11.10, Pithos latest daily)

Bug #860600 reported by Kyle Spraggs on 2011-09-27
182
This bug affects 34 people
Affects Status Importance Assigned to Milestone
GNOME Settings Daemon
New
Undecided
Unassigned
gnome-settings-daemon (Ubuntu)
Low
Unassigned
Oneiric
Undecided
Unassigned
guayadeque (Debian)
Fix Released
Unknown
guayadeque (Ubuntu)
Medium
Alessio Treglia
Oneiric
Undecided
Unassigned

Bug Description

When I press a media key a circle with a diagonal line appears instead of the standard play/pause/next, etc. Using the DBUS API directly does work.

I have a Logitech G110 keyboard, Ubuntu 11.10, and I'm using the latest Pithos from the daily.

Related branches

bongo (bong0) wrote :

The same issue occurs with my thinkpad media keys; there are reports posted in the gnome bugzilla discussing that issue.
https://bugzilla.gnome.org/show_bug.cgi?id=660549
https://bugzilla.gnome.org/show_bug.cgi?id=660706

schlypel (schlypel) wrote :

Same issue also on DELL Notebook Vostro 3500, mm keys generate onscreen sign "crossed circle".
Trying to assign key by keypress in clementine player global shortcut doesnt work nether, no reaction there.

Taras Martyniuk (tarabopm) wrote :

Same issue with keyboard A4TECH KL-7MU

RJP Computing (rpusztai) wrote :

Same issue with a Microsoft Natural Ergonomic Keyboard 4000

bongo (bong0) wrote :

Please don't post further comments regarding the keyboard used, It's an issue regarding the API communication as far as I understood.

Gerard (dmglouis) wrote :

On a Dell XPS 15 L502x, am encountering same problems with Pithos (circle with diagonal line appearing)

evilgeniuz (masta-vivi) wrote :

Same issue for vaio vgn-sr19vrn.

thomas (thomas-heuer) wrote :

This bug does not only affect Pithos, but any media-player within Unity under Ubuntu 11.10 (using LightDM, didn't try GDM)

affects: pithos → unity
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Kyle Spraggs (kyle-spraggs) wrote :

It should be noted that this affects gnome shell as well.

Gerard (dmglouis) wrote :

Should note a very curious behaviour:

When I pause Pithos (using the soundmenu), and I play Banshee, the Play/Pause media button works.
That is, with the first press, Banshee pauses and Pithos plays, and then with the second press, Pithos pauses and Banshee plays.

If I hit skip track when Banshee is playing and Pithos is paused, both skip and start playing at the same time.

Godzemo (godzemo) wrote :

Same issue with DELL Vostro 1500, Amarok 2.4.3

Leman (leman-kg) wrote :

I noticed that it's somehow connected to the totem player. When running totem media keys work fine for any multimedia players.

Rich (rodhull) wrote :

Same for me with spotify-client-qt under 11.10 64-bit and standard Ubuntu (Unity) session - big "no entry" symbol when the key-combo assigned to play/pause is pressed.

Maxim Hansen (maxim-hansen) wrote :

Can confirm this issue on Ubuntu 11.10, using Unity session.

This affects both my USB keyboard (Dell OEM), and my media keys on the ThinkPad T410s.

Using "sudo showkey", I can see that the OS detects keycode 165,164,163 and 166 (rewind, play/pause, forward, stop) on both the keyboards, but a big "Ø" shows up on the screen when pressed.

Mute and volume buttons work as expected.

Hope a fix can be released soon! :)

Balage (regenyi-balazs) wrote :

@Gerard I have the same case, but only with RadioTray. I hope a fix will be soon.

affects: unity (Ubuntu) → gnome-settings-daemon (Ubuntu)
Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Low
affects: unity → gnome-settings-daemon
timothymowens (timothymowens) wrote :

I installed the proposed fix for gnome-settings-daemon, but I still have this issue. Or is this going to be part of a newer build of the Gnome Settings Daemon?

Daniel Centore (dcentore) wrote :

Workaround: Run totem and minimize it. You're media keys will then work.
However, hopefully this will be fixed soon. I consider the priority much higher than low. The media keys are the main reason behind performance to use this client as opposed to the official one.

Caleb Molstad (cmolstad) wrote :

Same problem here. Keys work when Banshee is open but that means it plays alongside Pithos.

Josh Mckibbin (joshmckibbin) wrote :

The problem persists. Daniel's solution works for now. Has anyone tried uninstalling Totem or will that just totally break it?

edjash (edjash) wrote :

Same problem here with Microsoft Comfort Curve 2000. Media player is VLC (not tested with others) and set as default application for music. The volume and mute keys work, the Play/Pause key does not work and brings up the big circle as reported.

Kapil Koju (thekojueffect) wrote :

Same problem with HP pavilion g6 - 1037tx

Changed in guayadeque (Ubuntu):
assignee: nobody → Alessio Treglia (quadrispro)
importance: Undecided → Medium
status: New → In Progress

The attachment "upstream revision 1660 fixing the bug" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Changed in guayadeque (Debian):
status: Unknown → Fix Released
Alessio Treglia (quadrispro) wrote :

This bug was fixed in the package guayadeque - 0.3.1~dfsg0-2

---------------
guayadeque (0.3.1~dfsg0-2) unstable; urgency=low

  * Make multimedia keys work on GNOME 3; thanks to Damyan Ivanov for
    the report. (Closes: #655561) (LP: #860600)

 -- Alessio Treglia <email address hidden> Thu, 12 Jan 2012 12:23:58 +0100

Changed in guayadeque (Ubuntu):
status: In Progress → Fix Released

WTF is going on 31 people affected priority LOW?
Is this another windows like approach of Ubuntu/Gnome to promote their
fucked up applications like totem and banshee. Okay totem is not that bad
but banshee you just cannot tell me anyone is using this!
Get it fixed or tell me how to fix it where do i have to look?

Damyan Ivanov (dmn-debian) wrote :

Please see comment #26. There is no conspiracy :)

Perhaps the package needs an update in the stable Ubuntu releases and needs to be detached from gnome-settings-daemon, but I don't know how to achieve any of these.

James Brady (praetervictum) wrote :

I'm a bit confused at the "resolution." Do I need to install that Guayadeque package, even though I don't currently use that player (using Clementine), or is the fix going to be rolled into an update at some point?

Alessio Treglia (quadrispro) wrote :

Debdiff attached.

Changed in guayadeque (Ubuntu Oneiric):
status: New → Fix Released
Changed in gnome-settings-daemon (Ubuntu Oneiric):
status: New → Fix Released
Boris Baelen (sjimmie) wrote :

Can someone please tell me in which version of gnome-settings-daemon this is fixed? I'm running 3.2.2-0ubuntu2 and still have the problem

Pink Ink (pink-ink) wrote :

Not solved for me.
I'm on Ubuntu 11.10, 64 bit.
I'm running gnome-settings-daemon 3.2.2-0ubuntu2 like Boris and guayadeque 0.3.1~dfsg0-1.
I'm using Clementine as my music player.

I've installed all the latest updates and some media keys are still not working with my "home digital wireless rf" keyboard.
(volume up/down works, but play/pause/stop/skip back/skip forward don't work only showing the circle sign, the crossed out O).

The workaround with auto-starting the totem player is pretty annoying, because it cannot be configured to start minimized.
And when it starts, the window opens to high, that only one pixel of the title bar is visible. I then have to drag it down to reach the minimize-button. Very poor user experience in my eyes.

Oli Lane (olil4ne) wrote :

I'm getting this issue. Ubuntu 13.04, 64 bit, using Spotify.

Media controls work in the dropdown when you click the audio icon in the top bar, but pressing the media keys on my Logitech G510 shows the circle sign and does nothing.

Volume and mute work fine.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.