Gstreamer encountered a general stream error

Bug #759699 reported by Victor Costan on 2011-04-13
56
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Pithos
Fix Released
High
Luke Faraone
pithos (Ubuntu)
Medium
Unassigned
Natty
Medium
Luke Faraone

Bug Description

== SRU INFORMATION ==

What happens:
 Pithos will display a "Gstreamer encountered a general stream error" dialog towards the end of songs, usually occuring on the 2nd or 3rd song in a playlist, but seemingly randomly.

This makes pithos difficult to use; you have to switch to another station to recover, and loses the current playlist.

What should happen:
 Songs should play without errors.

Pithos is a low-impact application, it has no rev-depends.

This is being SRUed in bug 771804.

=== Minimal patch ===

diff -Nru pithos-0.3.8/bin/pithos pithos-0.3.9/bin/pithos
--- pithos-0.3.8/bin/pithos 2011-04-12 20:17:06.000000000 -0400
+++ pithos-0.3.9/bin/pithos 2011-04-27 16:25:29.000000000 -0400
@@ -190,7 +190,7 @@
         self.stations_model = gtk.ListStore(gobject.TYPE_PYOBJECT, str)

         self.player = gst.element_factory_make("playbin2", "player")
- #self.player.props.flags |= (1 << 7) # enable progressive download
+ self.player.props.flags |= (1 << 7) # enable progressive download (GST_PLAY_FLAG_DOWNLOAD)
         bus = self.player.get_bus()
         bus.add_signal_watch()
         bus.connect("message", self.on_message)

== END SRU INFORMATION ==

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: pithos 0.3.7-2ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: wl nvidia
Architecture: amd64
Date: Wed Apr 13 07:34:22 2011
ExecutablePath: /usr/bin/pithos
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: pithos
UpgradeStatus: Upgraded to natty on 2011-04-12 (0 days ago)

Victor Costan (costan) wrote :
Luke Faraone (lfaraone) wrote :

Does this occur all the time, or only at the end of songs?

I'm experiencing the same issue, but it only happens after playing a few songs.

Changed in pithos (Ubuntu):
importance: Undecided → Medium
Victor Costan (costan) wrote :

I had it happen at the very beginning of a song as well.

I completely agree on your second point: it only happens after a few songs. Restarting the app eliminates the problem... for a while.

steubens (steubens) wrote :

i reported a dup; but this happens under no special output device circumstance, it just happens, i'll see about running it with GST_DEBUG in a bit and add my findings

Bluelake3 (aserna3) wrote :

I am getting this bug as well. When the bug happens the song skips about a second ahead but continues playing without an issue. However after awhile songs will just refuse to keep playing and I have to restart the program.

I run a Pandora One account, and am using Ubuntu Natty Beta 2.

gdonwallace (gregoryw-minokc) wrote :

I just downloaded Pithos, I listen to Pandora quite a lot so I really appreciate this program.

However; I am having this same issue. After playing a few songs, I get a pop up in Ubuntu 11.04 with this same error. I click retry and Pithos will play the next couple songs, then I see a message next to the song timer, after the song has stopped that is the same error.

Oddity: When I closed down Pithos and attempted to restart it (Closing using the Icon on the panel), it rebooted my desktop and I had to login again.

Changed in pithos:
status: New → Fix Released
importance: Undecided → High
gdonwallace (gregoryw-minokc) wrote :

Seems that whatever was done Pithos is working fine.

Thanks for getting this fixed.

Luke Faraone (lfaraone) on 2011-04-28
Changed in pithos (Ubuntu Natty):
status: New → Fix Committed
importance: Undecided → Medium
assignee: nobody → Luke Faraone (lfaraone)
Changed in pithos:
assignee: nobody → Luke Faraone (lfaraone)
Changed in pithos (Ubuntu):
status: New → Triaged
Luke Faraone (lfaraone) on 2011-04-29
description: updated
Victor Costan (costan) wrote :

Thank you!

Accepted pithos into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Johntash (johntash) wrote :

The above patches worked, and I can confirm the pithos package in natty-proposed is working for me as well. Thanks :)

tags: added: verification-done
removed: verification-needed
Victor Costan (costan) wrote :

I haven't encountered anymore Gstreamer errors after switching to the new version. Thank you very much!

mancubus220 (mancubus220) wrote :

Works for me as well on 11.04. No errors after running for over an hour :D

dino99 (9d9) wrote :
Changed in pithos (Ubuntu Natty):
status: Fix Committed → Invalid
Changed in pithos (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers