complains about "Too many gstreamer errors. Not retrying" - halts playback

Bug #705271 reported by Andre on 2011-01-20
62
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Pithos
Fix Released
High
Unassigned
Mandriva
New
Undecided
Unassigned

Bug Description

Problem: After about 2 sets, Pithos stops playback and pops up with message box saying "GStreamer encountered a general stream error.". Gives option to retry, among others. Retry often will start playback again, but not always.

Steps to reproduce:
1. run "pithos --verbose" from cli
2. After each song ends, a gstreamer error occurs, but playback continues. Sometimes cuts song short. error as follows:

"ERROR - pithos:on_message:520 - Gstreamer error: GStreamer encountered a general stream error., gstqueue2.c(2348): gst_queue2_loop (): /GstPlayBin2:player/GstURIDecodeBin:uridecodebin3/GstQueue2:queue23:
streaming task paused, reason error (-5)"

3. After approx 6 songs, pithos pops up with an error box stating "GStreamer encountered a general stream error." with the option to "Cancel" "Retry" or "Preferences". Cli states error as follows:

"WARNING - pithos:get_playlist:435 - Too many gstreamer errors. Not retrying"

3.1 hitting cancel closes the box and starts playing
3.2 hitting retry closes box and starts playing
3.3 preferences opens basic pithos preferences, which has nothing helpful regarding this issue
4. continually repeats steps 2-3, until pithos stops playing altogether, with a msg on song display stating that ""GStreamer encountered a general stream error." Cli states same error as step 2, but this time does not continue playing.
5. Changing stations after step 4 causes msg box from step 3 to appear, but now cancel and retry do nothing.
6. After changing stations again, playback will resume, presumably to repeat steps 2-6 indefinitely.

Expected result: pithos to play indefinitely without gstreamer errors.

Have tried:
1. reinstalling pithos and gstreamer, though not sure if config files have been/need to be removed as well, nor where they are located to remove them.
2. rebooting machine
3. installed pithos on another machine and does not encounter this issue at all. stats of both machines listed below.
4. Was able to repeat issue through step 6 above in less than 1 hour.

Machine Stats:
Desktop - Ubuntu 10.04 32-bit, GNOME and Compiz, AMD Athlon(tm) 64 Processor 3400+, 1.5 gb ram, SB Audigy soundcard, also has onboard audio but not used, **this is the machine having the issue
Laptop - Xubuntu 10.04, Openbox WM, Intel P4, ~256 ram, onboard audio **does not have any gstreamer errors

Right before I submitted this bug, i also realized that I had uninstalled pulseaudio from the laptop, which makes me think this is a pulseaudio issue, since it is installed on the desktop.

Andre (g33kdot-life) wrote :
SorryGoFish (geoff-oxholm) wrote :

I have the same error. pianobar works, but Pithos does not. I'm running KDE on Ubuntu 10.10.

Changed in pithos:
status: New → Confirmed

Same thing happens with me on 0.3.5 installed from source

Seems that now Pithos doesn't want to connect for me at all. Don't know what
to think about this, as it's not my firewalling since I can still pull it up
thru the browser.... Anyway, more packet sniffing and more to tell at a
later date when I have enough info to open another bug, if needed.

Matt

On Tue, Mar 1, 2011 at 14:16, Spencer Kingsbury
<email address hidden>wrote:

> Same thing happens with me on 0.3.5 installed from source
>
> ** Also affects: mandriva
> Importance: Undecided
> Status: New
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (723479).
> https://bugs.launchpad.net/bugs/705271
>
> Title:
> complains about "Too many gstreamer errors. Not retrying" - halts
> playback
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/pithos/+bug/705271/+subscribe
>

Andre (g33kdot-life) wrote :

I just wanted to update with some new info. might give someone another starting point.

The laptop I listed in the bug is replaced and now has a custom/slim ubuntu Maverick install, again without pulseaudio. I recently removed pulseaudio on my desktop, which is Lucid, and am still having the same issue. seems to theoretically rule out a difference in the default Lucid vs Maverick installs.

my elementary thoughts are that maybe something is conflicting with gstreamer in the full (K)Ubuntu installs that isn't present when building off a minimal install. I could dump the packages from my laptop vs desktop on here...maybe SorryGoFish could do the same? would this be useful information in solving this?

Alexey A Nikitin (moonwalker) wrote :

Using Debian Wheezy x64 + PulseAudio, same behaviour - plays two sets, at the end of each track shows GStreamer error, at the end of second set shows GStreamer error dialog box and doesn't play further.

DigitalPig (lizhenqing-fudan) wrote :

Yes. I can confirm that the same bug exists under Ubuntu Natty. It shows the GStream error at every end of the music. I can also confirm that Pianobar works fine.

I can provide more info if needed.

I can confirm it, of course on x86_64 as well.

Johntash (johntash) wrote :

I can confirm it on a fresh install of Natty 11.04 as well. pithos 0.3.7-2ubuntu1 and libgstreamer0.10-0 0.10.32-3ubuntu3
Pithos worked fine on 10.10 for me on the same machine, thought I reinstalled with x86_64 instead of it may be an issue with the 64bit versions?

Andre (g33kdot-life) wrote :

I highly doubt it is only a problem with the 64bit versions. especially since most people here -seem- to be using x86 versions, including myself.

I recently removed pulseaudio on my Desktop from the original bug post, but didn't think to test Pithos before i reinstalled it since I had too many issues with just OSS4. When I get a chance, i will try Pithos again on the desktop, since pulseaudio and gstreamer were reinstalled with clean configs.

jose soa (josefsoares) wrote :

Temporary workaround (patch)

This does not solve the gstreamer errors, but it does remove the error dialog (which stops the stream)

locate pithos
$ which pithos
/usr/bin/pithos

apply the patch

The patch comments out 2 lines in pithos:
* line 524, the error message being shown on the song after song has finished
* line 526, the error counter which will causes the error dialog to show up after too many errors are encounter and stop playback

jose soa (josefsoares) wrote :

To add, these "general" gstreamer errors don't seem to effect the stream of the music.

In my tests (with patch) I didnt encounter any issues with the stream stopping, after about 2 hours of continuous play

Jeff Hatfield (hatfield-jeff) wrote :

Jose - could you give any more details about how to "apply the patch" for us non-programmer types? Thanks :-)

jose soa (josefsoares) wrote :

locate pithos

$ which pithos
/usr/bin/pithos

$ cd /usr/bin/

$ patch pithos < /path/to/pithos.patch

Bluelake3 (aserna3) wrote :

I am getting this bug too. I will try the patch.

Changed in pithos:
importance: Undecided → High
Bluelake3 (aserna3) wrote :

Patch works! I can tell gstreamer is still going screwy every now and then because every few songs the audio will skip for a second but that's fine for me because all errors are suppressed and the stream doesn't halt.

Kevin Mehall (kevin-mehall) wrote :

I can confirm this on Ubuntu 11.04 beta 2 in VirtualBox.

The patch above is not recommended. Because Pithos handles errors by skipping to the next song, that check is necessary to prevent a persistent gstreamer error from going out of control. Without that check, if gstreamer fails immediately when a song is started, it keeps loading playlists until Pandora bans your IP address. Instead, I'm looking for a solution to the "General stream error" issue.

If you are willing to patch Pithos, you can try enabling progressive streaming mode, by removing the first # of line 190 to uncomment it in /usr/bin/pithos (installed), or bin/pithos (from bzr or a tarball):

self.player.props.flags |= (1 << 7) # enable progressive download

This seems to work around the issue in my tests, but I'm not exactly sure why.

Post whether this (a) solves the problem, and (b) does not cause any adverse effects, such as making it slower to buffer songs.

jose soa (josefsoares) wrote :

Tested your solution Kevin on Ubuntu 11.04, seems to solve the gstreamer errors, Ive had no other issues yet.

On a side note, I noticed, (at least according to the song timer), was that before, the gstreamer errors were occurring with about 2 seconds left on the song. Now with the progressive download enabled, the song timers reach the end, as well as the "End of Stream" being reached (which wasn't being reached before)

gdonwallace (gregoryw-minokc) wrote :

I am having this same issue, will try the recommended "patch" to see if it works for me.

I've also tried the so-called patch. But I do think Kevin is right in
that this can and should be considered a hack so I am going to run it
until a proper fix has been implemented. I still don't think that even
though the issue is solved for now, through this hack that the bug
should be closed out as fixed.

Matt

On Tue, 2011-04-26 at 15:27 +0000, gdonwallace wrote:
> I am having this same issue, will try the recommended "patch" to see if
> it works for me.
>

Bluelake3 (aserna3) wrote :

Oh, I was not aware that's what the patch did. I will try your suggestion tomorrow Kevin. Thank you.

Changed in pithos:
status: Confirmed → Fix Released

Accepted pithos into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Luke Faraone (lfaraone) on 2011-05-01
tags: added: verification-done
removed: verification-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers