"You have no chance to survive make your time" error

Reported by Spencer Kingsbury on 2011-03-26
304
This bug affects 56 people
Affects Status Importance Assigned to Milestone
Pithos
Fix Released
Critical
Unassigned
pithos (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned
Oneiric
Critical
Bartosz Kosiorek

Bug Description

== SRU INFORMATION ==

Pandora changed their API, so here we provide an update to accommodate time synchronisation bugs.

This update also fixes LP #902322 , an issue with media keys handling on oneiric.

This is low-impact to other apps, because pithos have no rev-depends.

=== pithos (gtk) ===
The API was fixed, and we included a pointer to the upstream maintainer's site for the error dialogue in future instances of breakage.

What happens:
On login, "You have no chance to survive make your time"

What should happen:
You are logged in and a station loaded. You should also be able to use the media keys to skip to future songs, as well as to pause/play.

Ideally, test with your Pandora.com account.

== END SRU INFORMATION ==

Hi. Pithos was working yesterday, but for some reason today when I start it up it gives me a dialog which says: "you have no chance to survive make your time" and has cancel, retry, and preferences button. If I click cancel it will bring me to the Pithos main window, but there will be no songs displayed and no stations to choose from. If I then try to re-enter my Pandora login information, it will accept it but still display no stations or songs. I am very confused :-/. I run 64-bit OpenSuse 11.4, and Pithos 0.3.7.

----UPDATE---- So just to sum this up, this bug usually is from your software clock not matching up to the Pandora clock. The easiest fix is use ntpd to sync your clock. You can find instructions for that all over the web. If that doesn't work, try some other method of syncing your clock. There is also a patch posted below which you can try.

Kevin Mehall (kevin-mehall) wrote :

That string is not in the Pithos source code, nor any of it's libraries, so it must come from Pandora. Pithos still works for me, so Pandora hasn't blocked it.

Several Pandora error strings are really odd, so it must just be an error that I've never seen before.

Can you run pithos --verbose in a terminal and send me the output?

Kevin Mehall (kevin-mehall) wrote :

This error has been seen by pianobar users and may be a more pun-filled version of the Out Of Sync error. Make sure your computer's clock is set correctly.

Hi. I think you were right about the clock being out of sync. I told my computer (KDE) to synchronize time with an external server, and the error has now gone away. Thanks!

Changed in pithos:
status: New → Invalid
Liz Fong-Jones (lizthegrey) wrote :

I just saw this while attempting to fetch the next 4 entries in the playlist. My time is synced, so that can't be the cause. Playback continues, but stops after the end of the playlist has been reached. Re-launching displays the same error.

Changed in pithos:
status: Invalid → New
Liz Fong-Jones (lizthegrey) wrote :

My Pandora One subscription isn't out of date [it's up for renewal in March], my login still works on the web version of Pandora's site. Hrm.

Reed Loden (reed) wrote :

Yep, seeing this, too.

Liz Fong-Jones (lizthegrey) wrote :

pelizabeth@violet:~$ pithos --verbose
INFO - pithos:<module>:796 - Pithos 0.3.13
/usr/bin/pithos:773: GtkWarning: Ignoring the separator setting
  builder.add_from_file(ui_filename)
INFO - plugin:enable:36 - Enabling module mediakeys
INFO - mediakeys:bind_dbus:30 - Bound media keys with DBUS
INFO - plugin:enable:36 - Enabling module notify
ERROR - pandora:xmlrpc_call:129 - fault: com.savagebeast.radio.api.protocol.xmlrpc.RadioXmlRpcException: 192.168.160.249|1323820334980|OUT_OF_SYNC|You have no chance to survive make your time.

(and I triple-checked - I do have ntpd running, so it's definitely not that I'm out of sync).

Liz Fong-Jones (lizthegrey) wrote :

Retrying a few times seems to have gotten me back on. I'm going to blame Pandora for this one.

Aaron Wright (wrighta987) wrote :

I just started seeing this exact problem about 10 minutes ago. Judging by the times that other comments have been posted, I think something is up with either Pandora or Pithos.

N (nob) wrote :

せいぜい残り少ない命を、大切にしたまえ・・・
You have no chance to survive make your time.
Treasure what little time remains of your lives.

http://en.wikipedia.org/wiki/All_your_base_are_belong_to_us#Selected_transcript

Anyway, I'm encountering the problem as well, and it doesn't seem to go away on retry or restart.

I too am experiencing this error.
At first it seemed to go away when I disabled scrobbling, but that no longer does the trick.
This is whole thing is very curious!

David Sempsrott (dsempsro) wrote :

Considering it just happened all of a sudden to a lot of people (me included), I'm positive it has to be something from Pandora. I suspect it has something to do with the recent Pandora updates. I don't think it's just a problem with their servers, because I can still login through the web interface and play music.

Aaron Wright (wrighta987) wrote :

Update: I sent @pandora_radio a link to this thread via Twitter. Maybe they can forward it to their support team.

Has anybody tried a different Pandora app? Maybe that could tell us if its Pithos or the Pandora API that is at fault.

It happens to Android clients Pandoroid and Doom Box (largely Java translated from Pithos' Python) as well. This evening, as of a few hours ago, Pithos worked without issue, and then I started getting this message. Hitting "retry" worked after you got sent to another backend server, for a while. Now it doesn't work at all, it just comes back up after you hit "retry".

It is worth pointing out that Pianobar still works and in fact pushed out a new release a few days ago, so maybe they figured out / noticed something no one else did?

Kevin Mehall (kevin-mehall) wrote :

There's something interesting going on right now on Pandora's end. They recently changed the login API and seem to be in the process of phasing out the old one. I have information on a workaround and will modify Pithos to support it if this is related. Since it's intermittent, I'm waiting to see if it will go back or if there could be further changes.

Fun fact: Pithos 0.3.13 finally has a more helpful error message for the protocol version bumps/key changes that normally break Pithos. But that's not how Pandora chose to break it this time. At least this message is easy to google...

murrayv (murray) wrote :

It is an interesting message, at least. Several of us ended up here. So something is going on and Pithos is not generating that text. Must be Pandora. They will get it worked out. The air app is working fine. The message sounds like it is directed at an attacker. They are probably messing with security settings.

Changed in pithos:
status: New → Confirmed
importance: Undecided → Critical
status: Confirmed → In Progress

@Kevin Adam's method (using "misc.sync" from Pianobar) works fine, and is very easy to implement. I believe he CC'd you with the solution.

Terrence Bruff (tbruff13) wrote :

This has happened to me as well. I am kind of confused on this error because I did get it once before when my system time was set incorrectly, but I know my time is right, so what did I do wrong this time.

Terrence Bruff (tbruff13) wrote :

This bug affect Ubuntu and Linux Mint running pithos

Amen. Same problem. If only I could think of something I could do to help, I would offer!

I just settled down to work, and I always play Pandora to keep me sane when I stay up all night writing code. I guess me and Kevin both could be in for a tedious night. :) Isn't it scary how many people in the world have the power to ruin your evening with just one little change or mistake? haha.

I'll check back here periodically to see if it's fixed on Pithos' end, and keep trying to log in from my computer to see if it's fixed on Pandora's end.

-Chris

Changed in ubuntu:
status: New → Confirmed
Luke Faraone (lfaraone) on 2011-12-14
affects: ubuntu → pithos (Ubuntu)
vdude (thevpuli) wrote :

I've been pulling an all-nighter tonight, writing a report for my code. I switched to my LMDE installation and started Pithos, and freaked out when I saw that message... seriously, it's like a death threat >.<

Anyways, I really wish I could help with the progression of Pithos somehow. I'm open to being a guinea pig?

Tony Maro (tonymaro) wrote :

@vdude: Just type in "Take off every ZIG" and all will be well, bomb threat averted.

Seriously though, affects the PPA for Pithos as well, but unlike someone above saying the Android app was affected, the official app seems to still work fine on Android devices without an update. Obviously just Pandora targeting those of us using unauthorized players.

jro (jaredo) wrote :

It's possible people were able to keep retrying at one point if Pandora hadn't yet pushed their update to all servers. I've been spamming retry and unable to get through, also verified time was synced. Worked fine yesterday:

** Message: pygobject_register_sinkfunc is deprecated (GstObject)
INFO - pithos:<module>:796 - Pithos 0.3.13
./pithos:773: GtkWarning: Ignoring the separator setting
  builder.add_from_file(ui_filename)
INFO - plugin:enable:36 - Enabling module notify
INFO - plugin:enable:36 - Enabling module mediakeys
INFO - mediakeys:bind_dbus:31 - Bound media keys with DBUS
ERROR - pandora:xmlrpc_call:129 - fault: com.savagebeast.radio.api.protocol.xmlrpc.RadioXmlRpcException: 192.168.161.222|1323872357287|OUT_OF_SYNC|You have no chance to survive make your time.
INFO - pithos:error_dialog:495 - Manual retry
ERROR - pandora:xmlrpc_call:129 - fault: com.savagebeast.radio.api.protocol.xmlrpc.RadioXmlRpcException: 192.168.160.92|1323872365076|OUT_OF_SYNC|You have no chance to survive make your time.
INFO - pithos:error_dialog:495 - Manual retry
ERROR - pandora:xmlrpc_call:129 - fault: com.savagebeast.radio.api.protocol.xmlrpc.RadioXmlRpcException: 192.168.160.197|1323872365871|OUT_OF_SYNC|You have no chance to survive make your time.
INFO - pithos:error_dialog:495 - Manual retry
ERROR - pandora:xmlrpc_call:129 - fault: com.savagebeast.radio.api.protocol.xmlrpc.RadioXmlRpcException: 192.168.161.172|1323872366640|OUT_OF_SYNC|You have no chance to survive make your time.
INFO - pithos:error_dialog:495 - Manual retry
ERROR - pandora:xmlrpc_call:129 - fault: com.savagebeast.radio.api.protocol.xmlrpc.RadioXmlRpcException: 192.168.161.216|1323872367374|OUT_OF_SYNC|You have no chance to survive make your time.
INFO - pithos:error_dialog:495 - Manual retry
ERROR - pandora:xmlrpc_call:129 - fault: com.savagebeast.radio.api.protocol.xmlrpc.RadioXmlRpcException: 192.168.162.62|1323872368237|OUT_OF_SYNC|You have no chance to survive make your time.
INFO - pithos:error_dialog:495 - Manual retry
ERROR - pandora:xmlrpc_call:129 - fault: com.savagebeast.radio.api.protocol.xmlrpc.RadioXmlRpcException: 192.168.162.35|1323872368956|OUT_OF_SYNC|You have no chance to survive make your time.
INFO - pithos:error_dialog:495 - Manual retry
ERROR - pandora:xmlrpc_call:129 - fault: com.savagebeast.radio.api.protocol.xmlrpc.RadioXmlRpcException: 192.168.160.253|1323872369728|OUT_OF_SYNC|You have no chance to survive make your time.
INFO - pithos:error_dialog:495 - Manual retry
ERROR - pandora:xmlrpc_call:129 - fault: com.savagebeast.radio.api.protocol.xmlrpc.RadioXmlRpcException: 192.168.161.24|1323872370388|OUT_OF_SYNC|You have no chance to survive make your time.
INFO - pithos:error_dialog:495 - Manual retry
ERROR - pandora:xmlrpc_call:129 - fault: com.savagebeast.radio.api.protocol.xmlrpc.RadioXmlRpcException: 192.168.160.182|1323872371184|OUT_OF_SYNC|You have no chance to survive make your time.

jro (jaredo) wrote :

Fedora 16

Carl Leighton (crleighton88) wrote :

"All your base are belong to us..." that is not cool. This bug affects Linux Mint 12 as well. I get the same log output as above.

Chuck Smith (ccsmith) wrote :

I am having the same problem here too, but on a whim I downloaded pianobar source (dated 11.11) and it works. I would only hope the changes are implemented into Pithos soon....

Reed Loden (reed) wrote :

Well, if Pandora's desktop AIR app didn't suck so much, we wouldn't be forced to use alternative clients. :)

Chuck Smith (ccsmith) wrote :

True Reed but that is moot point now being Adobe stopped developing AIR for Linux on June 11,2011.
http://kb2.adobe.com/cps/521/cpsid_52132.html

Just as an FYI I downloaded and installed Pianobar (PromyLOPh-pianobar-2011.12.11-1) and it is still successfully working through the command line every time. Even with the updated Pianobar, Pithos still throws the time synch error.

Luke Scharf (lukescharf) wrote :

I'm a Pandora One subscriber, and I e-mailed <email address hidden> about this issue.

I went on at some length about how I really like both Pandora and Pithos and how I hope that they'd collaborate on a fix. The Pandora support person said that they'd go over the issue with the product team, though my guess they were probably mostly concerned with the text of the message that was displayed on a customer's screen.

Pandora seems to be quite responsive to customer-service inquiries, especially from Pandora One subscribers. I imagine that if all of the paying subscribers who have been affected by this issue were to contact <email address hidden> and tell them how much they like their 3rd party clients on Linux, Pandora might be encouraged to collaborate with the Open Source community on a fix.

As an advertising-supported service, I do understand why they might want to ban 3rd party clients for non-paying customers. But there's every reason why it's in Pandora's interest to let paying customers use the 3rd party client of their choice. And Pithos is my preferred way to access the streaming content that I paid for from Pandora.

Matt Harrison (mattharrison) wrote :

I have made a quick patch that gets this to work for me.

Some of this is not very clean and by far not the best way to do it, but it seems to work fine as far as using Pithos.

This is to be applied to pithos/pandora/pandora.py

I really don't think it's a good idea to be contacting Pandora about these issues. Their licensing agreements don't allow unlimited skips, and third party clients put them in a bad spot with the record companies. Until they release an official API we're going to have to exist on the fringe we should try to keep third party programs like Pithos off their radar as much as possible.

It seems some people aren't clear on the fact that this is a reverse-engineered client for Pandora's XML-RPC API. That API is *not* open to third-party use, from Pandora's perspective. At best they will ignore you if you contact them, at worst you may be violating their TOS and will have your account deleted.

The only way (again, from Pandora's perspective) to listen is through the Web, or through the apps published by Pandora themselves. For many of us this isn't an acceptable choice, hence the existence of projects like these. Much like AOL did 10+ years ago, from time to time they make changes that are largely designed to break programs like Pithos. So you have to deal with issues like these coming up. Welcome to the world of open source.

Matt Harrison (mattharrison) wrote :

Let me know if anyone is having issues with my patch and I'll take a look.

Chuck Smith (ccsmith) wrote :

Thanks Matt ... for those of us that are not patch savy ... how do we apply a patch? That would be helpful to us all ...

Luke Scharf (lukescharf) wrote :

I fully understand that this is a reverse engineered client, and I've been using reverse engineered open source software on my primary desktop since 1998. I know the drill, but I do thank you pointing this out for those who haven't been through it over and over again for the past 13 years or so.

But the question remains: Why make implementing a 3rd party client more difficult than it needs to be? If a bunch of paying customers invite Pandora to play ball with the Open Source community, maybe they'll show up? In my interactions with their support folks, they've been universally human and easy to deal with. Even if they eventually decline, an invitation (made through several dozen paying customers) probably wouldn't fall on deaf ears.

Matt Harrison (mattharrison) wrote :

If your on Ubuntu running this in the folder you downloaded pandora.py.patch to should do it:

sudo patch /usr/share/pyshared/pithos/pandora/pandora.py < pandora.py.patch

Anything else, just replace the pandora.py or pandora.py.patch paths.

Stephen Ostrow (isleshocky77) wrote :

Matt,
  Thanks this patch worked perfectly.

Chris,
  It depends on whether you installed from source or through a package manager; but basically track down the file pandory.py. The command I ran looked like the following.

patch -p0 pithos/pandora/pandora.py pandora.py.patch

Luke Scharf (lukescharf) wrote :

BTW, the patch above installs cleanly on /usr/share/pyshared/pithos/pandora/pandora.py on Ubuntu Oneiric Ocelot x86_64. I can now log in to Pandora and access my account, manage stations, see a playlist, and so on.

I'm not able to actually play music, though. It may be a codec problem of some sort. I was previously using the high definition MP3 stream, but I can't find the setting anymore.

Luke Scharf (lukescharf) wrote :

"I really don't think it's a good idea to be contacting Pandora about these issues. Their licensing agreements don't allow unlimited skips, and third party clients put them in a bad spot with the record companies."

If they really don't want 3rd party clients, than maybe they really don't want me to renew my subscription....

Chuck Smith (ccsmith) wrote :

Thanks Matt ... works perfectly....

VastOne (vastone) wrote :

I am running Debian and applied the patch Matt supplied and confirmed it did in fact patch correctly..

The patch did not resolve the problem for me.. Still the same error

Did a reboot and checked time / ntpd and all is functional

JC Hulce (soaringsky) wrote :

Applied Matt's patch, working for me. I have branched the pithos code and applied the patch. I have proposed this branch for merging with pithos.
https://code.launchpad.net/~soaringsky/pithos/743198
https://code.launchpad.net/~soaringsky/pithos/743198/+merge/85764

Carl Leighton (crleighton88) wrote :

OK. This works for Linux Mint 12 32bit as well. However, I had to use the following to make it patch. It didn't like anything shorter.

sudo patch -p0 /usr/share/pyshared/pithos/pandora/pandora.py /usr/share/pyshared/pithos/pandora/pandora.py.patch

Thanks Matt, I think you just saved us all a lot of work.

Sean (sedolan) wrote :

Thanks for the patch Matt! I followed your directions and loaded up Pithos, works great!

Linux 2.6.38-13-generic #52-Ubuntu SMP Tue Nov 8 16:48:07 UTC 2011 i686 i686 i386 GNU/Linux

The attachment "pithos misc.sync patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
VastOne (vastone) wrote :

I removed pithos completely .. reinstalled it

Applied patch this way as suggested

sudo patch -p0 /usr/share/pyshared/pithos/pandora/pandora.py /usr/share/pyshared/pithos/pandora/pandora.py.patch

verified the patch did install

and am still getting the same error

Running 64 bit Debian Sid

Kevin Mehall (kevin-mehall) wrote :

Fixed in bzr.

I'm testing to validate a fix for another bug that I'd like to include in this release (Media key support in 11.10, bug #902322), and will release to the PPA shortly.

Changed in pithos:
status: In Progress → Fix Committed
VastOne (vastone) wrote :

I realized my error... I had installed a bzr version a while back and had forgotten about it and was in fact patching the wrong file

I patched the correct file and used the new bzr method and all is working correctly

Kevin Godby (godbyk) wrote :

I applied the Matt's patch and reran pithos. It failed the first time, but worked the second time:

$ pithos --verbose
** Message: pygobject_register_sinkfunc is deprecated (GstObject)
INFO - pithos:<module>:796 - Pithos 0.3.13
/usr/bin/pithos:773: GtkWarning: Ignoring the separator setting
  builder.add_from_file(ui_filename)
INFO - plugin:enable:36 - Enabling module mediakeys
INFO - mediakeys:bind_dbus:30 - Bound media keys with DBUS
INFO - plugin:enable:36 - Enabling module notification_icon
INFO - plugin:enable:36 - Enabling module notify
ERROR - pandora:xmlrpc_call:134 - fault: org.apache.xmlrpc.XmlRpcException: For input string: "71310429730"
WARNING - pithos:eb:311 - Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/pithos/gobject_worker.py", line 34, in _run
    result = command(*args)
  File "/usr/lib/python2.6/dist-packages/pithos/pandora/pandora.py", line 161, in connect
    user = self.xmlrpc_call('listener.authenticateListener', [user, password], [], secure=True)
  File "/usr/lib/python2.6/dist-packages/pithos/pandora/pandora.py", line 135, in xmlrpc_call
    code, msg = fault.split('|')[2:]
ValueError: need more than 0 values to unpack

$ pithos --verbose
** Message: pygobject_register_sinkfunc is deprecated (GstObject)
INFO - pithos:<module>:796 - Pithos 0.3.13
/usr/bin/pithos:773: GtkWarning: Ignoring the separator setting
  builder.add_from_file(ui_filename)
INFO - plugin:enable:36 - Enabling module mediakeys
INFO - mediakeys:bind_dbus:30 - Bound media keys with DBUS
INFO - plugin:enable:36 - Enabling module notification_icon
INFO - plugin:enable:36 - Enabling module notify
INFO - pithos:pandora_ready:329 - Pandora connected
INFO - pithos:pandora_ready:339 - Restoring saved station: id = 349369257243922144
INFO - pithos:station_changed:518 - Selecting station 349369257243922144; total = 31
INFO - pandora:get_playlist:246 - pandora: Get Playlist
INFO - pithos:start_song:380 - Starting song: index = 0
INFO - pithos:art_callback:456 - Downloaded album art for 0
INFO - pithos:art_callback:456 - Downloaded album art for 1
INFO - pithos:art_callback:456 - Downloaded album art for 2
INFO - pithos:art_callback:456 - Downloaded album art for 3
INFO - pithos:on_gst_eos:526 - EOS
INFO - pithos:start_song:380 - Starting song: index = 1
INFO - pithos:on_gst_eos:526 - EOS
INFO - pithos:start_song:380 - Starting song: index = 2

Matt Harrison (mattharrison) wrote :

Just a FYI about the patch. I based my patch code on the misc.sync method taken from here:
https://github.com/PromyLOPh/pianobar/blob/2da38556d614b9bc969f65b3683c2ce6eb99e6bc/src/libpiano/piano.c

The case 0: block starting at line 248.
and
The case 0: block starting at line 892.

I did the decoding different from pianobar, just using the default pandora_decrypt from Pithos and using a regex to strip out anything but the timestamp.
It worked in my case, and lets me listen.

Kevin Mehall: The timeoffset is set to self.time_offset. That should keep it for all future xmlrpc calls unless the Pandora class is ever created without doing a login call. Not sure if it does without reviewing the entire codebase.

I also like the cleaner implementation in xmlrpc_call instead of just not setting listenerId to not send the timestamp.

cement_head (andor-udel) wrote :

Hi Matt,

SWEET! It works on Maverick Meerkat for the Rhythmbox Pandora Plugin (install here: http://ubuntuforums.org/showthread.php?t=1891348 )

Thanks!

- CH

Changed in pithos:
status: Fix Committed → Fix Released
Terrence Bruff (tbruff13) wrote :

I did not work for me and i might have messed up my system. because I followed the instructions on the main pithos page and i installed pithos from apt-get can someone help me fix this quick issue

Kevin Mehall (kevin-mehall) wrote :

0.3.14 is released in the PPA. It fixes this bug and works most of the time, but I'm occasionally seeing errors. (the same as what Kevin Godby posted above.) I'm still working on that, but in the mean time, if you're in a hurry to get Pithos working, try 0.3.14 and relaunch it if you encounter that error.

Human (bob-igo) wrote :

I was having this issue today, and 0.3.14 worked when I just tried it. Now I feel bad for complaining to Pandora's support that I was paying for Pandora One and not able to play Pandora because they blocked Pithos. (Do you know they actually recommend Firefox 3.x for playing via the web client? Absurd.)

David (dserbes) wrote :

I've changed my business entirely to Linux Ubuntu, and use Pithos to pipe sound throughout the store. I was lucky enough today to be able to use the Pandora app on my webOS touchpad for music, but I would much rather use my desktop for that. Thanks for the quick fix. I just applied the patch to my home computer, and it works perfectly. I'll be glad to apply it at the store tomorrow.

I was patient enough to wait, and installed the update from the PPA this morning. Needless to say, I'm rockin' out to "Rockin' Holidays". Thanks for fixing this issue!

Terrence Bruff (tbruff13) wrote :

How do we get the release with just sudo apt-get install pithos

Matt Harrison (mattharrison) wrote :

Terrence:
Follow the PPA install instructions here to get the latest version: http://kevinmehall.net/p/pithos/

(The first section under install)

Ian Tompkins (ittompkins) wrote :

Matt, thanks for the patch and instructions! I'm jamming again on 11.10. And rhyming now, too, it would seem.

Terrence Bruff (tbruff13) wrote :

I still get the same error I have installed the new version although I also installed to old version from source eariler. Is there anyway I can delete pithos completely (both source and PPA copy) and do a fresh install and see if that fixes the error

jamina1 (jamina1) wrote :

I Synced my time using ntpd and restarted Pithos and it's all working.

I thought the error was cute, but when I realized it was preventing pithos from working I became upset.

Thanks for the quick fix, I love your program!!

Terrence Bruff (tbruff13) wrote :

I cannot get it to work. Can someone please post back and tell me what I am doing wrong. I love pithos, but I wish I could still use it.

SLmanDR (sadill) wrote :

Terrance did you follow the PPA instructions as Matt pointed out?
Copy each of the 3 lines, one at a time and paste it into a terminal window. Follow each with a return.

VastOne (vastone) wrote :

@SLmanDR

Not everyone is running Ubuntu and that method (PPA) is not recommended at all for debian, which I suspect Terrence is running, but I cannot be sure.

He has two installs running, one form the ppa (I am assuming) and one from a bzr install/build which supersedes the git install.

What is needed is to run the git install/build again with the latest builds

I ran into a similar thing when I had forgotten that I did an earlier bzr/build. I kept applying the patch and confirmed the patch was applied to /usr/share/pyshared/pithos/pandora/pandora.py but still received the error

When a bzr/build is done it puts the file in /usr/local per the instructions

python setup.py install --prefix=/usr/local

So I was applying the patch to the incorrect setup (My original install was debian sudo apt-get pithos) .. I am now on debian sid and the updated version has not made it to debian yet, still sitting at 0.3.13-1

Terrence, to fix this all you really need to do is get the latest from bzr and build it again, if you cannot do it the Ubuntu ppa way

Terrence Bruff (tbruff13) wrote :

I am running Linux Mint, but I accidently install pithos twice the ppa way and build from source so I will follow your instructions. The PPA way gave me the new version, but I am still getting the error

Terrence Bruff (tbruff13) wrote :

I am rocking again thanks guys

tenchidbz (wbaldwin80) on 2012-01-01
Changed in pithos (Ubuntu):
status: Confirmed → Fix Released
Luke Faraone (lfaraone) wrote :

Uh, this wasn't fixed in Ubuntu proper, ISTR.

Changed in pithos (Ubuntu):
status: Fix Released → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pithos - 0.3.14-1

---------------
pithos (0.3.14-1) unstable; urgency=high

  * New upstream bugfix release:
    - Avoid "You have no chance to survive make your time" error (LP: #743198)

 -- Luke Faraone <email address hidden> Thu, 05 Jan 2012 00:11:10 -0500

Changed in pithos (Ubuntu):
status: Confirmed → Fix Released
description: updated

I am using ntpd on that box. I checked that with first round of Googling.
It looks like the Pithos guys have released a fix, though, so I'm back in
business.

Thanks,
-Luke
On Jan 7, 2012 10:15 PM, "Spencer Kingsbury" <email address hidden>
wrote:

> ** Description changed:
>
> Hi. Pithos was working yesterday, but for some reason today when I start
> it up it gives me a dialog which says: "you have no chance to survive
> make your time" and has cancel, retry, and preferences button. If I
> click cancel it will bring me to the Pithos main window, but there will
> be no songs displayed and no stations to choose from. If I then try to
> re-enter my Pandora login information, it will accept it but still
> display no stations or songs. I am very confused :-/. I run 64-bit
> OpenSuse 11.4, and Pithos 0.3.7.
> +
> +
> + ----UPDATE---- So just to sum this up, this bug usually is from your
> software clock not matching up to the Pandora clock. The easiest fix is use
> ntpd to sync your clock. You can find instructions for that all over the
> web. If that doesn't work, try some other method of syncing your clock.
> There is also a patch posted below which you can try.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/743198
>
> Title:
> "You have no chance to survive make your time" error
>
> Status in Pithos:
> Fix Released
> Status in “pithos” package in Ubuntu:
> Fix Released
>
> Bug description:
> Hi. Pithos was working yesterday, but for some reason today when I
> start it up it gives me a dialog which says: "you have no chance to
> survive make your time" and has cancel, retry, and preferences button.
> If I click cancel it will bring me to the Pithos main window, but
> there will be no songs displayed and no stations to choose from. If I
> then try to re-enter my Pandora login information, it will accept it
> but still display no stations or songs. I am very confused :-/. I run
> 64-bit OpenSuse 11.4, and Pithos 0.3.7.
>
>
> ----UPDATE---- So just to sum this up, this bug usually is from your
> software clock not matching up to the Pandora clock. The easiest fix is use
> ntpd to sync your clock. You can find instructions for that all over the
> web. If that doesn't work, try some other method of syncing your clock.
> There is also a patch posted below which you can try.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/pithos/+bug/743198/+subscriptions
>

Luke Faraone (lfaraone) on 2012-01-08
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pithos (Ubuntu Natty):
status: New → Confirmed
Changed in pithos (Ubuntu Oneiric):
status: New → Confirmed
Changed in pithos:
assignee: nobody → captnjack (holycaptnjack)
assignee: captnjack (holycaptnjack) → nobody
Erik (jazzmantrp) on 2012-01-25
Changed in pithos (Ubuntu):
assignee: nobody → Erik (jazzmantrp)
assignee: Erik (jazzmantrp) → nobody

Hello Spencer, or anyone else affected,

Accepted pithos into oneiric-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in pithos (Ubuntu Oneiric):
status: Confirmed → Fix Committed
tags: added: verification-needed
Alex Rieffel (arieffel-d) wrote :

Just upgraded to Linux Mint 12 - after installing, getting this error. I was getting it approximately 5 weeks ago running LM 11, but it went away a few days later. Appears it is on a come-back tour

Bartosz Kosiorek (gang65) wrote :

After installed pithos from proposed on Oneiric, the bug was completely solved for me.
Thanks.

tags: added: verification-done
removed: verification-needed
Changed in pithos (Ubuntu Oneiric):
importance: Undecided → Critical
Changed in pithos (Ubuntu Oneiric):
assignee: nobody → Bartosz Kosiorek (gang65)

I just encountered this again after a couple hours of using Pithos. My clock is correctly synchronized using NTP. I'm running 0.3.14~bzr181 from http://ppa.launchpad.net/kevin-mehall/pithos-daily/ubuntu on Ubuntu oneiric.

When I run pithos from the console I see:

ERROR:root:fault: com.savagebeast.radio.api.protocol.xmlrpc.RadioXmlRpcException: 192.168.160.82|1328076783334|OUT_OF_SYNC|You have no chance to survive make your time.

mike (mharkins621) on 2012-02-12
Changed in pithos:
assignee: nobody → mike (mharkins621)
assignee: mike (mharkins621) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pithos - 0.3.10-1ubuntu3

---------------
pithos (0.3.10-1ubuntu3) oneiric-proposed; urgency=low

  * Sync clock to avoid "You have no chance to survive make your time"
    error from Pandora on start (LP: #743198)
  * Fix media key support, broken in Oneiric (LP: #902322)
 -- Luke Faraone <email address hidden> Sun, 08 Jan 2012 16:13:45 -0500

Changed in pithos (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Clint Byrum (clint-fewbar) wrote :

Hello Spencer, or anyone else affected,

Accepted pithos into natty-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in pithos (Ubuntu Natty):
status: Confirmed → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers