New layer with Text object does not put text on this new layer

Bug #984573 reported by grofaty on 2012-04-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Pinta
High
Cameron White

Bug Description

Pinta 1.2-development-preview on Windows XP:
1. Open new image.
2. From Layers pad click on the Add New Layer.
Note: Beside Background layer witch is created by default when new image is created, now "Layer 2" is created and now selected as current layer.
3. Text object from Tools and click on canvas and type some text like: test
4. From Layer pad select Background layer.
5. From Tools pad select Paint Bucket and from Palette pad select red color.
6. Click on canvas to draw background red.
You will notice that inside test text there is still white color which indicates that "test" text is in the same layer as background. So here is a problem.

To test this out, do the following:
7. Click on "Layer 2" from Layers pad.
8. Click on Move Selected Pixels from Tools pad.
9. Click on "test" text and try to move it. Text can't be moved to new location, so it appears that "test" is not on separate layer.

I hope I understand this correctly, this is the way Gimp is working.

grofaty (grofaty) wrote :

It looks to me that this bug may be related to https://bugs.launchpad.net/pinta/+bug/983709 - both the work around is to use <Esc> key after typing text "test" into the canvas.

Cameron White (cameronwhite91) wrote :

I think the issue here is that the text tool isn't finalized before switching layers, so the text ended up being placed on the background layer even though you started typing it on Layer 2.

Changed in pinta:
importance: Undecided → Medium
status: New → Confirmed
grofaty (grofaty) wrote :

I have tested this bug in latest development on Ubuntu 12.04 and problem still persists. Work-around is to use <Esc> key after typing a text. I know this work-around, but I am little bit afraid that average users will not know this work-around I will see this bug as "layers do not work in Pinta".

I think we should change importance of this bug to High.

Cameron White (cameronwhite91) wrote :

Agreed, should be high priority.

This is a similar issue to bug #891556, so to avoid causing issues with the Move Selected Pixels tool we should wait for https://github.com/PintaProject/Pinta/pull/14 (a larger change that will go into Pinta 1.4)

Changed in pinta:
milestone: none → 1.4
importance: Medium → High
grofaty (grofaty) wrote :

I have tested the bug with Pinta-1.4-preview-20120812 on Windows XP and problem still persists. Is there any way we can just pull fix for this bug from pull request and not merge whole large pull request - you know like fixing this bug in v1.4 and leave the rest of pull request for v1.5?

Cameron White (cameronwhite91) wrote :

Fix committed: https://github.com/PintaProject/Pinta/commit/8912ae838730c131e5c73c49b34cb2496b1a3c40.

I think it should be safe to do this (unlike the issues caused in bug #891556) because we aren't trying to immediately undo afterwards.

Changed in pinta:
assignee: nobody → Cameron White (cameronwhite91)
status: Confirmed → Fix Committed
grofaty (grofaty) wrote :

I tested this bug in latest development on Ubuntu 12.04 and I can report this bug is fixed. I also tested steps from bug 891556 and it looks like this fix does not make any regressions, so this fix is OK.

grofaty (grofaty) wrote :

Pinta v1.4 on Windows XP. Problem solved.

Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers