Undo using Text object display letter z in text instead of undo

Bug #983709 reported by grofaty on 2012-04-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Pinta
Medium
Unassigned

Bug Description

Tested on Pinta latest development on Ubuntu 11.10 and Pinta 1.2-development-preview on Windows XP:
1. Click on Text object from Tools pad.
2. Click on canvas and type in some text like: test
3. Click on <Ctrl>+Z to undo text object, but instead of undo "z" letter appears on canvas.

Work-around is to press <Esc> key to quit text input and then undo works fine.

Cameron White (cameronwhite91) wrote :

This only seems to happen if there's nothing else on the Undo stack - if you draw something else on the canvas first it will work.

Changed in pinta:
importance: Undecided → Medium
status: New → Confirmed

I have tried to use Paintbrush before using Text object and it really looks like Undo is working fine if Text object is non-first to be used.

grofaty (grofaty) wrote :

It looks to me that this bug may be related to https://bugs.launchpad.net/pinta/+bug/984573 - both the work around is to use <Esc> key after typing text "test" into the canvas.

grofaty (grofaty) wrote :

Just a quick update. Tested on Pinta 1.2 on Windows and on the latest development on Ubuntu 11.10 and problem persists.

Cameron White (cameronwhite91) wrote :

The in-progress pull request at https://github.com/PintaProject/Pinta/pull/14 should fix this.

Changed in pinta:
milestone: none → 1.3
status: Confirmed → In Progress
Cameron White (cameronwhite91) wrote :

Bumping to 1.4 since the fix is part of a fairly large change.

Changed in pinta:
milestone: 1.3 → 1.4
Jonathan Pobst (jpobst) wrote :

The issue is that when there is nothing on the Undo stack, the GTK Action for Undo is disabled, so Ctrl-Z is no longer a valid keyboard shortcut. Hence it is not captured and gets passed to the Text tool. The fix is probably to have the Text tool ignore either this combination, or all key presses when the Ctrl key is down (probably the latter makes more sense).

Olivier Dufour (olivier-duff) wrote :

I have send a pull request to fix it.

Olivier Dufour (olivier-duff) wrote :

sorry my patch do not work...

grofaty (grofaty) wrote :

I have tested this bug now in latest development and bug does not appear any more. It looks one of the patches has also fixed this bug. It would be nice to know which one in case if that patch is reverted.

grofaty (grofaty) wrote :

Ah sorry, false report. I must been pressing <Esc> or something. This bug is still present if text is typed and not <Esc> or any other action is performed.

Cameron White (cameronwhite91) wrote :
Changed in pinta:
status: In Progress → Fix Committed
grofaty (grofaty) on 2012-09-27
Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers