/usr/bin/pinta has wrong path in it

Bug #932924 reported by Paul Lange on 2012-02-15
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Pinta
Medium
Cameron White

Bug Description

Pinta cannot be run using /usr/bin/pinta because it contains
exec /usr/bin/mono /usr/lib/pinta/Pinta.exe "$@"
and on x86_64 the correct path is /usr/lib64/pinta/Pinta.exe

See https://bugzilla.redhat.com/show_bug.cgi?id=790867

Is that word of the makefile or should the packager care?

Cameron White (cameronwhite91) wrote :

Looks like there was a hard-coded path in https://github.com/PintaProject/Pinta/blob/master/pinta.in

Changed in pinta:
importance: Undecided → Medium
status: New → Confirmed
grofaty (grofaty) wrote :

I have looked at downstream bug reporting system (link from bug report above) and there is a statement: "Fixed this till a solution is in upstream." So it looks like downstream has temporary solved the problem. Can someone look at the solution they made, maybe we can apply the same fix.

Paul Lange (palango) wrote :

What I did downstream is doeing this after extracting the archive:

sed -i 's:@prefix@/lib/:%{_libdir}/:' pinta.in

But I don't know how to fix this in the makefiles.

Cameron White (cameronwhite91) wrote :

Hi Paul,

Sorry for the delay. Could you test out the attached patch and verify if it fixes this issue?

Paul Lange (palango) wrote :

Sorry for the long testing time.

The patch doesn't work at it is. For fedora it should be
+exec @MONO@ @libdir@/@PACKAGE@/Pinta.exe "$@"

libdir in Fedora already includes the prefix, I'm not sure how other distros handle this however.

Cameron White (cameronwhite91) wrote :

Using @libdir@ didn't directly work for me in Ubuntu (64-bit) due to some issues with exec_prefix, but I managed to get that sorted out.

Can you try out the new patch I've attached?

Paul Lange (palango) wrote :

v2 works fine for me.

Thanks for the work!

Cameron White (cameronwhite91) wrote :
Changed in pinta:
assignee: nobody → Cameron White (cameronwhite91)
milestone: none → 1.4
status: Confirmed → Fix Committed
grofaty (grofaty) on 2012-09-27
Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers