Inconsistent Save dialog with other Gnome programs like Gedit

Bug #1909576 reported by grofaty
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Pinta
Fix Released
Low
Unassigned

Bug Description

I have downloaded Pinta 1.8 development for Ubuntu 20.04 from
https://github.com/PintaProject/Pinta/actions/runs/450000006

1. Open or create image.
2. Do some drawing on canvas.
3. Press "x" on image tab to close it down. Window dialog appears. Now when Pinta 1.8 is also GTK3 application it is more obvious that there are some differences between e.g. Gedit tool and Pinta when Save dialog is used. See attachment for details.

For better UX the same actions in multiple programs should produce the same EXPECTED result.

Revision history for this message
grofaty (grofaty) wrote :
Changed in pinta:
importance: Undecided → Low
milestone: none → 1.8
status: New → Confirmed
Revision history for this message
grofaty (grofaty) wrote :

Now have also noticed in Pinta there is main text:
"Save the changes..."

in Gedit:
"Save changes..."

I am not native English speaker, but if my English knowledge is not rusted too much, then "the" is used when there is noun we already have been talking about. For example: A car is red color. (We are talking about this car for the first time). The car is huge. (We already know which car we are talking about so that is "the"). If this is correct, then "the" can be removed from Pinta text to get more compatible with Gedit.

This is not super important problem. Just tiny problem, maybe some from community could fix. Can we mark the bug as "Help needed"?

Revision history for this message
Cameron White (cameronwhite91) wrote :

Yes, I think the wording from the Gedit dialog box is better

tags: added: easy-to-fix
Revision history for this message
Cameron White (cameronwhite91) wrote :
Changed in pinta:
status: Confirmed → Fix Committed
Revision history for this message
grofaty (grofaty) wrote :

I have tested in Pinta 1.8 development on Ubuntu 20.04 from:
https://github.com/PintaProject/Pinta/actions/runs/451486225

almost all changes are implemented except one. In Gedit default button in orange border around button is set to "Save As" button, so in this window pressing Enter and "Save As" button appears.

In Pinta default button is Cancel. So pressing enter and Cancel action takes place.

I actually prefer Gedit variant, because most of the times you want to save the work you have done, so it is convenient to just press Enter to take action.

I am marking this bug as "New".

Changed in pinta:
status: Fix Committed → New
grofaty (grofaty)
summary: - Inconsistent Save button with other Gnome programs like Gedit
+ Inconsistent Save dialog with other Gnome programs like Gedit
Revision history for this message
grofaty (grofaty) wrote :

I have found another one. Discharge button:
- Gedit: "Close without Saving"
- Pinta: "Close without saving".

Can you please uppercase the "Saving" word.

Revision history for this message
Cameron White (cameronwhite91) wrote :
Changed in pinta:
status: New → Fix Committed
Revision history for this message
grofaty (grofaty) wrote :

I downloaded Pinta 1.8 on Ubuntu 20.04:
https://github.com/PintaProject/Pinta/actions/runs/453364003

I can confirm both additional issues #5 and #6 are fixed. Thanks a lot.

Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers