Crash error selecting any option expect About from Help menu

Bug #1888883 reported by grofaty on 2020-07-24
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Pinta
High
Unassigned

Bug Description

Latest Pinta PPA update 1.7+r1106-202007230322~ubuntu18.04.1:

1. Select Help menu and any option except About and crash appears with error message: "Unhandled exception. Exception has been thrown by the target of an invocation.

Details:

System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.ComponentModel.Win32Exception: Cannot find the specified file
  at System.Diagnostics.Process.StartWithShellExecuteEx (System.Diagnostics.ProcessStartInfo startInfo) [0x00102] in <4e15bbae9d7043d8afd6cfd50bd9bd5a>:0
  at System.Diagnostics.Process.Start () [0x00032] in <4e15bbae9d7043d8afd6cfd50bd9bd5a>:0
  at (wrapper remoting-invoke-with-check) System.Diagnostics.Process.Start()
  at System.Diagnostics.Process.Start (System.Diagnostics.ProcessStartInfo startInfo) [0x0001b] in <4e15bbae9d7043d8afd6cfd50bd9bd5a>:0
  at System.Diagnostics.Process.Start (System.String fileName) [0x00006] in <4e15bbae9d7043d8afd6cfd50bd9bd5a>:0
  at Pinta.Core.HelpActions.DisplayHelp (System.Object sender, System.EventArgs e) [0x00065] in <572927d10c8e4a20846d21e927afae75>:0
  at (wrapper managed-to-native) System.Reflection.RuntimeMethodInfo.InternalInvoke(System.Reflection.RuntimeMethodInfo,object,object[],System.Exception&)
  at System.Reflection.RuntimeMethodInfo.Invoke (System.Object obj, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x0006a] in <a17fa1457c5d44f2885ac746c1764ea5>:0
   --- End of inner exception stack trace ---
  at System.Reflection.RuntimeMethodInfo.Invoke (System.Object obj, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00083] in <a17fa1457c5d44f2885ac746c1764ea5>:0
  at System.Reflection.MethodBase.Invoke (System.Object obj, System.Object[] parameters) [0x00000] in <a17fa1457c5d44f2885ac746c1764ea5>:0
  at System.Delegate.DynamicInvokeImpl (System.Object[] args) [0x000e7] in <a17fa1457c5d44f2885ac746c1764ea5>:0
  at System.MulticastDelegate.DynamicInvokeImpl (System.Object[] args) [0x00008] in <a17fa1457c5d44f2885ac746c1764ea5>:0
  at System.Delegate.DynamicInvoke (System.Object[] args) [0x00000] in <a17fa1457c5d44f2885ac746c1764ea5>:0
  at GLib.Signal.ClosureInvokedCB (System.Object o, GLib.ClosureInvokedArgs args) [0x0007d] in <ed39f21b9e9343dcbd442a17ad356a9f>:0
  at GLib.Signal+SignalClosure.Invoke (GLib.ClosureInvokedArgs args) [0x0000c] in <ed39f21b9e9343dcbd442a17ad356a9f>:0
  at GLib.Signal+SignalClosure.MarshalCallback (System.IntPtr raw_closure, GLib.Value* return_val, System.UInt32 n_param_vals, GLib.Value* param_values, System.IntPtr invocation_hint, System.IntPtr marshal_data) [0x00050] in <ed39f21b9e9343dcbd442a17ad356a9f>:0

Cameron White (cameronwhite91) wrote :

Does this happen for the other options like "Pinta Website", or just for accessing the help contents?

This works okay for me testing on OSX since it just opens the website, but on Linux it tries to launch the bundled documentation (bug 778981) which might not be working? I'm planning to remove that bundled documentation before 1.7 since it's very incomplete and the website is much more useful

grofaty (grofaty) wrote :

It happens on every option in Help about except About.

Cameron White (cameronwhite91) wrote :

Thanks, I could repro this on Ubuntu 18.04. This seems like a new issue, maybe with the updated Mono version?

Changed in pinta:
importance: Undecided → High
milestone: none → 1.7
status: New → Confirmed
grofaty (grofaty) wrote :

I am sure this problem was not appearing before, but I am not sure if this is the result of last Mono update. My current Mono is:

mono --version
Mono JIT compiler version 6.10.0.104 (tarball Fri Jun 26 19:38:24 UTC 2020)

Cameron White (cameronwhite91) wrote :

I think this is the same issue as https://github.com/mono/mono/issues/17204, so it's a Mono issue that we'll need to work around.

Cameron White (cameronwhite91) wrote :
Changed in pinta:
status: Confirmed → Fix Committed
grofaty (grofaty) wrote :

I can confirm this problem is fixed in 1.7+r1113-202007280014~ubuntu18.04.1.

Now additional problem appeared with Help | Pinta Website related to certificate, but I have reported new bug 1889249, to follow one problem per bug report policy.

grofaty (grofaty) on 2020-08-05
Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.