Undo after resize window and background color is changed to front color

Bug #1888131 reported by grofaty
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Pinta
Undecided
Unassigned

Bug Description

Undo resize canvas and background color gets the same color as front color

First check and confirm you have black front color and white background color in Palette selected.

Pinta daily PPA on Ubuntu 18.04.
1. Draw line on canvas.
2. Image | Resize Canvas.
3. In "By percentage" field type in: 200 and OK button.
4. Now from toolbar press Undo twice and problem appears. Background color turned red.

Note 1: If color after step 1 is set to e.g. red, then after step 4, background color turns red. It seams front color is set as background color.
Note 2: This problem also appears using other tools e.g. instead of line use Rectangle or Ellipse.

Actually this is No. 1 annoying bug for me, because I use resize window and undo non stop, and I am required to change background color non-stop.

Revision history for this message
Cameron White (cameronwhite91) wrote :
Changed in pinta:
milestone: none → 1.7
status: New → Fix Committed
Revision history for this message
grofaty (grofaty) wrote :

I can confirm this problem is fixed in daily build of Github https://github.com/PintaProject/Pinta/suites/953151141/artifacts/11911471

grofaty (grofaty)
Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers