Regression: Holding Shift and Rectangle does not draw square anymore

Bug #1452607 reported by grofaty on 2015-05-07
34
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Pinta
Medium
Unassigned

Bug Description

Pinta 1.7.0.194 on Windows 7.

1. Rectangle.
2. Press Shift key and hold.
3. Draw object on canvas. Problem appears. Holding Shift key should draw a square and not rectangle.

I did additional tests
- Pinta 1.6 on Windows 7: the same problem
- Pinta 1.5 on Windows 7: works fine!

It looks like this square feature was broken somewhere between Pinta 1.5 and 1.6.

P.S. Square selection works correctly using Rectangle Select tool.

Changed in pinta:
importance: Undecided → Medium
milestone: none → 1.7
status: New → Triaged
tags: added: line-tool tools
Cameron White (cameronwhite91) wrote :

Bug 1452607 also noted that the ellipse tool doesn't constrain to a circle.

Cameron White (cameronwhite91) wrote :

I meant to reference bug 1874265 in the previous comment

Cameron White (cameronwhite91) wrote :
Changed in pinta:
status: Triaged → Fix Committed
grofaty (grofaty) wrote :

I tested this in 1.7+r1120-202007292146~ubuntu18.04 and I can confirm this problem is fixed. Also problem using Ellipse in posts #1 and #2 is also fixed. Also tested Rounded Rectangle and it also works fine.

grofaty (grofaty) on 2020-08-05
Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers