Comment 15 for bug 75850

Ka-Hing Cheung (kahing) wrote :

I've taken a look at that branch recently, it doesn't change the existing APIs but adds quite a few, so we can do it in a minor release. However, there are also quite a few problems (silly memory management, bloated api) so it's not something that can just be merged.

for starters, I am thinking about redoing the _set_* hooks to be more like how ssl is handled, kill the prefs and make the enablement of the plugins as the prefs, and also killing all those destroy callback on passwords.

Richard I know this really isn't the place that this should be discussed, but you are nowhere to be found!