python-imaging broken in raring

Bug #1112496 reported by Rachel Greenham on 2013-02-01
478
This bug affects 113 people
Affects Status Importance Assigned to Milestone
Phatch
Undecided
Unassigned
comix (Ubuntu)
Undecided
Unassigned
Raring
Undecided
Unassigned
gwibber (Ubuntu)
Undecided
Unassigned
Raring
Undecided
Unassigned
ocrfeeder (Ubuntu)
Undecided
Unassigned
Raring
Undecided
Unassigned
phatch (Ubuntu)
High
Unassigned
Raring
High
Unassigned
python-imaging (Ubuntu)
High
Matthias Klose
Raring
High
Matthias Klose
simple-image-reducer (Ubuntu)
Undecided
Unassigned
Raring
Undecided
Unassigned
wsjt (Ubuntu)
Undecided
Unassigned
Raring
Undecided
Unassigned

Bug Description

python-imaging in raring doesn't include a PIL.pth to point python at the library, so attempts to import modules from the package fail with, eg:

rachel@rarity:/etc$ python -m ImageMode && echo ok
/usr/bin/python: No module named Image

When the PIL.pth file is manually created, so python can find it, the Image module itself still fails to load:

rachel@rarity:/etc$ python -m Image
Traceback (most recent call last):
  File "/usr/lib/python2.7/runpy.py", line 162, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "/usr/lib/python2.7/runpy.py", line 72, in _run_code
    exec code in run_globals
  File "/usr/lib/python2.7/dist-packages/PIL/Image.py", line 75, in <module>
    from . import ImageMode
ValueError: Attempted relative import in non-package

The ImageMode module that line seems to be trying to import, however, seems to import fine by itself:

rachel@rarity:/etc$ python -m ImageMode && echo ok
ok

(I've confirmed that ImageMode comes from the same place, as if I remove PIL.pth again, the above line just returns the "No module named ImageMode" error)

I've tried reinstalling python-imaging already. I note in any case the PIL.pth file is missing on the file list available at packages.ubuntu.com for raring.

This is on Ubuntu Raring as updated from Ubuntu Quantal a few days ago:

rachel@rarity:/etc$ lsb_release -rd
Description: Ubuntu Raring Ringtail (development branch)
Release: 13.04
rachel@rarity:/etc$ apt-cache policy python
python:
  Installed: 2.7.3-10ubuntu5
  Candidate: 2.7.3-10ubuntu5
  Version table:
 *** 2.7.3-10ubuntu5 0
        500 http://gb.archive.ubuntu.com/ubuntu/ raring/main amd64 Packages
        100 /var/lib/dpkg/status
rachel@rarity:/etc$ apt-cache policy python-imaging
python-imaging:
  Installed: 1.1.7+1.7.8-1ubuntu1
  Candidate: 1.1.7+1.7.8-1ubuntu1
  Version table:
 *** 1.1.7+1.7.8-1ubuntu1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ raring/main amd64 Packages
        100 /var/lib/dpkg/status

Affects me as it affects building/packaging XBMC post-frodo for raring. :-)

Related branches

tags: added: raring
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in python-imaging (Ubuntu):
status: New → Confirmed
David Shepherd (tophitter225-p) wrote :

Effects me in Gwibber.

Traceback (most recent call last):
  File "/usr/bin/gwibber-service", line 55, in <module>
    from gwibber.microblog.util.log import setup_logging
  File "/usr/lib/python2.7/dist-packages/gwibber/microblog/util/__init__.py", line 2, in <module>
    from gwibber.microblog.util import resources
  File "/usr/lib/python2.7/dist-packages/gwibber/microblog/util/resources.py", line 11, in <module>
    import Image
ImportError: No module named Image

Uninstalled the upgraded package python-imaging version 1.1.7+1.7.8-1 and installed the previous version python-imaging 1.1.7-4 and Gwibber now working again. Hope this gets fixed soon.

Julian Taylor (jtaylor) wrote :

phatch is broken too

Changed in python-imaging (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gwibber (Ubuntu):
status: New → Confirmed
MC Return (mc-return) wrote :

Gnome15 is now completely broken as well and fails to start.

Tibault Damman (tibault-damman) wrote :

The comic reader "Comix" (installed from software centre) fails to start (silently!) because of this.

Brian Murray (brian-murray) wrote :

python-imaging version 1.1.7-4build1 which used to be available in raring does not have this issue.

Changed in python-imaging (Ubuntu):
status: Confirmed → Triaged
assignee: nobody → Matthias Klose (doko)
Matthias Klose (doko) wrote :

as a long-term solution, every rdepends should be patched as:

try:
  from PIL import Image
except ImportError:
  import Image

as a midterm solution, maybe ship a python-imaging-compat which holds the .pth file

as short-term, maybe let python-imaging depend on python-imaging-compat.

The list of rdependencies is longish:

  yade
  xpra
  xmms2tray
  xbmc
  wsjt
  wotsap
  videoporama
  twms
  trac-wikiprint
  trac-odtexport
  trac-diavisview
  tpclient-pywx
  tilecache
  svgtoipe
  streamtuner2
  snowballz
  smartshine
  simple-image-reducer
  rst2pdf
  remuco-base
  rapid-photo-downloader
  python-weboob-core
  python-trml2pdf
  python-sympy
  python-surfer
  python-stepic
  python-sponge
  python-soya-doc
  python-skimage
  python-seqdiag
  python-scrapy
  python-scipy
  python-schooltool
  python-qrtools
  python-qrencode
  python-pyx
  python-pyepl
  python-plastex
  python-pisa
  python-pgm
  python-nwdiag
  python-numm
  python-mpltoolkits.basemap
  python-libtiff
  python-guiqwt
  python-glitch
  python-gamera
  python-freevo
  python-fabio
  python-enable
  python-djblets
  python-django-mumble
  python-django-filebrowser
  python-django-feincms
  python-dicom
  python-circuits
  python-captcha
  python-blockdiag
  python-actdiag
  python-aalib
  python-aafigure
  pymsnt
  pyicqt
  pyfai
  pyaimt
  psychopy
  plucker
  pkpgcounter
  photon
  photofilmstrip
  phatch-cli
  openshot
  openerp6.1-core
  oboinus
  nml
  nikola
  nautilus-image-manipulator
  moovida-plugins-bad
  mobyle
  mitmproxy
  memaker
  mediawiki-extensions-confirmedit
  mcomix
  mbot
  luciole
  lazygal
  last-align
  impressive
  ibid
  griffith
  grass-gui
  gpsdrive-scripts
  gourmet
  glue-sprite
  fretsonfire-game
  fontypython
  fofix
  fgo
  exaile-plugin-contextinfo
  didjvu
  dicompyler
  comix
  cinnamon
  cfv
  calibre
  bkchem
  beets
  apitrace-gl-frontend
  advene
  ubuntu-sso-client-qt
  python-uniconvertor-dbg
  python-uniconvertor
  python-sphinx
  python-reportlab
  python-htmlgen
  python-docutils
  hplip
  gwibber-service

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in phatch (Ubuntu):
status: New → Confirmed
Barry Warsaw (barry) wrote :

I like the idea of a compat package. Let me see if I can whip something up.

Barry Warsaw (barry) wrote :

As Rachel observes in the bug description, just adding a PIL.pth file won't be enough. I do not want to modify Pillow to use non-relative imports.

What I think might work is a PILcompat.pth file and a PILcompat Python package. Inside there would be files like Image.py that do

from PIL import Image

(maybe with a __all__)

The thing is, I'm not sure I want 80 .py files inside PILcompat (the number of .py files in the PIL package in Precise) even if we can autogenerate them. A few is not so bad though.

What other PIL packages are imported through the global namespace? Can anybody provide a list of those from all the rdeps?

For now, I'll play with the idea and if it works, I'll expose Image only for now, but make it easy to add others.

Barry Warsaw (barry) wrote :

Well, something like the linked branch is the idea. It works for `import Image` (Python 2 only of course), but if there are other modules that typically get imported from the top-level namespace instead of as a subpackage of PIL, they'll have to be added individually. I couldn't figure out a good way around that.

Matthias Klose (doko) wrote :

just Image doesn't seem to be enough. What about starting with the modules listed in the PIL handbook?

http://pythonware.com/library/pil/handbook/ (Part II, Module Reference)

The Image Module
The ImageChops Module
The ImageColor Module
The ImageDraw Module
The ImageEnhance Module
The ImageFile Module
The ImageFileIO Module
The ImageFilter Module
The ImageFont Module
The ImageGrab Module
The ImageMath Module
The ImageOps Module
The ImagePalette Module
The ImagePath Module
The ImageQt Module
The ImageSequence Module
The ImageStat Module
The ImageTk Module
The ImageWin Module
The PSDraw Module
The ImageCrackCode Module
The ImageGL Module

On Feb 06, 2013, at 02:04 PM, Matthias Klose wrote:

>just Image doesn't seem to be enough. What about starting with the
>modules listed in the PIL handbook?
>
>http://pythonware.com/library/pil/handbook/ (Part II, Module Reference)
>
>The Image Module
>The ImageChops Module
>The ImageColor Module
>The ImageDraw Module
>The ImageEnhance Module
>The ImageFile Module
>The ImageFileIO Module
>The ImageFilter Module
>The ImageFont Module
>The ImageGrab Module
>The ImageMath Module
>The ImageOps Module
>The ImagePalette Module
>The ImagePath Module
>The ImageQt Module
>The ImageSequence Module
>The ImageStat Module
>The ImageTk Module
>The ImageWin Module
>The PSDraw Module
>The ImageCrackCode Module
>The ImageGL Module

Branch updated to add these.

Alex Clark (aclark) wrote :

Is fixing the broken imports an option? If not, then yeah restoring PIL's PIL.pth is probably the best approach. We can't do this in Pillow, but it probably makes sense for Ubuntu to do it as a patch until such time as the imports can be fixed.

Barry Warsaw (barry) wrote :

On Feb 08, 2013, at 12:25 PM, Alex Clark wrote:

>Is fixing the broken imports an option?

Probably only with enough volunteers to fix upstream and/or provide patches to
the Debian and/or Ubuntu packages. It's always better to fix things as far
upstream as possible of course.

>If not, then yeah restoring PIL's PIL.pth is probably the best approach. We
>can't do this in Pillow, but it probably makes sense for Ubuntu to do it as a
>patch until such time as the imports can be fixed.

We can't restore PIL.pth because of the relative imports in Pillow, but my
branch (see merge proposal) does add a new compatibility binary package. We'd
still have to patch the Ubuntu/Debian packages to Depend on the compat
package, but that's not too much work.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in comix (Ubuntu):
status: New → Confirmed
Changed in ocrfeeder (Ubuntu):
status: New → Confirmed
Changed in simple-image-reducer (Ubuntu):
status: New → Confirmed
Barry Drake (b-drake) wrote :

I just put the hard-drive from my old (dead) desktop into my new one. It has raring installed. ocrfeeder worked Ok. It was almost two weeks since any software updates. After I did the updates, which included Python, the problem appeared, so it occurred within about the last ten days. The problem occurred in ocrfeeder.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python-imaging - 1.1.7+1.7.8-1ubuntu2

---------------
python-imaging (1.1.7+1.7.8-1ubuntu2) raring; urgency=low

  * Add python-imaging-compat modules to get back the old top-level module
    names (i.e. not subpackages within PIL) for Python 2 only. (Barry
    Warsaw). LP: #1112496.
  * python-imaging: Depend on python-imaging-compat for now.
 -- Matthias Klose <email address hidden> Sun, 10 Feb 2013 16:31:33 +0100

Changed in python-imaging (Ubuntu Raring):
status: Triaged → Fix Released
Barry Drake (b-drake) wrote :

It works for me. Thanks.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in wsjt (Ubuntu):
status: New → Confirmed
Dave Gilbert (ubuntu-treblig) wrote :

Thanks; the new python-imaging fixed wsjt; thanks.

Dave Gilbert (ubuntu-treblig) wrote :

Twas the python-imaging that did it; marking invalid for wsjt.

Changed in wsjt (Ubuntu Raring):
status: Confirmed → Invalid

fixed for me too

Fixed for me too

Changed in simple-image-reducer (Ubuntu Raring):
status: Confirmed → Invalid
Changed in phatch (Ubuntu Raring):
status: Confirmed → Invalid
Changed in ocrfeeder (Ubuntu Raring):
status: Confirmed → Invalid
Changed in gwibber (Ubuntu Raring):
status: Confirmed → Invalid
Changed in comix (Ubuntu Raring):
status: Confirmed → Invalid
Bernhard Reiter (ockham-razor) wrote :

This still affects pyolfc, which unsuccessfully tries to import GifImagePlugin. See bug #1160571.

BTW, Debian has started a transition for PIL -> Pillow, see http://lists.debian.org/debian-devel/2013/02/msg00176.html

Still affects me. Not fixed.

phatch
Traceback (most recent call last):
  File "/usr/bin/phatch", line 16, in <module>
    main(config_paths, app_file = __file__)
  File "/usr/share/phatch/phatch/app.py", line 203, in main
    from core.settings import create_settings
  File "/usr/share/phatch/phatch/core/settings.py", line 23, in <module>
    from pil import IMAGE_READ_EXTENSIONS
  File "/usr/share/phatch/phatch/core/pil.py", line 39, in <module>
    from lib import openImage
  File "/usr/share/phatch/phatch/lib/openImage.py", line 25, in <module>
    import thumbnail
  File "/usr/share/phatch/phatch/lib/thumbnail.py", line 62, in <module>
    import PngImagePlugin
ImportError: No module named PngImagePlugin

apt-cache policy python-imaging
python-imaging:
  Installed: 1.1.7+2.0.0-1
  Candidate: 1.1.7+2.0.0-1
  Version table:
 *** 1.1.7+2.0.0-1 0
        500 http://archive.ubuntu.com/ubuntu/ raring/main amd64 Packages
        100 /var/lib/dpkg/status

apt-cache policy python-imaging-compat
python-imaging-compat:
  Installed: 1.1.7+2.0.0-1
  Candidate: 1.1.7+2.0.0-1
  Version table:
 *** 1.1.7+2.0.0-1 0
        500 http://archive.ubuntu.com/ubuntu/ raring/main amd64 Packages
        100 /var/lib/dpkg/status

lsb_release -a
[...]
Description: Ubuntu Raring Ringtail (development branch)
Release: 13.04
Codename: raring

uname -rms
Linux 3.8.0-16-generic x86_64

Marius B. Kotsbak (mariusko) wrote :

Regression in package 1.1.7+2.0.0-1 maybe. As this bug report has status fix released, I suggest you open a new bug report and refer to it from here.

Matthias Klose (doko) wrote :

Christian, just replace it with

  from PIL import PngImagePlugin

and check the source for other occurrences. Then attach the patch to this issue.

Changed in phatch (Ubuntu Raring):
importance: Undecided → High
status: Invalid → Confirmed

Found a solution from https://bugs.launchpad.net/phatch/+bug/1156583 by user KEIII about a broken symlink. Additionally python3-imaging is *missing* from the depencies of the phatch package. (besides python-imaging and python-imaging-compat)

1.) sudo apt-get install python3-imaging

2.) User KEIII wrote: "It seems link to /usr/lib/python3/dist-packages/PIL/PngImagePlugin.py are broken or missing
If copy or make symlink it to /usr/share/phatch/phatch/lib phatch start correctly"

I just did: sudo cp -ivr /usr/lib/python3/dist-packages/PIL/* /usr/share/phatch/phatch/lib/ (press "n" for No twice!)

3.) it works!

I link this bug report to the other one of the phatch package.

Zisu Andrei (matzipan) on 2013-04-24
no longer affects: python-imaging
florin (florin-arjocu) wrote :

Any idea if there will be an update?

I switched to Raring and cannot use Phatch :(

Thanks!

CANTE Pierre (pierrecante) wrote :

Hi, I tried your command lines in #32, and I added the python-imaging-compat pakage before too (#21)
I get this problem since my upgrade to raring. Not fixed here, it affects phatch, wich is running but can't make effective work, and didn't recognize any picture file.

Jan D (jandeyk-gmail) wrote :

Still affects me:

Traceback (most recent call last):
  File "/usr/bin/phatch", line 16, in <module>
    main(config_paths, app_file = __file__)
  File "/usr/share/phatch/phatch/app.py", line 203, in main
    from core.settings import create_settings
  File "/usr/share/phatch/phatch/core/settings.py", line 23, in <module>
    from pil import IMAGE_READ_EXTENSIONS
  File "/usr/share/phatch/phatch/core/pil.py", line 39, in <module>
    from lib import openImage
  File "/usr/share/phatch/phatch/lib/openImage.py", line 25, in <module>
    import thumbnail
  File "/usr/share/phatch/phatch/lib/thumbnail.py", line 62, in <module>
    import PngImagePlugin
ImportError: No module named PngImagePlugin

CANTE Pierre (pierrecante) wrote :
Download full text (3.2 KiB)

I get this with phatch, no picture traited : I don't know anything about ; is it the same subject ? like in
https://bugs.launchpad.net/phatch/+bug/1156583
?
(I hope not to do anyone in lauchnpad waste time)

~$ phatch
Traceback (most recent call last):
  File "/usr/share/phatch/phatch/lib/pyWx/folderFileBrowser.py", line 246, in on_list_item_selected
    self.show_preview(filename)
  File "/usr/share/phatch/phatch/lib/pyWx/folderFileBrowser.py", line 236, in show_preview
    bitmap = pil_wxBitmap(open_thumb(filename, size=(128,128)))
  File "/usr/share/phatch/phatch/lib/openImage.py", line 94, in open_thumb
    save_cache=save_cache)
  File "/usr/share/phatch/phatch/lib/thumbnail.py", line 428, in open
    size=size, save_cache=save_cache)
  File "/usr/share/phatch/phatch/lib/thumbnail.py", line 206, in _open
    image = open_image(filename)
  File "/usr/share/phatch/phatch/lib/openImage.py", line 87, in open_image_exif_thumb
    return open_image_exif(uri)
  File "/usr/share/phatch/phatch/lib/openImage.py", line 74, in open_image_exif
    return imtools.transpose_exif(open(uri))
  File "/usr/share/phatch/phatch/lib/openImage.py", line 44, in open
    image = open_image_without_pil(uri, WITHOUT_PIL)
  File "/usr/share/phatch/phatch/lib/openImage.py", line 115, in open_image_without_pil
    image = open_method(filename)
  File "/usr/share/phatch/phatch/lib/openImage.py", line 350, in open_xcf
    return open_image_with_command(filename, command, 'xcf2png')
  File "/usr/share/phatch/phatch/lib/openImage.py", line 152, in open_image_with_command
    image = Image.open(temp_file)
  File "/usr/share/phatch/phatch/lib/Image.py", line 2020, in open
    raise IOError("cannot identify image file")
IOError: cannot identify image file
Traceback (most recent call last):
  File "/usr/share/phatch/phatch/lib/pyWx/folderFileBrowser.py", line 246, in on_list_item_selected
    self.show_preview(filename)
  File "/usr/share/phatch/phatch/lib/pyWx/folderFileBrowser.py", line 236, in show_preview
    bitmap = pil_wxBitmap(open_thumb(filename, size=(128,128)))
  File "/usr/share/phatch/phatch/lib/openImage.py", line 94, in open_thumb
    save_cache=save_cache)
  File "/usr/share/phatch/phatch/lib/thumbnail.py", line 428, in open
    size=size, save_cache=save_cache)
  File "/usr/share/phatch/phatch/lib/thumbnail.py", line 206, in _open
    image = open_image(filename)
  File "/usr/share/phatch/phatch/lib/openImage.py", line 87, in open_image_exif_thumb
    return open_image_exif(uri)
  File "/usr/share/phatch/phatch/lib/openImage.py", line 74, in open_image_exif
    return imtools.transpose_exif(open(uri))
  File "/usr/share/phatch/phatch/lib/openImage.py", line 44, in open
    image = open_image_without_pil(uri, WITHOUT_PIL)
  File "/usr/share/phatch/phatch/lib/openImage.py", line 115, in open_image_without_pil
    image = open_method(filename)
  File "/usr/share/phatch/phatch/lib/openImage.py", line 350, in open_xcf
    return open_image_with_command(filename, command, 'xcf2png')
  File "/usr/share/phatch/phatch/lib/openImage.py", line 152, in open_image_with_command
    image = Image.open(temp_file)
  File "/usr/share/phatch/phatch/lib/Image.py", line 2020, in...

Read more...

Barry Warsaw (barry) wrote :

On Apr 30, 2013, at 06:59 PM, Jan D wrote:

>Still affects me:
>
>Traceback (most recent call last):
> File "/usr/bin/phatch", line 16, in <module>
> main(config_paths, app_file = __file__)
> File "/usr/share/phatch/phatch/app.py", line 203, in main
> from core.settings import create_settings
> File "/usr/share/phatch/phatch/core/settings.py", line 23, in <module>
> from pil import IMAGE_READ_EXTENSIONS
> File "/usr/share/phatch/phatch/core/pil.py", line 39, in <module>
> from lib import openImage
> File "/usr/share/phatch/phatch/lib/openImage.py", line 25, in <module>
> import thumbnail
> File "/usr/share/phatch/phatch/lib/thumbnail.py", line 62, in <module>
> import PngImagePlugin
>ImportError: No module named PngImagePlugin

We probably need to add a file to the PILcompat directory of the source
package. It would be called PngImagePlugin and would contain:

from PIL.PngImagePlugin import *

Hey all

Here is a method to make symlinks, instead of copy the needed files:

$ sudo su -
# cd /usr/share/phatch/phatch
# for i in /usr/lib/python3/dist-packages/PIL/*.*; do ln -s "$i" "${i##*/}"; done

After that command, you will get this information:
ln: failed to create symbolic link ‘__init__.py’: File exists
Thats a good message :) so original file inside phatch folder won't be overwritten...

Hope there will be soon a fix for that.. but the above helped me to get phatch running...

Regards
thomi

Miguel Rozsas (marozsas) wrote :

I fixed my local installation of phatch by editing "/usr/share/phatch/phatch/lib/thumbnail.py" and changing "import PngImagePlugin" in line 62, to "from PIL import PngImagePlugin".

worked for me.

jldag (jlbusquet) wrote :

Yes it worked for me too.

wyderkat (wyderka-t) wrote :

Hi, if I cannot change "import Image" to "from PIL import Image" in my application, how should fix this Raring only issue?

I cannot make that change, because I have local file "TiffImagePlugin.py" which is modificated version from python-imaging, and "import Image" loads this file from local folder too. That "from PIL import Image" doesn't load it...

CANTE Pierre (pierrecante) wrote :

yes ! it works for me and my father too. The #39 comment is efficient, thanks !

michel_95 (michel-95) wrote :

me too wyderka-t and I am using raring.

Toshio Kuratomi (toshio) wrote :

I can't tell if phatch still has this problem from the comments but if needed, here's a patch for it:

http://pkgs.fedoraproject.org/cgit/phatch.git/plain/phatch-pillow.patch

When Fedora switched over to Pillow about the same time as Ubuntu, a group of us took care of generating all the patches to port code in Fedora to pillow. List of bugs here:

https://bugzilla.redhat.com/showdependencytree.cgi?id=894484&hide_resolved=0

We (the patchers) left it up to the package maintainers to submit bugs upstream. So theoretically, closed bugs on the tracker linked above should be upstreams which have accepted the pillow patches while open bugs are ones where Fedora is still carrying the patch locally (again, theoretically).

Neculai Dan Ciprian (enkumber) wrote :

@Toshio, how exactly can I apply this patch in Ubuntu ?

Hans Joachim Desserud (hjd) wrote :

I'm not that familiar with the package, so I can't tell for certain whether it has been fixed, but I tried phatch version 0.2.7.1-3 on Ubuntu 14.04 which installed and started without any error messages. From what I see from the comments, it seems like phatch would simply crash on startup, so maybe this is fixed. I also see that the changelog talks about fixes for python-imaging in both 0.2.7.1-2 and 0.2.7.1-3, see http://changelogs.ubuntu.com/changelogs/pool/universe/p/phatch/phatch_0.2.7.1-3/changelog

Rolf Leggewie (r0lf) wrote :

raring has seen the end of its life and is no longer receiving any updates. Marking the raring task for this ticket as "Won't Fix".

Changed in phatch (Ubuntu Raring):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers