Comment 5 for bug 1247861

PS 5.6 (and PXC 5.6) have this fixed correctly:

Package: percona-server-client-5.6
Architecture: any
Depends: debianutils (>=1.6), libdbi-perl, percona-server-common-5.6 (>= ${source:Version}), libmysqlclient18.1, ${shlib:Depends}, ${misc:Depends}

(ie. they are not dependent on specific version of libmysqlclient18.1
)
Same will need to be ported to 5.5 versions.