innobackupex does not copy non-InnoDB files when applying incremental backups

Bug #759701 reported by Valentine Gostev on 2011-04-13
44
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Percona XtraBackup moved to https://jira.percona.com/projects/PXB
Fix Released
Critical
Alexey Kopytov
1.6
Fix Released
Critical
Alexey Kopytov
2.0
Fix Released
Critical
Alexey Kopytov

Bug Description

When prepraing an incremental backups, innobackupex should copy all non-InnoDB files (including .frm files and non-InnoDB tables) to the full backup directory. Otherwise, any changes to .frm and/or non-InnoDB tables made between full and incremental backups lead to unusable backups.

Related branches

tags: added: incremental innobackupex myisam
Changed in percona-xtrabackup:
importance: Undecided → Critical
assignee: nobody → Valentine Gostev (core-longbow)
milestone: none → 1.7
Changed in percona-xtrabackup:
status: New → Confirmed
assignee: Valentine Gostev (core-longbow) → Vadim Tkachenko (vadim-tk)
Stewart Smith (stewart) wrote :

Vadim, is this on your radar at all or shall I reassign?

Changed in percona-xtrabackup:
status: Confirmed → Triaged
Vadim Tkachenko (vadim-tk) wrote :

ok,

proper fix for this bug also requires copying MyISAM files back to full directory.
This logic is not implemented in innobackupex yet.

I un-assign bug from myself.

Changed in percona-xtrabackup:
assignee: Vadim Tkachenko (vadim-tk) → nobody
Changed in percona-xtrabackup:
assignee: nobody → Valentine Gostev (longbow)
Stewart Smith (stewart) wrote :

Valentine, does this mean you're working on a real fix?

Valentine Gostev (longbow) wrote :

Stewart, yes, I have an idea about this. We have a copy-back function which places files back to mysql datadir - probably part of that code could be re-used for copying non-InnoDB files from inc to base basckup dir.

Changed in percona-xtrabackup:
status: Triaged → In Progress
summary: - Changes to MyISAM tables lost during incremental backups
+ innobackupex does not copy non-InnoDB files when applying incremental
+ backups
description: updated
Alexey Kopytov (akopytov) wrote :

See also bug #903984.

tags: added: cr i20511
removed: incremental innobackupex myisam
pservit (pservit) wrote :

Shouldn't innobackupex delete files for tables dropped between incremental backups ?

On 24.02.12 0:43, pservit wrote:
> Shouldn't innobackupex delete files for tables dropped between
> incremental backups ?
>

Yes, that's https://bugs.launchpad.net/percona-xtrabackup/+bug/856400

Which is a lower priority, because leaving stale tables is probably a
lesser evil than not copying newly created ones.

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PXB-216

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers