FR: split innodb_flush_method into two parameters

Bug #314510 reported by Baron Schwartz on 2009-01-06
4
Affects Status Importance Assigned to Milestone
Percona Server
Wishlist
Unassigned
Percona patches
Invalid
Medium
Unassigned

Bug Description

It would be nice to be able to set the open options on the data and log files separately. The current combinations are weird: some affect both files, some affect the logs, some affect only the data files. Why not just make two parameters and be done with it already?

Peter's additional comment:

Also the old parameter could actually set both parameters if it is set so it is clear what different values set them to.

please specify parameters names before implementation

Changed in percona-patches:
assignee: nobody → yasufumi-kinoshita
importance: Undecided → Medium
status: New → Confirmed
Changed in percona-patches:
status: Confirmed → Incomplete
Baron Schwartz (baron-xaprb) wrote :

I am not sure whether this should go into XtraDB only, or into our builds without XtraDB...

if it goes into the builds that have InnoDB, then:

innodb_datafile_flush_method
innodb_logfile_flush_method

if it goes into XtraDB, then those parameters should start with xtradb_ instead.

Xaprb,

Generally I'd call them innodb_XXX for simplicity reasons - we call
all parameters Innodb. Also we may want to backport some of the
changes to 5.0... and this is driven by customer feedback.

Wednesday, January 7, 2009, 5:06:16 AM, you wrote:

> I am not sure whether this should go into XtraDB only, or into our
> builds without XtraDB...

> if it goes into the builds that have InnoDB, then:

> innodb_datafile_flush_method
> innodb_logfile_flush_method

> if it goes into XtraDB, then those parameters should start with xtradb_
> instead.

--
Peter Zaitsev, CEO, Percona Inc.
Tel: +1 888 401 3401 ext 501
24/7 Emergency Line +1 888 401 3401 ext 911
Our Services: http://www.percona.com/services.html
Our Blog: http://www.mysqlperformanceblog.com/

Peter,

Also by plugin design all variables to related to plugin should start
with PLAGINNAME_

so as far as internally we keep plugin name innodb - all variables start
innodb_.

to move to xtradb_ naming we should rename plugin and therefore all
variables will be renamed, that will require a lot of work to handle
properly.

Peter Zaitsev wrote:
> Xaprb,
>
> Generally I'd call them innodb_XXX for simplicity reasons - we call
> all parameters Innodb. Also we may want to backport some of the
> changes to 5.0... and this is driven by customer feedback.
>
> Wednesday, January 7, 2009, 5:06:16 AM, you wrote:
>
>> I am not sure whether this should go into XtraDB only, or into our
>> builds without XtraDB...
>
>> if it goes into the builds that have InnoDB, then:
>
>> innodb_datafile_flush_method
>> innodb_logfile_flush_method
>
>> if it goes into XtraDB, then those parameters should start with xtradb_
>> instead.
>
>
>
>

--
Vadim Tkachenko, CTO
Percona Inc.
ICQ: 369-510-335, Skype: vadimtk153, Phone +1-888-401-3403
MySQL Performance Blog - http://www.mysqlperformanceblog.com
MySQL Consulting http://www.percona.com/

Stewart Smith (stewart) wrote :

Moving to Wishlist item for Percona Server.

Changed in percona-server:
status: New → Triaged
importance: Undecided → Wishlist
Changed in percona-patches:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers