Comment 3 for bug 584070

what the time for 1.0.11-2 release.

2010-05-27

************************************************************************************************************
电话:13688406298

Email:<email address hidden>

四川中央音乐平台

本邮件及其附件含有华为公司的保密信息,仅限于发送给上面地址中列出的个人或群组。
止任何其他人以任何形式使用(包括但不限于全部或部分地泄露、复制、或散发)本邮件中
的信息。如果您错收了本邮件,请您立即电话或邮件通知发件人并删除本邮件!
This e-mail and its attachments contain confidential information from HUAWEI, which
is intended only for the person or entity whose address is listed above. Any use of the
information contained herein in any way (including, but not limited to, total or partial
disclosure, reproduction, or dissemination) by persons other than the intended
recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender by
phone or email immediately and delete it!
************************************************************************************************************

发件人: Paul McCullagh
发送时间: 2010-05-26 19:10:57
收件人: limohao
抄送:
主题: [Bug 584070] Re: pbxt-1.0.11-pre-ga does not work with mysql 5.1.47

The problem was a hack that was put in to avoid a deadlock with
LOCK_plugin. MySQL 5.1.47 added a bug fix for LOCK_plugin, which cause
the hack to hang.
Anyway, the bug is now fixed in version 1.0.11-2.
** Branch linked: lp:pbxt
** Changed in: pbxt
       Status: In Progress => Fix Committed
--
pbxt-1.0.11-pre-ga does not work with mysql 5.1.47
https://bugs.launchpad.net/bugs/584070
You received this bug notification because you are a direct subscriber
of the bug.
Status in PrimeBase XT: Fix Committed
Bug description:
I am use pbxt engine in mysql new project .
pbxt load as plugin .
compile options
./configure --with-mysql=/opt/mysql5.1.47 --with-plugindir=/opt/xtradb/lib/mysql/plugin
when exec
INSTALL PLUGIN pbxt SONAME 'libpbxt.so';
the mysql client is locked and the whole database is locked
mysql error log
100522 11:18:32 [Note] PrimeBase XT (PBXT) Engine 1.0.11 Pre-GA loaded...
100522 11:18:32 [Note] Paul McCullagh, PrimeBase Technologies GmbH, http://www.primebase.org
if compile with mysql5.1.46. it's works filne.
./configure --with-mysql=/opt/mysql5.1.46 --with-plugindir=/opt/xtradb/lib/mysql/plugin
INSTALL PLUGIN pbxt SONAME 'libpbxt.so';
Query OK, 0 rows affected (0.05 sec)
To unsubscribe from this bug, go to:
https://bugs.launchpad.net/pbxt/+bug/584070/+subscribe