Put "Connect To Server..." In the Network section

Bug #995762 reported by Daniel Fore on 2012-05-07
30
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Files
Fix Released
Wishlist
Albert

Bug Description

A much more obvious location for "Connect To Server..." Would be in the Network section.

Related branches

This would be nice

Sounds bitesize

Changed in pantheon-files:
milestone: none → luna-beta1
tags: added: bitesize
Daniel Fore (danrabbit) wrote :

This is not essential for beta. It's enhanced/altered functionality, not really a bug.

Changed in pantheon-files:
milestone: luna-beta1 → none
Cody Garver (codygarver) on 2012-08-12
tags: added: networking sidebar
Changed in pantheon-files:
status: New → Confirmed
importance: Undecided → Wishlist
Albert (optimisme) on 2013-05-24
Changed in pantheon-files:
status: Confirmed → In Progress
assignee: nobody → Albert (optimisme)
Albert (optimisme) wrote :

Changes:

- Added one plugin named "cserver" that shows one "Connect to Server..." button while navigating the "Entire network" folder (like the "Empty Trash" one while navigating the "Trash" folder)

- Added one button "Connect to Server..." at the right button menu of sidebar' "Entire network" entry (so the plugin is not really necessary)

- Removed the "Connect to Server..." button at the top right menu near the location bar.

Albert (optimisme) wrote :

Hi Cody,

I got a fresh copy of pantheon-files, removed branches for bugs 998555 and 995762 and committed the changes again.

I hope there will be no problems merging the branches now.

Remember that 995762 has new files for the "cserver" plugin at:

pantheon-files-fix-995762/plugins/marlin-cserver/

I added these files with "bzr add plugins/marlin-cserver/*"

Albert (optimisme) wrote :

Hi Victor,

- I added your code suggestions and I am using the new "gof_file_is_network_uri_scheme" and "gof_file_is_smb_uri_scheme" functions

- The plugin is also using "network-places" instead of "marlin-cserver"

- I fixed the bug number "998555" in this code and removed the other branch because I don't want to fix merge problems with small changes.

Albert (optimisme) wrote :

Hi Cody,

When accepted this bug will also fix: https://bugs.launchpad.net/pantheon-files/+bug/998555

Cody Garver (codygarver) on 2013-05-27
tags: removed: sidebar
description: updated
Changed in pantheon-files:
milestone: none → luna-rc1
RabbitBot (rabbitbot-a) on 2013-05-27
Changed in pantheon-files:
status: In Progress → Fix Committed
Changed in pantheon-files:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints