sourceId and other constraints for getUserMedia are ignored

Bug #1535818 reported by Chris Coulson on 2016-01-19
50
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Oxide
Medium
Alexandre Abreu

Bug Description

We currently don't allow sites to select specific capture devices or specify other constraints. Eg, try https://webrtc.github.io/samples/src/content/devices/input-output/

Changed in oxide:
importance: Undecided → Medium
status: New → Triaged
Changed in oxide:
milestone: none → branch-1.15
Peter Bittner (peter-bittner) wrote :

The issue of switching cameras (not available in webapp-container) is still not fixed with OTA-10.

Related bugs: bug #1554244, bug #1554603

Chris Coulson (chrisccoulson) wrote :

Hence why the bug is not marked as Fix Released :)

(There's generally no need to comment on an open bug to tell us that the bug still exists)

Peter Bittner (peter-bittner) wrote :

Sorry, Chris. This was meant as a reminder on what this bug is really about on the user end.

No camera selection = No WebRTC powered video calling / video conferencing app = one class of potential "killer apps" less for Ubuntu Touch = Less reasons for users to ask for Ubuntu Touch as a platform = Less reasons for operators to offer Ubuntu Touch with their phones.

More rant on https://lists.launchpad.net/ubuntu-phone/msg19510.html

Changed in oxide:
assignee: nobody → Alexandre Abreu (abreu-alexandre)
Changed in oxide:
status: Triaged → In Progress
Changed in oxide:
status: In Progress → Fix Released
Alan Bell (alanbell) wrote :

this isn't working in OTA11, you can't switch cameras using in-page web controls, you can go to the privacy settings in the browser preferences and set the default camera to front and reload the page, but you seem to have to do that every time you start the browser.
tried using talky.io and the samples page https://webrtc.github.io/samples/src/content/devices/input-output/

Olivier Tilloy (osomon) wrote :

This was fixed in oxide 1.15, which isn’t in OTA-11. It will be in OTA-12.

Peter Bittner (peter-bittner) wrote :

I can confirm that this specific issue is now fixed (OTA-12, OTA-13). Unfortunately, WebRTC applications such as Talky.io and Appear.in are still non-functional as they now suffer from an upside-down image displayed from the person using Ubuntu Touch. Tested with bq Aquaris E5 Ubuntu Edition.

See https://bugs.launchpad.net/oxide/+bug/1535820

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers