Bad archive mirror using juju.preceed file

Bug #884133 reported by Shang Wu on 2011-10-31
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Orchestra
Undecided
Unassigned

Bug Description

I am testing Orchestra to deploy Openstack via juju these days, but I ran into a bug with the default juju.preceed file.

To reproduce:
1. Setup the Orchestra server
2. Add the system using the following command:

sudo cobbler system add --name="oneiric02.shang.com" --mac-address="08:00:27:0A:31:EC" --ip-address="192.168.10.106" --dns-name="oneiric02.shang.com" --hostname="oneiric02.shang.com" --profile="oneiric-x86_64-juju" --mgmt-classes="orchestra-juju-available" --kopts=" DEBCONF_DEBUG=developer netcfg/dhcp_timeout=120 netcfg/choose_interface=eth0"

3. PXE boot the system
4. The installation will stop at "Choose a mirror of the Ubuntu archive"

Attach the juju.preseed file from /var/lib/orchestra/kickstarts and the installation syslog.

It might be related to this bug:
https://bugs.launchpad.net/ubuntu/+source/choose-mirror/+bug/600789

Shang Wu (shangwu) wrote :
Shang Wu (shangwu) wrote :
Shang Wu (shangwu) wrote :

I should also add using the /var/lib/cobbler/kickstarts/ubuntu-server.preseed works just fine.

Andres Rodriguez (andreserl) wrote :

Hi Shang,

I'm guessing this has something to do with the proxy. Could you please provide the following information:

1. Did you import a new ISO or you used an old one?
2. When using the juju.preseed, please provide the output preseed file, you can obtain this by doing:

sudo cobbler system getks --name=oneiric02.shang.com

3. Check /var/log/squid/access.log and verify it the installation has used the squid proxy.

Thank you again for reporting this bug.

Andres

Shang Wu (shangwu) wrote :

1. I am aware of the Bug #882726, tried the workaround:

RELEASES=$(distro-info --supported)
ARCHES="x86_64 i386"
KSDIR="/var/lib/orchestra/kickstarts"
for r in $RELEASES; do
  for a in $ARCHES; do
    sudo cobbler profile edit --name="$r-$a" \
        --kickstart="$KSDIR/orchestra.preseed"
  done
done

(not sure if that will refresh the old images tho)

I will try to run the sudo orchestra-import-isos again.

2.
The preseed file is here: http://paste.ubuntu.com/724377/

3. It is not using the squid. i.e. nothing in the access.log. I have start the squid manually: sudo service squid start
But the same error. This is the part that I am not sure...

Shang Wu (shangwu) wrote :

I think the issue is that squid does not start and it doesn't like my oneiric-server as the hostname. After changing it, squid starts normally and system seems install fine now.

Thanks Andres!

Changed in orchestra:
status: New → Invalid
Dixon Dick (dixon1e) wrote :

Not sure this is related, but in my PXE attempt to get Orchestra to startup an oneiric system, I get "Bad Mirror Archive."

The command that fails in the syslog is:

wget -q http://archive.ubuntu.com/ubuntu/dists/oneiric/Release -O - | grep -E '^(Suite|Codename):'

which correctly (I think) returns the strings:

Suite: oneiric
Codename: oneiric

But the log clearly says as a result of this command:

INFO: MIrror does not have any suite sym...

and then it issues the command again and:

WARNING: **** mirror does not support the specified release.

What's missing here? What's wrong? Looking at your idea, I restarted my squid but that did not help. What did you mean by "doesn't like my oneiric-server as the hostname" ?

Blasterjr (blasterjr) wrote :

dixon1e, if you're still having this problem, it may be an issue with SQUID, as soon as i went into Orchestra/Cobbler and commented out the "Proxy" line, my stuff downloaded just fine and was able to validate, not sure why as everything works fine network wise on my main machine, i just setup a small NAT/ICS to test this.

Blasterjr (blasterjr) wrote :

Sorry, let me correct that, in the Snippets section under the orchestra_proxy section

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers