"d-i mirror/*" does not work on presseding

Bug #600789 reported by C de-Avillez on 2010-07-01
56
This bug affects 10 people
Affects Status Importance Assigned to Milestone
choose-mirror (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: debian-installer

We have been using automated installs for the QA UEC rig since beginning of the Lucid cycle. Specific to this bug, we set 'd-i mirror/*" to point to a local server with the ISO image. Today I tried my first UEC install for Maverick (Alpha 2). The installation failed with the following relevant lines:

Jul 1 14:52:46 main-menu[713]: INFO: Menu item 'choose-mirror' selected
Jul 1 14:52:46 anna-install: Queueing udeb apt-mirror-setup for later installation
Jul 1 14:52:46 choose-mirror[3103]: DEBUG: command: wget -q http://gb.archive.ubuntu.com/ubuntu//dists/maverick/Release -O - | grep -E '^(Suite|Codename):'
Jul 1 14:53:07 choose-mirror[3103]: INFO: mirror does not have any suite symlinks
Jul 1 14:53:07 choose-mirror[3103]: DEBUG: command: wget -q http://gb.archive.ubuntu.com/ubuntu//dists/maverick/Release -O - | grep -E '^(Suite|Codename):'
Jul 1 14:53:28 choose-mirror[3103]: WARNING **: mirror does not support the specified release (maverick)
Jul 1 14:56:49 main-menu[713]: (process:3096): wget: cannot connect to remote host (194.169.254.10): Connection timed out
Jul 1 14:56:49 main-menu[713]: (process:3096): wget: cannot connect to remote host (194.169.254.10): Connection timed out
Jul 1 14:56:49 main-menu[713]: INFO: Menu item 'choose-mirror' succeeded but requested to be left unconfigured.

Of course, after this error, automation was shot.

I looked around, but could not find any reference to a change in debian-installer that would affect this. Given the first line above, I decided to change all references to 'd-i mirror/' to 'd-i choose-mirror/'. I was then able to PXE-boot and install without any further (visible) errors.

I am also attaching 'installer.tar', a tarball of the successful install, and 'failed-d-i-syslog.log', the syslog of a failed install with the above problem.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: debian-installer (not installed)
ProcVersionSignature: Ubuntu 2.6.35-6.9-generic 2.6.35-rc3
Uname: Linux 2.6.35-6-generic x86_64
Architecture: amd64
CheckboxSubmission: 48216eabc5cef2006b8478621d301a28
CheckboxSystem: d00f84de8a555815fa1c4660280da308
Date: Thu Jul 1 15:15:09 2010
EcryptfsInUse: Yes
InstallationMedia: Ubuntu-Server 10.04 "Lucid Lynx" - Beta amd64 (20100406.1)
MachineType: Dell Inc. Inspiron 1721
MemoryUsage:
 total used free shared buffers cached
 Mem: 3796196 3520572 275624 0 124924 2251160
 -/+ buffers/cache: 1144488 2651708
 Swap: 3903484 2940 3900544
ProcCmdLine: BOOT_IMAGE=/vmlinuz-2.6.35-6-generic root=/dev/mapper/hostname-root ro crashkernel=384M-2G:64M,2G-:128M
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: debian-installer
dmi.bios.date: 04/21/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A07
dmi.board.name: 0RT951
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA07:bd04/21/2008:svnDellInc.:pnInspiron1721:pvr:rvnDellInc.:rn0RT951:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Inspiron 1721
dmi.sys.vendor: Dell Inc.

C de-Avillez (hggdh2) wrote :
C de-Avillez (hggdh2) wrote :
C de-Avillez (hggdh2) wrote :
C de-Avillez (hggdh2) wrote :

a chat with cjwatson pointed me to a change:

hggdh: you might need to set mirror/country to "manual" these days, not to "enter information manually"
hggdh: but in any case, for debugging, it's best if I get a full (not excerpted) syslog of an installation run with DEBCONF_DEBUG=developer passed as a kernel parameter

So... I changed mirror/country to 'string manual' and again PXE-booted the system -- it went all the way through, no error. I will try again as it was.

C de-Avillez (hggdh2) wrote :

I ran another PXE install with 'DEBCONF_DEBUG=developer, while having the 'd-i mirror/* left as is:

d-i mirror/country string enter information manually
d-i mirror/http/hostname string {% if iso_name is defined %} 10.55.55.1 {% else %} archive.ubuntu.com {% endif %}
d-i mirror/http/directory string {% if iso_name is defined %} /eucalyptus-integration/isos/{{ iso_name }} {% else %} /ubuntu {% endif %}
d-i mirror/http/proxy string

I got the error (see syslog attached)

Colin Watson (cjwatson) on 2010-07-14
affects: debian-installer (Ubuntu) → choose-mirror (Ubuntu)
Srivatsa Kanchi R (srivatsak) wrote :

This is seen while pxe booting xubuntu. as said above,
if provided with DEBCONF_DEBUG=developer, its works!

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in choose-mirror (Ubuntu):
status: New → Confirmed
Dixon Dick (dixon1e) wrote :

My PXE boot attempts are failing on oneiric with same error. The mirror/country string is set to manual, this does not fix the problem. Also tried an apt-mirror to local, still failed. Also tried the oneiric ISO mounted in /var/www/ubuntu, still failed. Two days at this, still can't PXE boot.

The failing command is:

wget -q http://archive.ubuntu.com/ubuntu/dists/oneiric/Release -O - | grep -E '^(Suite|Codename):'

When I execute this same command on the machine trying to PXE it returns:

Suite: oneiric
Codename: oneiric

Carlos Hernandez (carher) wrote :

I'm observing a similar error while trying to use netboot images http://ports.ubuntu.com/ubuntu-ports/dists/precise/main/installer-armel/current/images/omap/netboot/ on beagleXM rev C.

I initially tried loading preseed.cfg from the network and it did not work. Log is available at http://pastebin.com/jzTVG5Sf

I then added preseed.cfg to the uInitrd image but that did not work either. Logs with DEBCONF_DEBUG=developer flag is available at http://pastebin.com/yriArCPb

I'm not sure if the problem is due to my proxy but if I use an Ubuntu PC on the same network and with the same proxy, I can get to ports.ubuntu.com as shown below

@@ wget http://ports.ubuntu.com/ubuntu-ports/dists/precise/Release
--2012-04-25 12:48:46-- http://ports.ubuntu.com/ubuntu-ports/dists/precise/Release
Resolving webproxy.ext.ti.com... 192.91.66.189, 192.94.92.11, 192.94.92.14, ...
Connecting to webproxy.ext.ti.com|192.91.66.189|:80... connected.
Proxy request sent, awaiting response... 200 OK
Length: 49563 (48K) [text/plain]
Saving to: `Release'

100%[==========================================================================================================>] 49,563 245K/s in 0.2s

2012-04-25 12:48:47 (245 KB/s) - `Release' saved [49563/49563]

Mattias Andersson (matand) wrote :

I'm having the same problem when PXE-booting nodes in the latest 13.04 release of MAAS (after following the install instructions.) I can confirm that changing all references of 'mirror' to 'choose-mirror' in the file /usr/share/maas/preseeds/generic solves the problem. This needs to be fixed.

Dale Noe (dnoe) wrote :

I ran into this as well on saucy. Changing "mirror" to "choose-mirror" in the generic preseed file fixed it, and now the pxe boot install process works.

narasimha (narasimha-sv) wrote :

I have changed the mirror to choose-mirror in the preseed file, but still i am facing the same issue

Sciron (sciron64) wrote :

Having the same issue (same log data for us.archive.ubuntu.com with Trusty) as the OP with MAAS, I executed:
sed -i '@s@mirror@choose-mirror@g' /etc/maas/preseeds/generic

which resolved the issue.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers