Grizzly testing packages : python-quantumclient installation/upgrade fails

Bug #1165059 reported by Nerijus Bendziunas on 2013-04-05
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
openstack-ubuntu-testing
Undecided
Chuck Short

Bug Description

OS: Ubuntu 12.03 x86_64
Packages: ppa:openstack-ubuntu-testing/grizzly-trunk-testing

How to reproduce:
# apt-get update && apt-get dist-upgrade
...
The following packages will be upgraded:
  python-quantumclient
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
3 not fully installed or removed.
Need to get 0 B/69.3 kB of archives.
After this operation, 1,024 B disk space will be freed.
Do you want to continue [Y/n]? y
E: changelog for this version is not (yet) available; try https://launchpad.net/ubuntu/+source/python-quantumclient/+changelog
Reading changelogs... Done
(Reading database ... 440788 files and directories currently installed.)
Preparing to replace python-quantumclient 2:2.2.0.17.g3277d38+git201303290401~precise-0ubuntu1 (using .../python-quantumclient_2%3a2.2.1.7.g22fd452+git201304040531~precise-0ubuntu1_all.deb) ...
Unpacking replacement python-quantumclient ...
dpkg: error processing /var/cache/apt/archives/python-quantumclient_2%3a2.2.1.7.g22fd452+git201304040531~precise-0ubuntu1_all.deb (--unpack):
 trying to overwrite '/usr/share/pyshared/tests/__init__.py', which is also in package python-boto 2.2.2-0ubuntu2
Errors were encountered while processing:
 /var/cache/apt/archives/python-quantumclient_2%3a2.2.1.7.g22fd452+git201304040531~precise-0ubuntu1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
zsh: exit 100 apt-get dist-upgrade

Aimon Bustardo (aimonb) wrote :

I get same on Precise:

As of today the repository is still broken. Getting

Preparing to replace python-quantumclient 1:2.2.0-0ubuntu1~cloud0 (using .../python-quantumclient_2%3a2.2.1.7.g22fd452+git201304040531~precise-0ubuntu1_all.deb) ...
Unpacking replacement python-quantumclient ...
dpkg: error processing /var/cache/apt/archives/python-quantumclient_2%3a2.2.1.7.g22fd452+git201304040531~precise-0ubuntu1_all.deb (--unpack):
 trying to overwrite '/usr/share/pyshared/tests/__init__.py', which is also in package python-boto 2.2.2-0ubuntu2

Aimon Bustardo (aimonb) wrote :

Note that python-ceilometer had same issue recently: https://bugs.launchpad.net/ceilometer/+bug/1102110. Perhaps fix for that will help here..

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in python-quantumclient (Ubuntu):
status: New → Confirmed
Aimon Bustardo (aimonb) on 2013-04-06
Changed in quantum:
status: New → Confirmed
Chuck Short (zulcss) on 2013-04-07
affects: quantum → python-quantumclient

Fix proposed to branch: master
Review: https://review.openstack.org/26306

Changed in python-quantumclient:
assignee: nobody → Chuck Short (zulcss)
status: Confirmed → In Progress
Aimon Bustardo (aimonb) wrote :

I no longer have this issue as of 04/08 build 2:2.2.1.11.ge901c5f+git201304081157~precise-0ubuntu1 .

Changed in python-quantumclient (Ubuntu):
status: Confirmed → In Progress
no longer affects: python-quantumclient (Ubuntu)
Aimon Bustardo (aimonb) wrote :

Appears the original 'Affects' was refined. I removed the one I added so we dont have two of the same entry.

Aimon Bustardo (aimonb) wrote :

Version 2:2.2.1.13.g2a75275+git201304081831~precise-0ubuntu1 also ok.

I confirm this. Version 2:2.2.1.13.g2a75275+git201304081831~precise-0ubuntu1 is OK.

Akihiro Motoki (amotoki) wrote :

It is unrelated to the upstream neutronclient.

affects: python-neutronclient → openstack-ubuntu-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers