Copyright 2012 statements need to be added to many documents

Bug #916953 reported by Anne Gentle on 2012-01-15
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
High
Emma Grace Steimann
OpenStack Identity (keystone)
High
Shevek
OpenStack Object Storage (swift)
Undecided
Anne Gentle
neutron
Medium
dan wendlandt
openstack-manuals
Medium
Unassigned

Bug Description

Now that it's the new year, document files should be updated with the year 2012.

Devin Carlen (devcamcar) on 2012-01-16
Changed in horizon:
status: New → Confirmed
importance: Undecided → High
milestone: none → essex-4
dan wendlandt (danwent) on 2012-01-16
Changed in quantum:
status: New → In Progress
milestone: none → essex-3
Razique Mahroua (razique) wrote :

How would you do that Anne, so maybe I could give a hand here :)

Mark McLoughlin (markmc) wrote :

The advice Red Hat have been given is that the year in a Copyright notice is the "year of publication" and that one should only update the year (to the current year) when one makes non-trivial modifications to a file.

Mark McLoughlin (markmc) wrote :

s/advice Red Hat have been given/advice Red Hat *developers* have been given/

Russell Bryant (russellb) wrote :

+1 to Mark's statement. That is the advice that I have followed from before joining Red Hat, as well.

There may be top level documentation that warrants a change if it's referring to the copyright of OpenStack itself and not the documentation. There's probably a lot of code that could have the date updated, too, but I don't think it should be a giant widespread search and replace.

+1 I am only putting 2012 on new files and updating to include 2012
when making major changes to files.

Cheers!
-jay

On Wed, Jan 18, 2012 at 9:27 AM, Russell Bryant
<email address hidden> wrote:
> +1 to Mark's statement.  That is the advice that I have followed from
> before joining Red Hat, as well.
>
> There may be top level documentation that warrants a change if it's
> referring to the copyright of OpenStack itself and not the
> documentation.  There's probably a lot of code that could have the date
> updated, too, but I don't think it should be a giant widespread search
> and replace.
>
> --
> You received this bug notification because you are subscribed to
> OpenStack Dashboard (Horizon).
> https://bugs.launchpad.net/bugs/916953
>
> Title:
>  Copyright 2012 statements need to be added to many documents
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/glance/+bug/916953/+subscriptions

dan wendlandt (danwent) on 2012-01-18
Changed in quantum:
assignee: nobody → dan wendlandt (danwent)
status: In Progress → Fix Committed
importance: Undecided → Medium
Brian Waldon (bcwaldon) on 2012-01-19
Changed in glance:
status: New → Triaged
importance: Undecided → Wishlist
no longer affects: glance
Thierry Carrez (ttx) on 2012-01-23
Changed in nova:
importance: Undecided → Wishlist
status: New → Triaged
Thierry Carrez (ttx) on 2012-01-25
Changed in quantum:
status: Fix Committed → Fix Released
Brian Waldon (bcwaldon) on 2012-01-29
no longer affects: nova
Changed in horizon:
assignee: nobody → Emma Grace Steimann (emmasteimann)
Anne Gentle (annegentle) on 2012-02-02
tags: added: low-hanging-fruit
Changed in openstack-manuals:
status: New → In Progress
importance: Undecided → Medium
Changed in swift:
assignee: nobody → Somar Musa (somarsom2000)

Fix proposed to branch: master
Review: https://review.openstack.org/3785

Changed in horizon:
status: Confirmed → In Progress
Changed in swift:
assignee: Somar Musa (somarsom2000) → nobody
Joseph Heck (heckj) on 2012-02-09
Changed in keystone:
importance: Undecided → High
assignee: nobody → Joseph Heck (heckj)
milestone: none → essex-4
status: New → Confirmed
tags: added: redux
Changed in keystone:
assignee: Joseph Heck (heckj) → nobody

Reviewed: https://review.openstack.org/3785
Committed: http://github.com/openstack/horizon/commit/6516c3890bf2695bbccbe2d2067fc0a9c6dbbd31
Submitter: Jenkins
Branch: master

commit 6516c3890bf2695bbccbe2d2067fc0a9c6dbbd31
Author: Emma Steimann <email address hidden>
Date: Sat Feb 4 17:40:31 2012 -0600

    Updated Copyright dates to 2012.

      * fixes bug 916953

    Change-Id: I44bdbb735fa1ac068c38997844591c8f256c62fb

Changed in horizon:
status: In Progress → Fix Committed
Changed in keystone:
assignee: nobody → Shevek (r-launchpad-anarres-org)
status: Confirmed → In Progress
Joseph Heck (heckj) wrote :
Changed in keystone:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2012-02-29
Changed in keystone:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-02-29
Changed in horizon:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in keystone:
milestone: essex-4 → 2012.1
Thierry Carrez (ttx) on 2012-04-05
Changed in horizon:
milestone: essex-4 → 2012.1
Thierry Carrez (ttx) on 2012-04-05
Changed in quantum:
milestone: essex-3 → 2012.1
Anne Gentle (annegentle) on 2012-04-23
Changed in swift:
status: New → Fix Released
assignee: nobody → Anne Gentle (annegentle)
Anne Gentle (annegentle) on 2012-04-24
Changed in openstack-manuals:
status: In Progress → Fix Released
Thierry Carrez (ttx) on 2012-05-29
Changed in swift:
milestone: none → 1.5.0
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers