[I18N]localized Chinese po file of api-quick-start is broken

Bug #1669037 reported by JunhuiHe
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
openstack i18n
Invalid
Undecided
JunhuiHe

Bug Description

Locale:Chinese(zh_CN)
Steps to reproduce:
1.add language setting in api-site\api-quick-start\source\conf.py
language = 'zh_CN'
2.add extra packages to enable zh_CN in sphinx.
git clone https://github.com/bosbyj/sphinx.search.zh_CN

3.run building html with command
tox -e api-quick-start

4.error occurred and the build

Error Message:
Inline interpreted text or hprase reference start-string without end-string.

JunhuiHe (junhuihe)
Changed in openstack-api-site:
assignee: nobody → JunhuiHe (junhuihe)
Revision history for this message
Ian Y. Choi (ianychoi) wrote :

I do not know why it is a bug.

You can see Chinese (zh_CN) version + all supported translated versions of api-quick-start by executing

$ tox -e publishlang-api

The result will be publish-docs/api-ref/zh_CN/api-guide/quick-start/index.html for zh_CN.

Revision history for this message
JunhuiHe (junhuihe) wrote :

Unfortunately master code is broken, please refer to my log attached.
I also publish the right po file fyi.

Revision history for this message
JunhuiHe (junhuihe) wrote :

Unfortunately master code is broken, please refer to my log attached.

Revision history for this message
Ian Y. Choi (ianychoi) wrote :

Thanks.

One note is that the errors using extra packages are difficult to tell that those errors are bugs.

I have seen https://review.openstack.org/#/c/439979/ and translation changes look fine, you need to contribute translations through translate.openstack.org, not directly change PO files in each project repository.

The main reason why OpenStack I18n team does like the style is that translate.o.o supports translation memory and directly editing on PO files would not reflect to current *big* translation platform.

I explained it to @zzxwill, an I18n Chinese (zh_CN) language coordinator. If you need more help, please tell me or him.

With many thanks,

/Ian

Revision history for this message
JunhuiHe (junhuihe) wrote :

Appreciated for your comments, I may submit my changes to Zanata sometime later.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Change abandoned on api-site (master)

Change abandoned by jian.song (<email address hidden>) on branch: master
Review: https://review.openstack.org/439979

Revision history for this message
Ian Y. Choi (ianychoi) wrote :

@junhuihe, thanks a lot for such following.

I want you to change it since I think you and jian.song have the credit for such change suggestion, but it you think submitting into Zanata by you would take time and if you are fine for others to change translations in Zanata, then I think @zzxwill will kindly help it.

affects: openstack-api-site → openstack-i18n
tags: added: simplified-chinese
Revision history for this message
tl chen (vuuv) wrote :

seems fixed in zanata? should we close this issue?

tl chen (vuuv)
Changed in openstack-i18n:
status: New → Fix Committed
Revision history for this message
Ian Y. Choi (ianychoi) wrote :

This is not an I18n bug but @vuuv helped for better Chinese translation.

Changed in openstack-i18n:
status: Fix Committed → Fix Released
status: Fix Released → Invalid
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers