"Unresponsive script" warning

Bug #1314713 reported by Kevin L. Mitchell on 2014-04-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Core Infrastructure
Confirmed
Undecided
Unassigned

Bug Description

I'm trying to review https://review.openstack.org/#/c/44715/8 and when I go to look at the nova/tests/db/test_db_api.py by clicking on that link under "File Path" in the review table, I get an "Unresponsive script" warning from my browser; clicking on the "Continue" option in the warning pop-up does not help. I've also tried the "Side-by-Side" and "Unified" links from that table, even the "All Side-by-Side" and "All Unified" links. The same problem also occurs if I try to get there by clicking the "next" link while looking at the commit message. I have tried restarting my browser, but the same thing still happens. I'm also having the issue trying to look at the same file in patch set 7, which I had previously reviewed.

This is happening with Firefox 28.0 running on a Fedora 19 x86_64 system.

The script that's being referenced is:

        https://review.openstack.org/gerrit_ui/89B6B1C2255AB537598BF6FC8F36BB0D.cache.html:164

My "Change View" setting is "Server Default (Old Screen)".

Any ideas? The change is a +14-12, and I can't seem to look at the file in *any* patch set on this review anymore.

Further investigation shows that the same problem occurs with the same file in https://review.openstack.org/#/c/44714 and https://review.openstack.org/#/c/44716/ so it seems to be a problem specific to the test_db_api.py file itself.

Khai Do (zaro0508) on 2014-04-30
Changed in openstack-ci:
assignee: nobody → Khai Do (zaro0508)
David Kranz (david-kranz) wrote :

Works with Chrome.

Anita Kuno (anteaya) on 2014-04-30
Changed in openstack-ci:
status: New → Confirmed
Anita Kuno (anteaya) wrote :

I too confirm this is a bug in Firefox and the file opens in Chrome.

Khai Do (zaro0508) wrote :
Kevin L. Mitchell (klmitch) wrote :

A follow-up email to the gerrit mailing list thread mentioned different behavior when using the "new view". I tried out the new view on the problematic patches that originally sparked this bug report, and I can confirm that using the new view does allow me to review the change. That said, I don't really like the new view, so I'm only planning on switching to it when I have to in order to review a patch.

The thread poster also made an off-hand reference to a "huge file" constant, which the poster believes is set to 9,000 lines. Given that test_db_api.py is 7,000 lines and is having problems, we might want to consider making a local change to that constant—maybe 5,000 lines? Or was this, perhaps, set to a specific value in the previous gerrit configuration that was not copied in when we updated gerrit?

Khai Do (zaro0508) wrote :

From James Blair...

The upstream tracker would probably be a better place. We're only
running code that has landed upstream, so this is unlikely to be a local
bug (especially considering the behavior described). Gerrit's tracker
is here:

  https://code.google.com/p/gerrit/issues/list

To work around the immediate problem, I'd recommend downloading the
change locally with the "git fetch" and "git checkout" commands listed
on the page in Gerrit; you can then run "git diff" locally to see the
change.

-Jim

Changed in openstack-ci:
status: Confirmed → Invalid
status: Invalid → Confirmed
Khai Do (zaro0508) on 2014-05-02
Changed in openstack-ci:
assignee: Khai Do (zaro0508) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers