OpenLP - Worship Presentation Software

String Errors in OpenLP 1.9.5

Reported by Raoul Snyman on 2011-03-13
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
OpenLP
Low
Raoul Snyman

Bug Description

Any string errors in OpenLP 1.9.5 should be added as a comment on this ticket.

Raoul Snyman (raoul-snyman) wrote :

In openlp/core/ui/firsttimewizard.py, Line 199:

This wizard will help you to configure OpenLP for initial use. Click the next button below to start the process of selection your initial options.

tags: added: translation translation-error
Jonathan Corwin (j-corwin) wrote :

openlp/plugins/bibles/forms/bibleimportform.py:685 - bible should be Bible
openlp/plugins/bibles/forms/bibleimportform.py:748 - bible should be Bible
openlp/core/ui/mainwindow.py:442 - bible should be Bible
openlp/plugins/songs/forms/songexportform.py:185 - "Select the directory you want the songs to be saved.". Needs a "where" or trailing "in" think

Andreas Preikschat (googol) wrote :

openlp/plugins/bibles/lib/manager.py:267 should mention the possibility to use "," or "v" as separator (Genesis 1,3 = Genesis 1:3 = Genesis 1v3).

Jon Tibble (meths) wrote :

No it doesn't. Genesis 1,3 is Genesis chapters 1 and 3. We could add

                 'Book Chapter\n'
                 'Book Chapter-Chapter\n'
+ 'Book Chapter,Chapter\n'
                 'Book Chapter:Verse-Verse\n'

if you think it needs the extra example.

The comma as a verse separator is a translators issue (see the German regex and comment in bibles/lib/__init__.py)

Jonathan Corwin (j-corwin) wrote :

In plugins\media\lib\mediaitem.py, the two strings on lines 139 and 153 are currently using a translation from the Presentation plugin. Change these to one owned by itself.

Andreas Preikschat (googol) wrote :

John:
yeah... You are right, Genesis 1v3 is not the same as Genesis 1:3.

Cheers

Jonathan Corwin (j-corwin) wrote :

ui/mainwindow.py: Uncomment 432/433

Tim Bentley (trb143) wrote :

About Tab credits need to be aligned to the copyright text but as they are in a translate string.
Should this be a dictionary of translates to make for easier maintenance?

Changed in openlp:
assignee: nobody → Raoul Snyman (raoul-snyman)
Johan Mynhardt (johanmynhardt) wrote :

Missing translations:
+plugins/bibles/lib/mediaitem.py:
 - 195: advancedTab
 - 240: quickVersionLabel
 - 248: advancedVersionLabel

John Cegalis (jseagull1) wrote :

The last step of the wizard is labeled "Setting up and Importing" Openlp is not importing anything.
The bar shows Download complete and nothing is being downloaded
I suggest removing "and Importing" and "Download complete"

Tim Bentley (trb143) wrote :

#5 Done.

Andreas Preikschat (googol) wrote :

I think this is higher importance than "Low"!

I am just fixing tooltip strings and this will reset all tooltip string which are affected. Same with this bug... All strings affected will probably need to be re translated. And the release of Beta 1 is not more than a month ago. In favour of our translators:
1) Lets fix this (strings in general) *soon*
2) Notify them and possibly upload a "backup" of the old translations files, so they they do not have to translate
- Add a new Bible.
- Add a new Song.
- Add a new Image.
- Add a new Media.
....
again, just because we missed the period, instead may be able to do some copy and past.

Cheers

Andreas Preikschat (googol) wrote :

"Replace" strings in core/lib/ui are not Sentence case and do not end with a period (as these are tooltips)

Just an addition to my previous post:
I don't/didn't want to blame anybody, I just wanted to make clear how urgent I consider this bug. (I probably did add a few wrong strings myself. Who is perfect?)

Simon Scudder (samscudder) wrote :

openlp/plugins/bibles/bibleplugin.py : 95 - Should read ".... Bible verses ...."

reported above, but the line numbers changed:

openlp/plugins/bibles/forms/bibleimportform.py : 695 - should read "Starting Registering Bible..."
openlp/plugins/bibles/forms/bibleimportform.py : 758 - should read "Registered Bible. Please...."

Simon Scudder (samscudder) wrote :

openlp/core/ui/firsttimewizard.py : 202 - Type... it says "Click the next button below to start the process of selection your initial options". It should read "... process of selecting your initial options" or "start the selection process of your initial options".

Raoul Snyman (raoul-snyman) wrote :

Done #1, #2, #7, #8, #9, #14, #15

Simon Scudder (samscudder) wrote :

openlp/core/ui/mainwindow.py : 357
"Print the current Service Order" should be "Print the current Service"

openlp/core/ui/printservicedialog.py : 160
"Service Order Sheet" should be "Service Sheet"

openlp/core/lib/ui.py : 107
"Print Service Order" should be "Print Service"

Jonathan Corwin (j-corwin) wrote :

At time of writing, outstanding items are
#10 - Note, if the user doesn't select anything to download, then remove references to download/import from FRW last page.
#13
#17

Changed in openlp:
status: Confirmed → In Progress
Changed in openlp:
status: In Progress → Fix Committed
Changed in openlp:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers