cities scope should provide forecast too

Bug #897305 reported by f_padia on 2011-11-28
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
One Hundred Scopes
Medium
David Callé

Bug Description

Not really a bug, more of a suggestion. but I think the cities scope should provide the weather forecast as well as current weather. the Google weather API provides an xml with current weather and forecast.
http://www.google.com/ig/api?weather=(city name here) maybe the current scope can be edited to use this instead?

David Callé (davidc3) on 2011-11-28
Changed in onehundredscopes:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → David Callé (davidc3)
David Callé (davidc3) wrote :

Hi, thank you for your suggestion.
It's more a design issue than a technical one, as the API the scope is using can provide weather forecast.

Scopes rely on the Dash display abilities and I haven't found a good way to display a forecast :
[map] [time] [current weather] [day+1 weather] [day+2 weather] [day+3 weather]
doesn't seem nice to me, as it would mix multiple categories of data on the same line.

I could make a lens dedicated to weather and call it at the same time as the map+time one, but I wouldn't have any control of the ordering of lens results, a search for Paris would look like this:

[¤ Paris ]

[map] [time]

[files lens results matching "Paris"] [...] [...] [...]

[music lens result matching "Paris"]

[current weather] [day+1 weather] [...] [...]

It would be very confusing.
I'm investigating the idea though, as it's a must-have to me.

f_padia (f-padia) wrote :

I see. Is it not possible to have different categories. For example the music lens currently has
[songs]

[albums]

[available for purchase]

cities could have something like:
[map]

[time]

[weather]
current, tomorrow, day 2 etc.
or
in its current format but add forecast beneath:
[map] [time] [current weather]

[forecast]

David Callé (davidc3) wrote :

It's possible when you are viewing a single lens, not in the Dash home.
I'm using a lens called "Utilities", with the cities scope in it, but I hide it from the user (it's not in the lens bar).
When you call a lens from the Dash home, it doesn't handle categories inside lenses and display each lens as a category

<Applications>
[..] [..] [..]
<Files & Folders>
[..] [..] [..]
<Utilities>
[..] [..] [..]
<Music>
[..] [..] [..]

Maybe we could have a visible 'Utilities' lens and display whatever we want in it with nice time & forecast categories. But that would remove the benefits of just needing to type <super> + city name, as we would have to click on the lens icon after opening the dash.

f_padia (f-padia) wrote :

yes I see what you mean.
perhaps another solution is to leave it as it is but when a user clicks on the current weather then it moves to the weather lens. Is this possible? This was the basic functionality would be kept the same but the added forecast can also be achieved with a click is required

bioShark (bioshark) wrote :

Yesterday I've installed cities scope, and I quite like it. I've seen people complaining that they have their temperature in Celsius instead of Fahrenheit. For me that is not a problem, since I already use the metric system. However, after installing it, I've noticed that I have the temperature in Fahrenheit, and not in Celsius. How could I change that to Celsius?
Thanks a lot.

David Callé (davidc3) wrote :

@bioShark There will be an update in a few hours fixing this.

bioShark (bioshark) wrote :

@David Callé (davidc3) cool, thx guys. You are doing an awesome job!

David Callé (davidc3) on 2011-12-02
Changed in onehundredscopes:
status: Confirmed → Fix Released
status: Fix Released → Confirmed
bioShark (bioshark) wrote :

I've made an update, but I still have the temperature in Fahrenheit instead of Celsius. Is there an option somewhere that I am missing?

David Callé (davidc3) wrote :

Have you logged out/logged in since the update?

If it doesn't work, please paste here the terminal output of
"apt-cache show unity-scope-cities | grep Version"

bioShark (bioshark) wrote :

Hi

Sorry, I forgot about the log-out part. It works just fine (great in dual C/F). I also like the wind speed.
Keep up the good work.

David Callé (davidc3) on 2012-01-03
Changed in onehundredscopes:
status: Confirmed → In Progress
Péter Trombitás (trombipeti) wrote :

I have a suggestion, though I don't know if it's possible/easy to do:
when one searches from the dash home, the scope should show this:
[Location] [time] [temp] [wind] and here a button that maybe shows the forecast in a new line, maybe by bringing you to a "forecast lens"
btw, is it possible to make the dash start a new line inside one category, even if there's enough place on the screen?

Péter Trombitás (trombipeti) wrote :

maybe by bringing you to a "forecast lens"
** fix, sorry: maybe brings you to a "forecast lens"

David Callé (davidc3) wrote :

What you are suggesting is currently impossible, but the Home Dash is now able to display separate categories from a single lens. In Precise, there will be a forecast category that will solve this issue for good. :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers