Nux

Conditional jump or move depends on uninitialised value(s) nux::GraphicsDisplay::ProcessXEvent(_XEvent, bool) (GraphicsDisplayX11.cpp:1702)

Bug #983321 reported by Andrea Azzarone on 2012-04-16
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Nux
Fix Released
Medium
Andrea Azzarone
2.0
Fix Committed
Undecided
Unassigned
Unity
Fix Released
Undecided
Andrea Azzarone
nux (Ubuntu)
Low
Unassigned
Precise
Low
Unassigned
unity (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

[Test Case]
Running valgrind to check if the given conditional jump error still appears.

[Regression Potential]
No regression potential, trivial fix.

Original description:

==24716== 6 errors in context 132 of 20919:
==24716== Conditional jump or move depends on uninitialised value(s)
==24716== at 0x12AF1E27: nux::GraphicsDisplay::ProcessXEvent(_XEvent, bool) (GraphicsDisplayX11.cpp:1702)
==24716== by 0x12AF25D7: nux::GraphicsDisplay::GetSystemEvent(nux::Event*) (GraphicsDisplayX11.cpp:1287)
==24716== by 0x16314377: nux::WindowThread::ExecutionLoop(unsigned int) (WindowThread.cpp:523)

Related branches

Andrea Azzarone (azzar1) on 2012-04-16
Changed in nux:
status: New → In Progress
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity:
milestone: none → 5.14.0
Tim Penhey (thumper) on 2012-06-06
Changed in nux:
importance: Undecided → Medium
Andrea Azzarone (azzar1) on 2012-06-07
Changed in unity:
assignee: nobody → Andrea Azzarone (andyrock)
Changed in nux:
status: In Progress → Fix Committed
Changed in unity:
status: New → Fix Committed
milestone: 5.14.0 → 6.0
Didier Roche (didrocks) on 2012-07-10
Changed in nux:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 3.0.0-0ubuntu1

---------------
nux (3.0.0-0ubuntu1) quantal-proposed; urgency=low

  [ Łukasz 'sil2100' Zemczak ]
  * New upstream release.
    - Conditional jump or move depends on uninitialised value(s)
      nux::GraphicsDisplay::ProcessXEvent(_XEvent, bool) (LP: #983321)
    - Coverity PW.PARAMETER_HIDDEN - CID 10653 (LP: #937588)
    - Coverity SECURE_CODING - CID 10659 (LP: #937564)
    - Coverity PW.PARAMETER_HIDDEN - CID 10651 (LP: #937576)
    - Coverity PW.PARAMETER_HIDDEN - CID 10652 (LP: #937586)
    - QueueDraw is very expensive (LP: #994884)
    - Unity is slow and pausing occasionally (when its DrawList size spikes,
      to almost 6000!) (LP: #1014610)
    - IBus hotkey using Release modifier doesn't work in unity (LP: #1016665)
    - Nothing should be written into the dash/hud searchbar when holding super,
      ctrl or Alt (LP: #1013751)
    - IBus can't be activated on dash or HUD since r2428 (LP: #1016354)
  * debian/control, debian/libnux-3.0-0.install,
    debian/libnux-3.0-common.install, debian/libnux-3.0-dev.install:
    - switch to nux-3.0
 -- Didier Roche <email address hidden> Tue, 10 Jul 2012 08:53:00 +0200

Changed in nux (Ubuntu):
status: New → Fix Released
Changed in nux (Ubuntu):
importance: Undecided → Low
Changed in nux (Ubuntu Precise):
importance: Undecided → Low
status: New → In Progress
description: updated

Hello Andrea, or anyone else affected,

Accepted nux into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/nux/2.14.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in nux (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Łukasz Zemczak (sil2100) wrote :

Ran unity with valgrind memcheck and didn't see any jumps basing on uninitialized values in nux. For me it works.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 2.14.0-0ubuntu1

---------------
nux (2.14.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - QueueDraw is very expensive (LP: #994884)
    - Unity is slow and pausing occasionally (when its DrawList size spikes,
      to almost 6000!) (LP: #1014610)
    - Conditional jump or move depends on uninitialised value(s)
      nux::GraphicsDisplay::ProcessXEvent(_XEvent, bool)
      (GraphicsDisplayX11.cpp:1702) (LP: #983321)
    - Performance fixes for GdkPixbuf conversions and QueueDraw calls (SRU)
      (LP: #1028020)
 -- Lukasz 'sil2100' Zemczak <email address hidden> Thu, 26 Jul 2012 19:02:11 +0200

Changed in nux (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: New → Fix Released
Jaime Pérez (jaime-91) on 2015-10-13
Changed in unity (Ubuntu Precise):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers