Nux

compiz crashed with SIGSEGV in nux::InputArea::StartDragAsSource()

Bug #737519 reported by bonimba on 2011-03-18
112
This bug affects 21 people
Affects Status Importance Assigned to Milestone
Nux
Fix Released
Undecided
Unassigned
Unity
Fix Released
Medium
Jason Smith
nux (Ubuntu)
Medium
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

I was dragging the banshee icon from dash to launcher: all "freeze" like in exposè mode.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: libnux-0.9-0 0.9.34-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-7.35-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
CrashCounter: 1
Date: Fri Mar 18 13:52:39 2011
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110202)
ProcCmdline: compiz
ProcEnviron:
 LANGUAGE=it_IT:it:en_GB:en
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: nux
StacktraceTop:
 nux::InputArea::StartDragAsSource() () from /usr/lib/libnux-0.9.so.0
 nux::InputArea::OnEvent(nux::Event&, long, long) () from /usr/lib/libnux-0.9.so.0
 nux::Layout::ProcessEvent(nux::Event&, long, long) () from /usr/lib/libnux-0.9.so.0
 nux::Layout::ProcessEvent(nux::Event&, long, long) () from /usr/lib/libnux-0.9.so.0
 nux::Layout::ProcessEvent(nux::Event&, long, long) () from /usr/lib/libnux-0.9.so.0
Title: compiz crashed with SIGSEGV in nux::InputArea::StartDragAsSource()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

bonimba (altrobonimba) wrote :

StacktraceTop:
 nux::InputArea::StartDragAsSource (this=0x7f1e280748c8) at ./InputArea.cpp:810
 nux::InputArea::OnEvent (this=0x7f1e280748c8, event=..., TraverseInfo=<value optimized out>, ProcessEventInfo=<value optimized out>) at ./InputArea.cpp:510
 nux::Layout::ProcessEvent (this=0x1189490, ievent=..., TraverseInfo=<value optimized out>, ProcessEventInfo=0) at ./Layout.cpp:746
 nux::Layout::ProcessEvent (this=0x117fbe0, ievent=..., TraverseInfo=<value optimized out>, ProcessEventInfo=0) at ./Layout.cpp:751
 nux::Layout::ProcessEvent (this=0x117cbf0, ievent=..., TraverseInfo=<value optimized out>, ProcessEventInfo=0) at ./Layout.cpp:751

Changed in nux (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
visibility: private → public
Doug McMahon (mc3man) wrote :

Seen here - fresh install with 03/19 iso
At best can drag an icon once per session, next attempt 'freezes' the applications lens and clicking out crashes compiz
Many times can't do even once
Only seen when dragging from applications.place (dash), from any other location dragging & dropping .desktops into launcher works fine

Changed in nux (Ubuntu):
status: New → Confirmed
Giovanni Mellini (merlos) wrote :

I expirienced this while dragging an icon from dash to launcher.
Compiz crashed and I restarted it from TTY

Didier Roche (didrocks) on 2011-03-21
Changed in unity:
status: New → Confirmed
Changed in nux:
status: New → Confirmed
Neil J. Patel (njpatel) wrote :

Hi, can someone who was receiving this crash please try with latest Unity (3.8.2) please? We're a bit stumped about this bug as we think it's fixed but need some validation, thanks!

Changed in unity:
assignee: nobody → Jason Smith (jassmith)
importance: Undecided → Medium
milestone: none → 3.8.4
status: Confirmed → In Progress
Doug McMahon (mc3man) wrote :

It absolutely doesn't crash anything anymore, (hasn't for a bit

Testing again on beta 1, updated, - it works as intended for the most part
Most times it seems you only get 'one chance' in that if you hesitant too much, or change mind and don't drop the icon in the launcher then when trying again WITH the Same Icon the launcher doesn't respond, ie. the icons don't separate
Similar to what would happen if you tried to add the same app twice

 It also seems that if you remove an icon from the launcher you again can't add ANY new ones to the launcher

A logout/in restores the ability to try again, in all cases

Chad A. Davis (chadadavis) wrote :

The original bug also affected me, but I am not able to reproduce it on unity-3.8.2-0ubuntu1.

Regarding Doug's issues:
1) I cannot reproduce the freezing, the icons always separate for me, but a duplicate shortcut wont' be added.
2) I cannot add a previously deleted icon to the launcher (Thought this should be a new bug 752740)
3) I can still add other icons the launcher, however. It's not locked or otherwise stuck.

Doug McMahon (mc3man) wrote :

Upon further testing on another install I, like chad, can't duplicate some of the things i mentioned. on that install.
Generally I try to confirm here on 2 installs and sometimes with a fresh one as well. Every thing will get fresh installs this weekend, it seen then will start new bug

Jason Smith (jassmith) wrote :

Marked fix commited as reporters cant seem to reproduce the crash anymore (and I vaguely remember fixing this some time ago)

Changed in unity:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-04-07
Changed in nux:
status: Confirmed → Fix Committed
Changed in nux (Ubuntu):
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2011-04-07
Changed in nux:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 0.9.40-0ubuntu1

---------------
nux (0.9.40-0ubuntu1) natty; urgency=low

  * New upstream release.
    - [fglrx] compiz crashed with SIGSEGV in nux::IOpenGLSurface::UnlockRect()
      (LP: #685682)
    - compiz crashed with SIGSEGV in
      nux::WindowCompositor::ViewWindowPreEventCycle() (LP: #741952)
    - Missing icons in app launcher (LP: #728393)
    - compiz crashed with SIGSEGV in malloc_consolidate() (LP: #743738)
    - compiz crashed with SIGSEGV in nux::BaseWindow::IsModal() (LP: #749675)
    - compiz crashed with SIGSEGV in
      nux::GpuRenderStates::SubmitChangeStates() (LP: #722391)
    - compiz crashed with SIGSEGV in nux::InputArea::StartDragAsSource()
      (LP: #737519)
    - unity_support_test crashed with SIGSEGV in
      nux::IOpenGLAsmVertexShader::IOpenGLAsmVertexShader() (LP: #734519)
    - compiz crashed with SIGSEGV in nux::WindowCompositor::RenderTopViews()
      (LP: #747486)
  * debian/copyright:
    - licence is now LGPL2.1+
  * ABI break, add Breaks: unity (<< 3.8.4)
  * debian/rules:
    - bump the shlib
 -- Didier Roche <email address hidden> Thu, 07 Apr 2011 18:26:13 +0200

Changed in nux (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers