most PATA/SATA modules missing in Lucid netboot

Bug #546929 reported by Luis Mondesi
70
This bug affects 13 people
Affects Status Importance Assigned to Milestone
NULL Project
Undecided
Unassigned
linux (Ubuntu)
Critical
Stefan Bader
Lucid
Critical
Stefan Bader

Bug Description

Today I got the latest netboot.tar.gz from archive.ubuntu.com and attempted to install Lucid from PXE on a Sun system (x86) which has an Nvidia SATA controller (software RAID).

The installer failed to find a module for the controller (sata_nv). I copied this from a system already running Lucid onto a USB disk and load this module (2.6.32-17 kernel). This worked perfectly fine.

Please update the scsi-modules udeb or whichever package is supposed to have this module.

Regards,

Colin Watson (cjwatson)
Changed in lucid:
status: New → Invalid
Revision history for this message
Colin Watson (cjwatson) wrote :

This affects all the PATA/SATA modules that were recently modularised.

Changed in linux (Ubuntu Lucid):
importance: Undecided → Critical
milestone: none → ubuntu-10.04-beta-2
status: New → Triaged
summary: - sata_nv missing in Lucid netboot
+ most PATA/SATA modules missing in Lucid netboot
Stefan Bader (smb)
Changed in linux (Ubuntu Lucid):
assignee: nobody → Stefan Bader (stefan-bader-canonical)
status: Triaged → In Progress
tags: added: kernel-series-unknown
Revision history for this message
Bratmaxe (marcel-456) wrote :

its also affect the alternate-install CD

Revision history for this message
Brett Sheffield (brett-gladserv) wrote :

Possibly related:

lucid 20100324 alternate cd: "no common cdrom drive" error

https://bugs.launchpad.net/ubuntu/+source/debian-installer/+bug/546489

Revision history for this message
Stefan Bader (smb) wrote :

Yes, yes. I know its bad and I am working on it. ;-)

tags: added: lucid
removed: kernel-series-unknown
Revision history for this message
Stefan Bader (smb) wrote :

Fix is committed now. I plan to do an upload later today.

Changed in linux (Ubuntu Lucid):
status: In Progress → Fix Committed
Revision history for this message
Mathieu Mitchell (mat128) wrote :

I can confirm this affects the ahci module too.

rkaluta (rkaluta)
Changed in linux (Ubuntu Lucid):
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Revision history for this message
rkaluta (rkaluta) wrote :

Changed in linux (Ubuntu Lucid):
status: Fix Committed → Fix Released
rkaluta 4 minutes ago
Changed in linux (Ubuntu Lucid):
status: Fix Released → Fix Committed

Apologies! I should not have pressed these buttons.

Bratmaxe (marcel-456)
description: updated
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.32-18.27

---------------
linux (2.6.32-18.27) lucid; urgency=low

  [ Chase Douglas ]

  * SAUCE: Don't register vga16fb framebuffer if other framebuffers are
    present
    - LP: #527369

  [ Loïc Minier ]

  * [Config] armel/versatile: Set CRAMFS=m
    - LP: #524893
  * [Config] armel: Reset default command-line
    - LP: #524893

  [ Stefan Bader ]

  * build/modules: Update d-i to reflect recent config changes
    - LP: #546929

  [ Upstream Kernel Changes ]

  * (pre-stable) drm/nouveau: report unknown connector state if lid closed
    - LP: #523072
  * (pre-stable) Staging: rt2870: Add USB ID for Buffalo Airstation
    WLI-UC-GN
    - LP: #441990
  * (pre-stable) iwlwifi: fix nfreed--
    - LP: #545585
  * (pre-stable) pata_via: Add VIA VX900 support
    - LP: #548675
 -- Stefan Bader <email address hidden> Fri, 26 Mar 2010 18:39:42 +0100

Changed in linux (Ubuntu Lucid):
status: Fix Committed → Fix Released
Joel Ebel (jbebel)
tags: added: glucid
Revision history for this message
Centaur5 (djacks555) wrote :

I downloaded the new netboot file that was uploaded but still have the problem installing over PXE. How can modules be loaded from USB to get passed this in the mean time? I tried putting all the modules in the ata folder in the root of my flash drive and it doesn't work so I'm sure I'm doing something wrong.

Revision history for this message
Joel Ebel (jbebel) wrote :

You'll need the debian installer version 20081029ubuntu93 which still hasn't been published to the installer directories. The source is already in the pool, so I expect it will happen soon.

Aiman Baharna (aiman)
affects: lucid → launchpad
affects: launchpad → null
Revision history for this message
Colin Watson (cjwatson) wrote :

Drat, I forgot that debian-installer would need to have its builds retried. I've kicked those off now and they should happen very soon.

Revision history for this message
Mathieu Mitchell (mat128) wrote :

Tomorrow I'll test and let you know. Thanks for the great work Colin!

Revision history for this message
Stein Henrik Jensaas (steinhj) wrote :

 My duplicate Bug #548617 is solved in fresh update from this morning. Thanks to all involved.

Revision history for this message
Mathieu Mitchell (mat128) wrote :

I can confirm this fixes the problem. Thanks again Colin!

Revision history for this message
thamieu (thamieuz3r0-deactivatedaccount) wrote :

I've got some other problems now but my duplicate bug #548753 is solved.
Thank you!

Revision history for this message
Centaur5 (djacks555) wrote :

Thanks for the prompt work on this bug. I can confirm it fixed the problem with my machine that has nvidia nforce chipset. However, the problem persists with my amd780 chipset (00:11.0 SATA controller: ATI Technologies Inc SB700/SB800 SATA Controller) and my laptop with 00:11.6 IDE Interface: VIA Technologies, Inc. VT82C586A/B/VT823x/A/C PIPC Bus Master IDE (rev 06).

Revision history for this message
Centaur5 (djacks555) wrote :

As this bug was marked for the milestone of beta 2 I decided to await yesterday's release before testing again. Today I tried once again to do a PXE install on the previous chipset I mentioned in post #16 but it still doesn't automatically detect and it asks for a driver to be manually selected. I can confirm they work in Karmic.

Revision history for this message
Mathieu Mitchell (mat128) wrote :

Have you updated your kernel + initrd files on your PXE server? As soon as the files were rebuilt they worked for me (using the AHCI module).
I think some modules might not work correctly? Try switching to a terminal and type modprobe <modulename>.

Revision history for this message
Centaur5 (djacks555) wrote :

Yes, I updated to the files released March 30, April 5, and now I just did April 9 today and it still happens. What is the easiest way to find out the module I need to manually load? I know it's the amd780 chipset listed above in post #16 but I don't know where to get the appropriate module to load on a working system. I know I have properly updated kernel + initrd files since I was able to do my PXE install on my sata_nv machine ever since the March 30 release. Thanks for your help.

Revision history for this message
Mathieu Mitchell (mat128) wrote :

The easiest way would be to check using a working system (say from 9.10 or a working 10.04 install). I think I can still have access to an ASUS M4A78-EM motherboard, using the AMD780 chipset. I'll get back to you soon.

Revision history for this message
Mathieu Mitchell (mat128) wrote :

I can confirm that the setup works on my ASUS M4A78-EM with the SATA controller set to "SATA" mode (which is listed as
00:11.0 SATA controller: ATI Technologies Inc SB700/SB800 SATA Controller [IDE mode]) and in AHCI mode (which is listed as [AHCI mode]).
The disks are detected fine.
The module loaded for my storage is module "ahci" in both modes (which is weird). There is also a module called pata_atiixp but I could unload it without problem during the installation, meaning it was not used.
Do you have details on your hardware?

Btw I'm on the latest netboot file (I have a crontab entry getting the latest file every morning).

Revision history for this message
Centaur5 (djacks555) wrote :

Thanks Mathieu for your efforts on testing this bug. How coincidental that as soon as you tested with that board they released a new netboot file last night. I was running the newest one released on the 9th and I know the problem persisted but first thing this morning I noticed a new file and immediately tested it and this bug is officially fixed. I can now install on my Averatec 3200 laptop, Asus M4A77D, Asus M4A78L-M, and Asus M3A78-CM.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers