ntrack - Network Connectivity Tracking library for Desktop Applications

Comment 340 for bug 191889

Logging out didn't help. I tried reinstalling network-manager and
network-manager-gnome, it prompted me to restart, which I did, and still
nothing. I went to my Sessions Preferences and the Network Manager Applet
was listed there with a command "nm-applet --sm-disable"

I checked my System Monitor Processes and nm-applet appears to be running,
but just to try I killed it and ran sudo nm-applet --sm-disable. Still
nothing.

I thought that network manager was different than nm-applet actually, but I
wasn't sure. If that's the case, I don't know how to start network
manager. I checked Services and Session Preferences and didn't find
anything helpful in either (besides the Network Manager Applet I mentioned).

I also find it weird that I can't access it via System -> Administration
anymore... Any thoughts? I can provide debugging if you let me know what
you need (and how to get it).

On Sat, Oct 11, 2008 at 7:20 PM, Alexander Sack <email address hidden> wrote:

> jonathan, nm manager should be in the tray. maybe relogin. if that
> doesnt work, please ensure that NetworkManager process is running.
>
> However, if you have configurations in /etc/network/interfaces and you
> want NM to manage them you have to turn on managed=true in
> /etc/NetworkManager/nm-system-settings.conf.
>
> This is an experimental mode in intrepid though.
>
> --
> [MASTER] [WORKAROUND] "Offline Mode" feature fails to detect proper online
> state for networks that are managed outside of network manager.
> https://bugs.launchpad.net/bugs/191889
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in The Mozilla Firefox Browser: Fix Released
> Status in NetworkManager: Confirmed
> Status in USB ADSL Modem Manager for Gnome, written in Python: New
> Status in "empathy" source package in Ubuntu: New
> Status in "evolution" source package in Ubuntu: Invalid
> Status in "firefox-3.0" source package in Ubuntu: Invalid
> Status in "network-manager" source package in Ubuntu: Fix Released
> Status in "pidgin" source package in Ubuntu: Confirmed
> Status in empathy in Ubuntu Hardy: New
> Status in evolution in Ubuntu Hardy: Invalid
> Status in firefox-3.0 in Ubuntu Hardy: Invalid
> Status in network-manager in Ubuntu Hardy: Triaged
> Status in pidgin in Ubuntu Hardy: Confirmed
> Status in empathy in Ubuntu Intrepid: New
> Status in evolution in Ubuntu Intrepid: Invalid
> Status in firefox-3.0 in Ubuntu Intrepid: Invalid
> Status in network-manager in Ubuntu Intrepid: Fix Released
> Status in pidgin in Ubuntu Intrepid: Confirmed
> Status in "firefox-3.0" source package in Baltix: New
>
> Bug description:
> Binary package hint: firefox-3.0
>
> DISTRIB_ID=Ubuntu
> DISTRIB_RELEASE=8.04
> DISTRIB_CODENAME=hardy
> DISTRIB_DESCRIPTION="Ubuntu hardy (development branch)"
> Firefox 3.0b3
> When I start firefox from the panel it always start in offline mode. I am
> connected via wireless to a network that is always on. When I want to browse
> I need to unclick "work offline"
>
> Workaround 1: (since ffox 3.0.1) ->
> set toolkit.networkmanager.disable to false in about:config
>
> Workaround 2: (make NM to be always online) ->
> add a non existing interface to /etc/network/interfaces, like:
>
> iface eth1000 inet dhcp
>
>
>
>
>
>
>