Comment 6 for bug 1761140

(Note: There was a paste failure with my last comment so I've hidden that.)

Hi Annie,

I can't confirm that your package is coming from a Canonical or Ubuntu supported archive.

Your log has the following:

nova-compute:
  Installed: (none)
  Candidate: 2:17.0.1-0ubuntu1~cloud0
  Version table:
     2:17.0.1-0ubuntu1~cloud0 500
        500 http://172.31.200.12/cloud_archive/x86_64 xenial-proposed/queens/main amd64 Packages
     2:13.1.4-0ubuntu4.2 500
        500 http://172.31.200.12/ubuntu/x86_64 xenial-updates/main amd64 Packages
     2:13.0.0-0ubuntu2 500
        500 http://172.31.200.12/ubuntu/x86_64 xenial/main amd64 Packages

Whereas when I add the queens-proposed cloud archive to xenial I see:

nova-compute:
  Installed: (none)
  Candidate: 2:17.0.4-0ubuntu1~cloud0
  Version table:
     2:17.0.4-0ubuntu1~cloud0 500
        500 http://ubuntu-cloud.archive.canonical.com/ubuntu xenial-proposed/queens/main amd64 Packages
     2:13.1.4-0ubuntu4.2 500
        500 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
     2:13.0.0-0ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu xenial/main amd64 Packages

If you still see problems using the standard Ubuntu archive for xenial with the Queens cloud archive [1] on top of it, please move this bug back to New status.

[1] sudo add-apt-repository cloud-archive:queens-proposed && sudo apt update

Thanks,
Corey