Libvirt Watchdog support is broken when ComputeCapabilitiesFilter is used

Bug #1367344 reported by Roman Podoliaka on 2014-09-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Medium
Pavel Kholkin
Icehouse
Medium
Pavel Kholkin
Juno
Medium
Pavel Kholkin

Bug Description

The doc (http://docs.openstack.org/admin-guide-cloud/content/customize-flavors.html , section "Watchdog behavior") suggests to use the flavor extra specs property called "hw_watchdog_action" to configure a watchdog device for libvirt guests. Unfortunately, this is broken due to ComputeCapabilitiesFilter trying to use this property to filter compute hosts, so that scheduling of a new instance always fails with NoValidHostFound error.

Changed in nova:
assignee: nobody → Roman Podoliaka (rpodolyaka)
Sean Dague (sdague) on 2014-09-10
Changed in nova:
status: New → Confirmed
importance: Undecided → Medium
Pavel Kholkin (pkholkin) on 2014-09-12
Changed in nova:
assignee: Roman Podoliaka (rpodolyaka) → Pavel Kholkin (pkholkin)

Fix proposed to branch: master
Review: https://review.openstack.org/121148

Changed in nova:
status: Confirmed → In Progress
Changed in nova:
assignee: Pavel Kholkin (pkholkin) → Roman Podoliaka (rpodolyaka)
Changed in nova:
assignee: Roman Podoliaka (rpodolyaka) → Pavel Kholkin (pkholkin)
Jay Pipes (jaypipes) on 2014-10-10
tags: added: juno-rc-potential

Reviewed: https://review.openstack.org/121148
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=79bfb1bf343484e98aa36dcc663a5370baf4cab7
Submitter: Jenkins
Branch: master

commit 79bfb1bf343484e98aa36dcc663a5370baf4cab7
Author: pkholkin <email address hidden>
Date: Fri Sep 12 19:31:54 2014 +0400

    Fix libvirt watchdog support

    Using the flavor extra_specs property "hw_watchdog_action" was broken.
    Scheduling of a new instance always failed with NoValidHostFound error
    because of ComputeCapabilitiesFilter, which treated this property as a
    host capability to be checked.

    Commit f0ff4d51057080e769407e873e5ed212f15b773d caused the problem.

    To fix this watchdog_action property is put into 'hw:' scope, so
    that it will be ignored by ComputeCapabilitiesFilter in scheduler and
    handled in libvirt driver. The doc must be fixed accordingly.

    Now driver accepts both 'hw_watchdog_action' and
    'hw:watchdog_action', tests were edited for these cases.
    Were added TODO items to delete the compat code in the next release.

    DocImpact
    Closes-Bug: #1367344

    Change-Id: Ic5344ec34a130ee5a0ed2c7348af0b9d79e3508e

Changed in nova:
status: In Progress → Fix Committed

Change abandoned by Thierry Carrez (<email address hidden>) on branch: proposed/juno
Review: https://review.openstack.org/128262
Reason: 2014.2 is released

Thierry Carrez (ttx) on 2014-10-16
tags: added: juno-backport-potential
removed: juno-rc-potential
Alan Pevec (apevec) on 2014-11-27
tags: removed: juno-backport-potential
Thierry Carrez (ttx) on 2014-12-18
Changed in nova:
milestone: none → kilo-1
status: Fix Committed → Fix Released

Reviewed: https://review.openstack.org/133922
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=8a3b609580ae6a72767eebb1af9e0d71a1412897
Submitter: Jenkins
Branch: stable/juno

commit 8a3b609580ae6a72767eebb1af9e0d71a1412897
Author: pkholkin <email address hidden>
Date: Fri Sep 12 19:31:54 2014 +0400

    Fix libvirt watchdog support

    Using the flavor extra_specs property "hw_watchdog_action" was broken.
    Scheduling of a new instance always failed with NoValidHostFound error
    because of ComputeCapabilitiesFilter, which treated this property as a
    host capability to be checked.

    Commit f0ff4d51057080e769407e873e5ed212f15b773d caused the problem.

    To fix this watchdog_action property is put into 'hw:' scope, so
    that it will be ignored by ComputeCapabilitiesFilter in scheduler and
    handled in libvirt driver. The doc must be fixed accordingly.

    Now driver accepts both 'hw_watchdog_action' and
    'hw:watchdog_action', tests were edited for these cases.
    Were added TODO items to delete the compat code in L release.

    DocImpact
    Closes-Bug: #1367344

    Conflicts:
     nova/tests/virt/libvirt/test_driver.py

    Change-Id: Ic5344ec34a130ee5a0ed2c7348af0b9d79e3508e
    (cherry picked from commit 79bfb1bf343484e98aa36dcc663a5370baf4cab7)

Thierry Carrez (ttx) on 2015-04-30
Changed in nova:
milestone: kilo-1 → 2015.1.0

Reviewed: https://review.openstack.org/134217
Committed: https://git.openstack.org/cgit/openstack/nova/commit/?id=dbc348d296cbbb03650f77f6ef29b55635162c15
Submitter: Jenkins
Branch: stable/icehouse

commit dbc348d296cbbb03650f77f6ef29b55635162c15
Author: pkholkin <email address hidden>
Date: Fri Sep 12 19:31:54 2014 +0400

    Fix libvirt watchdog support

    Using the flavor extra_specs property "hw_watchdog_action" was broken.
    Scheduling of a new instance always failed with NoValidHostFound error
    because of ComputeCapabilitiesFilter, which treated this property as a
    host capability to be checked.

    Commit f0ff4d51057080e769407e873e5ed212f15b773d caused the problem.

    To fix this watchdog_action property is put into 'hw:' scope, so
    that it will be ignored by ComputeCapabilitiesFilter in scheduler and
    handled in libvirt driver. The doc must be fixed accordingly.

    Now driver accepts both 'hw_watchdog_action' and
    'hw:watchdog_action', tests were edited for these cases.
    Were added TODO items to delete the compat code in L release.

    DocImpact
    Closes-Bug: #1367344

    Conflicts:
     nova/tests/virt/libvirt/test_libvirt.py

    Change-Id: Ic5344ec34a130ee5a0ed2c7348af0b9d79e3508e
    (cherry picked from commit 79bfb1bf343484e98aa36dcc663a5370baf4cab7)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers