Activity log for bug #1336846

Date Who What changed Old value New value Message
2014-07-02 16:06:59 Sergey "Shnatsel" Davidoff bug added bug
2014-07-02 16:10:41 Sergey "Shnatsel" Davidoff description Noise.FileUtils.count_music_files () function has side effects - it modifies the original collection passed to it. The name is, as of right now, misleading sine. It also only declares Gee.LinkedList<string> as supported structure while the It also abuses "ref" - it's not useful in any way here since GObjects are already pointers and it prohibits the function from working with subclasses of the structure declared in function prototype. It is exposed on the plugin API so fixing it directly will require breaking the external API/ABI. Alternatively we can deprecate it and create a properly named function. (I'm not that good at Vala. We figured this out together with xapantu). Noise.FileUtils.count_music_files () function has side effects - it modifies the original collection passed to it. Thus the name is misleading (and I have no idea what the function *really* does). It also only declares Gee.LinkedList<string> as supported structure while the It also abuses "ref" - it's not useful in any way here since GObjects are already pointers and it prohibits the function from working with subclasses of the structure declared in function prototype. It is exposed on the plugin API so fixing it directly will require breaking the external API/ABI. Alternatively we can deprecate it and create a properly named function. (I'm not that good at Vala. We figured this out together with xapantu).
2014-07-02 16:12:20 Sergey "Shnatsel" Davidoff description Noise.FileUtils.count_music_files () function has side effects - it modifies the original collection passed to it. Thus the name is misleading (and I have no idea what the function *really* does). It also only declares Gee.LinkedList<string> as supported structure while the It also abuses "ref" - it's not useful in any way here since GObjects are already pointers and it prohibits the function from working with subclasses of the structure declared in function prototype. It is exposed on the plugin API so fixing it directly will require breaking the external API/ABI. Alternatively we can deprecate it and create a properly named function. (I'm not that good at Vala. We figured this out together with xapantu). Noise.FileUtils.count_music_files () function has side effects - it modifies the original collection passed to it. Thus the name is misleading (and I have no idea what the function *really* does). This should be fixed. Counting function should not have any side effects (and should only work with a read-only view of the collection). And whatever this function really does should be split into a properly named function. The current function also only declares Gee.LinkedList<string> as supported structure while the implementation would work with any subclass of Gee.Collection<string>, i.e. any Gee structure at all. It also abuses "ref" - it's not useful in any way here since GObjects are already pointers and it prohibits the function from working with subclasses of the structure declared in function prototype. It is exposed on the plugin API so fixing it directly will require breaking the external API/ABI. Alternatively we can deprecate it and create a properly named function. (I'm not that good at Vala. We figured this out together with xapantu).
2014-07-03 09:10:01 Sergey "Shnatsel" Davidoff description Noise.FileUtils.count_music_files () function has side effects - it modifies the original collection passed to it. Thus the name is misleading (and I have no idea what the function *really* does). This should be fixed. Counting function should not have any side effects (and should only work with a read-only view of the collection). And whatever this function really does should be split into a properly named function. The current function also only declares Gee.LinkedList<string> as supported structure while the implementation would work with any subclass of Gee.Collection<string>, i.e. any Gee structure at all. It also abuses "ref" - it's not useful in any way here since GObjects are already pointers and it prohibits the function from working with subclasses of the structure declared in function prototype. It is exposed on the plugin API so fixing it directly will require breaking the external API/ABI. Alternatively we can deprecate it and create a properly named function. (I'm not that good at Vala. We figured this out together with xapantu). Noise.FileUtils.count_music_files () function has side effects - it modifies the original collection passed to it. Thus the name is misleading (and I have no idea what the function *really* does). This should be fixed. Counting function should not have any side effects (and should only work with a read-only view of the collection). And whatever this function really does should be split into a properly named function. It is exposed on the plugin API so fixing it directly will break the external API/ABI, but we officially don't have plugin API stability yet (bug #1336493). (I'm not that good at Vala. We figured this out together with xapantu).
2014-07-29 07:47:59 PerfectCarl tags library-management
2014-08-22 06:42:38 PerfectCarl noise: assignee PerfectCarl (name-is-carl)
2014-08-22 06:42:43 PerfectCarl noise: status New In Progress
2014-08-22 06:42:56 PerfectCarl branch linked lp:~name-is-carl/noise/perf-instant-search
2015-02-02 16:57:51 PerfectCarl branch unlinked lp:noise/0.4.x
2015-02-28 07:37:51 Cody Garver noise: status In Progress Confirmed
2015-02-28 07:37:51 Cody Garver noise: assignee PerfectCarl (name-is-carl)