noise crashed with SIGSEGV in g_object_ref()

Bug #1263550 reported by Jay on 2013-12-22
202
This bug affects 33 people
Affects Status Importance Assigned to Milestone
Granite
Fix Released
Critical
Victor Martinez
Noise
Invalid
Undecided
Unassigned

Bug Description

Noise stopped working for me this morning right after first boot up, now every time I launch the player it crashes almost instantly. It doesn't freeze on screen it just retracts like I'm minimizing a window and the player is no longer then running at all. I just get grey box maximizing then minimizing like a rapid flash on screen. I haven't installed any other apps recently but there was a few OS updates the night before and it was still working after those update till a booted down at least.
Thanks for your time. I'm using eOS all up to date.

Jay (jimlad2224) on 2013-12-23
summary: - Noise will not launch.
+ noise crashed with SIGSEGV in g_object_ref()
Jay (jimlad2224) on 2013-12-23
description: updated
LioBino (lionelbino) wrote :

I upgraded to the latest version and it fails freezing, the terminal displays the following text (sorry for my English)

[_LOG_LEVEL_INFO 12:11:25.191301] Application.vala:77: Música version: 0.2.2
[_LOG_LEVEL_INFO 12:11:25.191340] Application.vala:79: Kernel version: 3.2.0-58-generic
[_LOG_LEVEL_FATAL 12:11:25.194227] [GLib] g_variant_new_string: assertion `string != NULL' failed
[_LOG_LEVEL_FATAL 12:11:25.194249] Música will not function properly.
[_LOG_LEVEL_FATAL 12:11:25.194274] [GLib-GIO] g_settings_schema_key_type_check: assertion `value != NULL' failed
[_LOG_LEVEL_FATAL 12:11:25.194289] Música will not function properly.
[_LOG_LEVEL_FATAL 12:11:25.194334] [GLib] g_variant_get_type_string: assertion `value != NULL' failed
[_LOG_LEVEL_FATAL 12:11:25.194358] Música will not function properly.
[_LOG_LEVEL_FATAL 12:11:25.194395] [GLib-GIO] g_settings_set_value: key 'music-folder' in 'org.pantheon.noise.settings' expects type 's', but a GVariant of type '(null)' was given
[_LOG_LEVEL_FATAL 12:11:25.194409] Música will not function properly.
[_LOG_LEVEL_WARN 12:11:25.194428] Settings.vala:324: Key 'music-folder' could not be written to.

LioBino (lionelbino) on 2014-01-21
Changed in noise:
assignee: nobody → LioBino (lionelbino)
status: New → Confirmed
assignee: LioBino (lionelbino) → nobody
austin (austinchang4) wrote :

same here... using elementary os luna..

juanmatias (juanmatias) wrote :

Hi, I had this issue since a while. I removed noise and now reinstalled it.

I started the app from command line, but the only "error" I catch is a segment violation.
This output is in Spanish due to it's my primary language. Please let me know if you nedd translation.

What test can I perfom to get more info?

Thanks.

COMMAND LINE OUTPUT:
jdelacamara@marilujuan:~$ noise

(noise:15677): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:544:12: Expected '('

(noise:15677): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1039:0: Junk at end of value

(noise:15677): Gtk-WARNING **: Theme parsing error: button.css:41:13: Expected '('

(noise:15677): Gtk-WARNING **: Theme parsing error: button.css:46:29: Expected ',' in color definition

(noise:15677): Gtk-WARNING **: Theme parsing error: button.css:98:16: Not using units is deprecated. Assuming 'px'.

(noise:15677): Gtk-WARNING **: Theme parsing error: button.css:98:24: Not using units is deprecated. Assuming 'px'.

(noise:15677): Gtk-WARNING **: Theme parsing error: toolbar.css:34:23: Not a valid image

(noise:15677): Gtk-WARNING **: Theme parsing error: toolbar.css:93:22: Not a valid image

(noise:15677): Gtk-WARNING **: Theme parsing error: popover.css:27:4: Junk at end of value

(noise:15677): Gtk-WARNING **: Theme parsing error: popover.css:37:17: Expected '('

(noise:15677): Gtk-WARNING **: Theme parsing error: albumlistview.css:26:20: Not using units is deprecated. Assuming 'px'.
[_LOG_LEVEL_INFO 11:44:44.590736] Application.vala:77: Música version: 0.2.4
[_LOG_LEVEL_INFO 11:44:44.590815] Application.vala:79: Kernel version: 3.2.0-57-generic
Violación de segmento (`core' generado)
jdelacamara@marilujuan:~$

juanmatias (juanmatias) wrote :

By the way, I installed noise into a fresh elementary OS Luna install and it worked like a charm.
So I presume that in my notebook and desktop it do not work due to another installed package, please let me know how can I get more debug info.
Thanks again.

Victor Martinez (victored) wrote :

An ABI break made it through a Luna release when Granite 0.2.3 was released.

I will try work this around by reverting the code portion that breaks the binary compatibility. Expect a fix soon.

Changed in noise:
status: Confirmed → Incomplete
Changed in granite:
status: New → Confirmed
assignee: nobody → Victor Martinez (victored)
Victor Martinez (victored) wrote :

Cody,

Could you revert rev. 659 at lp:granite/0.2 please?

I'm afraid I don't have enough time to be choosy and only revert the code that breaks the ABI.

Changed in granite:
assignee: Victor Martinez (victored) → nobody
Cody Garver (codygarver) on 2014-03-04
Changed in granite:
milestone: none → 0.2.3.1
importance: Undecided → Critical
Stephen J Radachy (sjradach) wrote :

The issue is that the 0.2.3 version of SourceList is incompatible with the 0.2.2 version

Replication requires any package which implements SourceList built with Granite 0.2.2, but run on a machine with 0.2.3

Excluding backward compatibility, the solution is to rebuild all packages using Granite 0.2.2 with Granite 0.2.3

I've tested this solution on my machine with Noise 0.2.4, Cable 0.2, and Elementary-Tweaks 0.1

Cody Garver (codygarver) on 2014-03-18
Changed in granite:
status: Confirmed → Fix Released
assignee: nobody → Victor Martinez (victored)
milestone: 0.2.3.1 → none
Changed in noise:
status: Incomplete → Invalid
Changed in granite:
milestone: none → 0.2.3.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers