Segfault when gzip_types is used in 1.5.6 (mainline ppa)

Bug #1250802 reported by Mustang on 2013-11-13
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Nginx
High
Unassigned

Bug Description

I am finding that nginx segfaults when using the gzip_types configuration option in 1.5.6 on Ubuntu 13.10 (saucy) 64-bit.

This being used my nginx.conf in the http block:
gzip_types text/plain text/css application/json application/x-javascript text/xml application/xml application/xml+rss text/javascript;

If I comment out that line, nginx starts normally.

Thomas Ward (teward) wrote :

Related: https://bugs.launchpad.net/nginx/+bug/1243050

Marking as confirmed because I was able to replicate this in a Saucy VM.

I plan to attempt to resync 1.5.6 with the Debian version of nginx, but that may take a little bit more time...

Changed in nginx:
status: New → Triaged
importance: Undecided → High
status: Triaged → Confirmed
summary: - Segfault when gzip_types is used in 1.5.6
+ Segfault when gzip_types is used in 1.5.6 (mainline ppa)

I am experimenting the same issue. Is there a workaround or just wait until next reléase?

Thomas Ward (teward) wrote :

Can someone see if this is fixed in the latest upload?

Thomas Ward (teward) wrote :

Please check to see if this is still applicable in the latest uploads on a supported release of Ubuntu.

Changed in nginx:
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers