dpkg: multiple fixes required for Nexenta OS

Bug #4504 reported by Alex Ross
10
Affects Status Importance Assigned to Milestone
Baltix
Undecided
Unassigned
Nexenta Operating System
Invalid
Undecided
Unassigned
dpkg (Ubuntu)
Wishlist
Unassigned

Bug Description

As above.

I'll also attach a cumulative patch for dpkg-1.13.10 and comment on it..

Revision history for this message
Alex Ross (alexross) wrote : Cumulative patch

The following is a list of specific comments on various parts of the attached patch.

1) build dependency includes selinux (look for [gnu-linux] in the patch)

2) missing solaris debian architecture (look for ostable)

3) dpkg-shlibdeps does not recognize SUN's ldd output

4) checking for ENOTEMPTY-only is insufficient for other POSIX (but not Linux) OSes (look for ENOTEMPTY).

5) object stack (obstack) is missing.

6) strnlen() is not POSIX

7) multiple type casting errors in dselect around mvwaddstr()

8) resizeterm() is NCURSES extension

Matt Zimmerman (mdz)
Changed in dpkg:
assignee: nobody → keybuk
Revision history for this message
Scott James Remnant (Canonical) (canonical-scott) wrote :

Patched and uploaded

Changed in dpkg:
status: Unconfirmed → Fix Released
Revision history for this message
Scott James Remnant (Canonical) (canonical-scott) wrote :
Changed in dpkg:
status: Fix Released → Confirmed
Revision history for this message
Scott James Remnant (Canonical) (canonical-scott) wrote :

In fact, this patch is highly invasive and cannot simply be applied to our dpkg -- it's not been done in a portable manner

Revision history for this message
Alex Ross (alexross) wrote :

Agree with the comment. Coincidentally, we just started to work with Debian to submit this patch, or more exactly, the very first part of it that introduces a new architecture:

http://lists.debian.org/debian-devel/2006/04/msg00064.html

We now intend to use Debian's BTS. Let us know whether this is the right way to go.

Revision history for this message
Scott James Remnant (Canonical) (canonical-scott) wrote :

That's probably just as good; the Debian dpkg guys are ok

I should have probably read that patch before I tried it <g>

Revision history for this message
Dennis Kaarsemaker (dennis) wrote : Re: [Bug 4504] Re: dpkg: multiple fixes required for Nexenta OS

Scott, shouldn't this bug be rejected, since we (well, you) aren't
working on it and nexenta isn't a primary Ubuntu target?

Revision history for this message
Scott James Remnant (Canonical) (canonical-scott) wrote :

No...

I think we should offer whatever help the Nexenta guys need to get this patch in good shape to be accepted; after all, they're one of our derivatives. This bug can stay open as long as their patch is in the wild.

Revision history for this message
Alex Ross (alexross) wrote :

Submitted to Debian BTS:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=361866

This is the first in the upcoming series, indended specifically to introduce a new dpkg architecture.

The patch is done against Ubuntu's 1.13.11, and not Debian's current 1.13.17.

Revision history for this message
Dennis Kaarsemaker (dennis) wrote :

> I think we should offer whatever help the Nexenta guys need to get
> this patch in good shape to be accepted; after all, they're one of our
> derivatives. This bug can stay open as long as their patch is in the
> wild.

Fair enough, I was just curious about your poicy towards bugs :)

Revision history for this message
Alex Ross (alexross) wrote : dpkg.0419.diff

Cumulative patch as of 04/19

Revision history for this message
Alex Ross (alexross) wrote :

I've attached a complete patch, as of today. Two notes: (1) the patch needs to be cleaned up, and (2) part of it was submitted to Debian:

http://lists.debian.org/debian-devel/2006/04/msg00064.html

On the related note, see:

http://lists.debian.org/debian-devel/2006/04/msg00281.html

Changed in dpkg:
assignee: keybuk → nobody
Ian Jackson (ijackson)
Changed in dpkg:
importance: Medium → Wishlist
Revision history for this message
Christian Reis (kiko) wrote :

Marking fixed based on original Trac bug.

anilg (anil-verve)
Changed in dpkg:
milestone: none → hardy-release
Revision history for this message
Nigel Babu (nigelbabu) wrote :

Are all these changes done? Can this bug be closed now?

Revision history for this message
Raphaël Hertzog (hertzog) wrote :

Most of the interesting bits have already found their way into dpkg due to submission to Debian and dpkg has improved in terms of portability. If there are any stuff left to merge, feel free to submit changes directly through the Debian bug tracking system.

Changed in dpkg (Ubuntu):
status: Confirmed → Won't Fix
Revision history for this message
Alberto Salvia Novella (es20490446e) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. It would help us a lot if you could test it on a currently supported Ubuntu version. When you test it and it is still an issue, kindly upload the updated logs by running apport-collect <bug #> and any other logs that are relevant for this particular issue.

affects: dpkg (Nexenta Operating System) → nexenta
Changed in nexenta:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints