OVN migration is missing python3 support

Bug #1839834 reported by Jakub Libosvar on 2019-08-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
networking-ovn
Undecided
Unassigned

Bug Description

Description of problem:

OVN migration job is failing with error:
TASK [Install python virtualenv] ***********************************************
task path: /home/rhos-ci/jenkins/workspace/DFG-network-networking-ovn-15_director-rhel-virthost-3cont_2comp-ipv4-vxlan-ml2ovs-to-ovn-migration/infrared/plugins/tripleo-ovn-migration/migration/infrared/tripleo-ovn-migration/main.yml:6
Saturday 15 June 2019 21:50:24 +0000 (0:00:03.216) 0:00:03.420 *********
fatal: [undercloud-0]: FAILED! => {
    "changed": false,
    "failures": [
        "No package python-virtualenv available."
    ],
    "rc": 1,
    "results": []
}

MSG:

Failed to install some of the specified packages

 to retry, use: --limit @/home/rhos-ci/jenkins/workspace/DFG-network-networking-ovn-15_director-rhel-virthost-3cont_2comp-ipv4-vxlan-ml2ovs-to-ovn-migration/infrared/plugins/tripleo-ovn-migration/migration/infrared/tripleo-ovn-migration/main.retry

PLAY RECAP *********************************************************************
undercloud-0 : ok=1 changed=0 unreachable=0 failed=1

Reviewed: https://review.opendev.org/675884
Committed: https://git.openstack.org/cgit/openstack/networking-ovn/commit/?id=985f3805da9bed6477aa462f74d37c746c9bc2c6
Submitter: Zuul
Branch: master

commit 985f3805da9bed6477aa462f74d37c746c9bc2c6
Author: Jakub Libosvar <email address hidden>
Date: Mon Aug 12 12:22:13 2019 +0000

    migration: Use python3 packages when needed

    The patch changes names of installed packages by yum module based on
    what Python version of interpreter is available on given node.

    Closes-bug: #1839834

    Change-Id: I5a2409d80ebd19904909bd62fb7c11ae0cbfde30

Changed in networking-ovn:
status: New → Fix Released

Reviewed: https://review.opendev.org/677935
Committed: https://git.openstack.org/cgit/openstack/networking-ovn/commit/?id=c4367485a18947bd204ce6ef72cc7d43890bfb3d
Submitter: Zuul
Branch: stable/stein

commit c4367485a18947bd204ce6ef72cc7d43890bfb3d
Author: Jakub Libosvar <email address hidden>
Date: Mon Aug 12 12:22:13 2019 +0000

    migration: Use python3 packages when needed

    The patch changes names of installed packages by yum module based on
    what Python version of interpreter is available on given node.

    Closes-bug: #1839834

    Change-Id: I5a2409d80ebd19904909bd62fb7c11ae0cbfde30
    (cherry picked from commit 985f3805da9bed6477aa462f74d37c746c9bc2c6)

tags: added: in-stable-stein

This issue was fixed in the openstack/networking-ovn 7.0.0.0b1 development milestone.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers