NM can't configure ZTE AC8700 modem; wvdial can

Reported by Amit Mendapara on 2009-10-26
84
This bug affects 15 people
Affects Status Importance Assigned to Milestone
NetworkManager
New
Undecided
Unassigned
modemmanager (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: network-manager

I have just installed ubuntu 9.10 rc1. My BSNL EVDO modem (zte ac8700) doesn't work with network-manager which was working fine with ubuntu 9.04. Though, it works fine with wvdial.

ProblemType: Bug
Architecture: amd64
CRDA: Error: [Errno 2] No such file or directory
Date: Mon Oct 26 19:15:55 2009
DistroRelease: Ubuntu 9.10
IfupdownConfig:
 auto lo
 iface lo inet loopback
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release Candidate amd64 (20091020.3)
IpRoute:
 192.168.1.0/24 dev wlan0 proto kernel scope link src 192.168.1.151 metric 2
 169.254.0.0/16 dev wlan0 scope link metric 1000
 default via 192.168.1.1 dev wlan0 proto static
NonfreeKernelModules: nvidia
Package: network-manager 0.8~a~git.20091013t193206.679d548-0ubuntu1
ProcEnviron:
 PATH=(custom, user)
 LANG=en_IN
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: network-manager
Uname: Linux 2.6.31-14-generic x86_64

Amit Mendapara (cristatus) wrote :
Amit Mendapara (cristatus) wrote :

Here are the last few syslog entries...

Amit Mendapara (cristatus) wrote :

After downgrading to NM 0.7 (from network manager PPA) and removing modemmanager, it's working now. So I think, the problem comes from modemmanager it self.

Alexander Sack (asac) wrote :

please get the logs like described here: https://wiki.ubuntu.com/DebuggingModemmanager

affects: network-manager (Ubuntu) → modemmanager (Ubuntu)
Changed in modemmanager (Ubuntu):
status: New → Incomplete
Amit Mendapara (cristatus) wrote :
Amit Mendapara (cristatus) wrote :
Amit Mendapara (cristatus) wrote :
ninja_style (ninja-style4000) wrote :

this modem is very popular in here, i do have at least 5 of my friends are having the same issue, i hope it will be fixed soon

Changed in modemmanager (Ubuntu):
status: Incomplete → Confirmed
Changed in modemmanager (Ubuntu):
status: Confirmed → Invalid
Amit Mendapara (cristatus) wrote :

After latest updates, with network-manager 0.8~a~git.20091123t080835.830bded-0ubuntu1~nmt1~karmic, it's now working perfectly. Thanks...

Changed in network-manager:
status: New → Fix Released
Hendy Irawan (ceefour) wrote :

Amit, where did you get version: "network-manager 0.8~a~git.20091123t080835.830bded-0ubuntu1~nmt1~karmic" ? I'd love to get this version too!

Hendy Irawan (ceefour) wrote :

For those wondering, I answered my own question, get the packages from daily PPA here :

https://launchpad.net/~network-manager/+archive/trunk

Amit Mendapara (cristatus) wrote :

I repopen the bug. I switched the device to `HDR Only` mode, now NM doesn't connect. I found that only `Automatic` & `CDMA Only` mode are working. Though, once connected device can use `HDR` mode.

Changed in network-manager:
status: Fix Released → New
karl pihlblad (karl-pihlblad) wrote :

I get similar logs when using the cmotech modem CNU-680 / ice.net D-50 and the option driver.

karl pihlblad (karl-pihlblad) wrote :

I did some testing, and the problem seems to be with modem-manager and that the modem responds with a SID of 0, in IS-707-A format.

** (modem-manager:2779): DEBUG: (ttyUSB0): --> 'AT+CSS?<CR>'
** (modem-manager:2779): DEBUG: (ttyUSB0): <-- '<CR><LF>?, 0<CR><LF><CR><LF>OK<CR><LF>'

Modem-manager thinks SSD == 0 || SSD == 99999 means no service. According to some document i found, SSD=0 is actually a valid number.
(http://www.tiaonline.org/standards/technology/cdma2000/documents/TIA-EIA-IS-707-A-2.pdf)

> SID:
> 0-16383 The mobile station is registered with
> the system indicated.
> 99999 The mobile station is not registered.

I have no idea if this is correct or not, but i changed the test to check against 99999 only, and then it works for me.
If sid 0 is invalid in later specs; something more clever is needed...

I've attached a patch to allow sid 0.

Changed in modemmanager (Ubuntu):
status: Invalid → Confirmed
karl pihlblad (karl-pihlblad) wrote :

Sorry; SSD should have been "SID" in my previous post...

This patch worked for me. We were getting the same error while connecting Huwei EC 1260 (Reliance NetConnect Broadband+ / Tata Photo+ )

Here is PPA [1] Please confirm whether it's working for you or not?

[1] https://launchpad.net/~hardik-dalwadi/+archive/ppa

tags: added: patch

Should we consider this patch for Karmic-updates & Lucid?

karl pihlblad (karl-pihlblad) wrote :

If You are asking me, I would say yes please, that would be nice. :-)

The patch seems to be in conformance to the relevant protocol specifications, and the non-patched code seems to be failing for at least a few devices used by a couple of carriers around the world. Also, my device (CNU-680) can't use Amit's workaround, so the patch is the only solution for me...

Jerone Young (jerone) wrote :

Need to submit this upstream & get comments. Though comment #14 gives best lead.

@ Karl,

Yes, i have tested your patch against Huawei EC1260 / Haier CE 100, Now those modems are working fine with NM. Those modems are used by Reliance for NetConnect Broadband+ service and Tata's for Photon+ s INTERNET service.

@ Jerone,

Thanks. Here is analysis from Lucid Lynx Beta 1.

If you are In Lucid Lynx Beta 1, You will get the same problem while connecting Huawei EC1260 with Reliance NetConnect Broadband+ service or ZTE AC8700, BSNL EVDO. ModemManage, It checks for SID / Class / Band. If it will not get those value it will give "No Service" error. In 0.3 ModemManager allows SID=0 in some cases. But, below code is putting SID=9999, because of No Band / Class by provider. Please comment below code in mm-generic-cdma.c, rebuild the package, Now RelianceNetConnect Broadband+ service will work Huawei EC 1260 Modem, it's also true for other modems, but not tested, still investigating the issue, but this hacks works for me.

---
/* Return 'no service' if none of the elements of the +CSS response
         * indicate that the modem has service. Note that this allows SID 0
         * when at least one of the other elements indicates service.
         * Normally we'd treat SID 0 as 'no service' but some modems
         * (Sierra 5725) sometimes return SID 0 even when registered.
         */
        //if (sid == 0 && !class_ok && !band_ok)
        // sid = 99999;
---

Jerone Young (jerone) wrote :

Dan Williams has good comment on this problem upstream:

http://mail.gnome.org/archives/networkmanager-list/2010-March/msg00326.html

@ Jerone,

Thanks for posting, does that mean, future version will take care of SID=0?

Jerone Young (jerone) wrote :

Hi all can you try out this upstream modem manager package I created. It has the fixes Dan Williams mentions.

You will need to try it under a 10.04 build. Please write back with your findings of if it works or not.

@ Jerone,

Here is testing procedure, result and observation..

1. Installed packaged mentioned in Comment #25
2. Rebooted machine
3. Started Modemmanager in debugging mode as described here https://wiki.ubuntu.com/DebuggingModemmanager
4. Insert the Huaei EC 1260 with Reliance NetConnect Broadband+ Service
5. Created Reliance NetConnect Broadband+ Connection (RNB) with Number / Username / Password
6. Dialed RNB Connection
7 Result: Could not connect to RNB Service.

Observation:
ModemManager / NetworkManager debugged log files are attached
I have also tried to reconnect RNB Service after first failure.
Ubuntu 10.04 Beta - 1 was updated to the latest update (5th April, 2010 12:03 PM IST)

@ Jerone:

Wow, Now, It's working fine. I can confirm that.

Here is testing procedure, result and observation..

1. Installed packaged mentioned in Comment #25
2. Rebooted machine
3. Started Modemmanager in debugging mode as described here https://wiki.ubuntu.com/DebuggingModemmanager
4. Insert the Huaei EC 1260 with Reliance NetConnect Broadband+ Service
5. Created Reliance NetConnect Broadband+ Connection (RNB) with Number / Username / Password
6. Dialed RNB Connection
7. It's connected

Observation:
ModemManager / NetworkManager debugged log files are attached
It was connected in first attempt only
During browsing, it's taking too much time while contacting server, but after that it loads page with default speed as claimed, look like DNS Problem, right?
Ubuntu 10.04 Beta - 1 was updated to the latest update (7th April, 2010 03:24 PM IST)

cyber-punk (cyber-punk) wrote :

@ Jerone:

Idle modem ZTE AC8700 in NM in Lucid became a big problem for the transition from Jaunty. But I tried at first to upgrade from "https://launchpad.net/~network-manager/+archive/trunk", then put the package from the Comment #25 and the modem is working!
MANY THANKS!
Now I'm finally able to switch completely to Lucid.
Thanks again!

@ Cyber-punk,

It it working during suspend / resume, it NM + Mobile Broadband is in auto-reconnect mode? During my testing i found it's not working.

grn (gaurangarora) wrote :

@Hardik
@Jerone

It's working with Huawei 1260.

Thanks

grn (gaurangarora) wrote :

@Hardik
@Jerone
With Huawei 1260, it is working, but it is very unstable. Does not necessarily connect everytime. And the lower side is that wvdial does not work either.

I had to install the packaged version of modemmanager and go back to using wvdial.

cyber-punk (cyber-punk) wrote :

After the last system update again does not work

Thomas Hood (jdthood) on 2012-07-03
summary: - ZTE AC8700 modem doesn't work
+ NM can't configure ZTE AC8700 modem; wvdial can

What's the status of this on 12.04? Anybody seeing this bug on that release?

Thanks!

Changed in modemmanager (Ubuntu):
status: Confirmed → Incomplete
importance: Undecided → Medium

It's still not working after years.
Any updates?

raamee (thiyadaram) wrote :

I'm also having the same issue. I purchased BSNL Teracom T-U500 modem and I have the same issue. I use Ubuntu 12.04 64 bit.

To post a comment you must log in.