[9.04 beta] no way to access screensaver enable/disable or timer settings like pre-beta 9.04

Bug #350962 reported by Mike Hurley on 2009-03-29
8
Affects Status Importance Assigned to Milestone
Mythbuntu
Fix Released
Undecided
Unassigned
gnome-screensaver (Ubuntu)
Undecided
Unassigned
mythbuntu-default-settings (Ubuntu)
Undecided
Unassigned
xfce4-utils (Ubuntu)
Undecided
Unassigned
xubuntu-default-settings (Ubuntu)
Undecided
Unassigned

Bug Description

Platform: amd64

In the 9.04 Alpha 3 install I had kept upgrading there was a way to set the screensaver idle timeout in a dialog (enabled/disabled, idle timeout, etc). If you set the idle timeout to X, you could then specify, for instance, a "put monitor to sleep" time of X+Y.

In the beta, fresh install, I see in Applications > Other > Power Management that you can still set the X+Y time for post-idle events, but I don't see a place to set the idle timeout X or disable gnome-screensaver's idle timer. Also different from the alpha, there is an Applications > Settings > Screensavers menu that lets you set the current screensaver, but not any other settings.

Workaround: Install gconf-editor and manually tweak the settings you care about.

Mario Limonciello (superm1) wrote :

I want to say this was a side effect of the transition to Xfce 4.6 that the xubuntu developers did, but i'm not positive. It is awfully confusing now I agree.

Changed in mythbuntu:
status: New → Confirmed
Lionel Le Folgoc (mrpouit) wrote :

> Workaround: Install gconf-editor and manually tweak the settings you care about.

Isn't it a bug in gnome-screensaver/gnome-power-manager then?
Xfce4 has never provided a way to change screensaver settings iirc (and it wouldn't use gconf anyway...).

In Xubuntu 9.04 (beta), gnome-screensaver-preferences is still installed and can be manually executed, giving access to all the standard screen saver settings. The problem seems to be only that it is not offered in any menu anywhere.

Lionel Le Folgoc (mrpouit) wrote :

Its desktop file contains "OnlyShowIn=GNOME;", that's why it won't show up in the Xfce menu.

affects: xfce4-settings (Ubuntu) → gnome-screensaver (Ubuntu)
Mario Limonciello (superm1) wrote :
Changed in gnome-screensaver (Ubuntu):
milestone: none → ubuntu-9.04
status: New → Confirmed
Changed in xubuntu-default-settings (Ubuntu):
status: New → Confirmed
Changed in mythbuntu-default-settings (Ubuntu):
milestone: none → ubuntu-9.04
status: New → Confirmed
Changed in xubuntu-default-settings (Ubuntu):
milestone: none → ubuntu-9.04
Charlie Kravetz (charlie-tca) wrote :

Would sponsoring bug 355370 and getting the .desktop file corrected also fix this?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xubuntu-default-settings - 0.54

---------------
xubuntu-default-settings (0.54) jaunty; urgency=low

  * etc/xdg/xubuntu/menus/xfce-applications.menu: Don't show the
    Screensavers menu. It has no purpose. Instead we should be showing the
    screensavers preferences utility. (LP: #350962)

 -- Mario Limonciello <email address hidden> Sat, 11 Apr 2009 10:39:41 -0500

Changed in xubuntu-default-settings (Ubuntu):
status: Confirmed → Fix Released
Changed in xfce4-utils (Ubuntu):
milestone: none → ubuntu-9.04
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfce4-utils - 4.6.0-1ubuntu2

---------------
xfce4-utils (4.6.0-1ubuntu2) jaunty; urgency=low

  * Update xubuntu_update-xdg-config-and-data-dirs.patch to also include
    /etc/xdg so that any settings that are not defined in the XDG_CONFIG_DIRS
    directory can be defined by /etc/xdg. (LP: #350962)

 -- Mario Limonciello <email address hidden> Sat, 11 Apr 2009 11:21:17 -0500

Changed in xfce4-utils (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mythbuntu-default-settings - 0.78-0ubuntu1

---------------
mythbuntu-default-settings (0.78-0ubuntu1) jaunty; urgency=low

  * Drop other and screensaver menus. (LP: #350962)
  * Make sure that the menu uses our menu rather than the one in
    /etc/xdg.

 -- Mario Limonciello <email address hidden> Sat, 11 Apr 2009 11:52:43 -0500

Changed in mythbuntu-default-settings (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-screensaver - 2.24.0-0ubuntu6

---------------
gnome-screensaver (2.24.0-0ubuntu6) jaunty; urgency=low

  * debian/patches/09_include_in_xfce.patch: Don't hide the screensaver
    preferences from XFCE based sessions. (LP: #350962)

 -- Mario Limonciello <email address hidden> Sat, 11 Apr 2009 09:51:29 -0500

Changed in gnome-screensaver (Ubuntu):
status: Confirmed → Fix Released
Mario Limonciello (superm1) wrote :

Fixed in mythbuntu daily disks starting april 12, closing mythbuntu task

Changed in mythbuntu:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Patches