Weather Setup screen unusably slow

Bug #146626 reported by JP Vossen on 2007-09-29
2
Affects Status Importance Assigned to Milestone
Mythbuntu
Undecided
Unassigned

Bug Description

The Weather Setup screen (Utilities / Setup; Setup; Info Center Settings; Weather Settings) is unusably slow on the GUI on my backend server.

Steps to reproduce: Go into that menu on my machine and then get stuck there.

Details:
All other menus (and I've walked them all) are fine to adequate. Weather Setup takes *minutes* to act on *any* keystroke (CTRL-ALT-F1 doesn't even work) and 'top' from an SSH session shows Xorg with 99% CPU. As soon as I'm out of Weather Setup, CPU goes back to 0. It's 10-65% during general menu surfing, 81% during live SD TV, 30% in program guide, but 99% in Weather Setup.

I am using the stock ATI drivers as I'm running this backend on a Dell PE-650 server (see lspci) and I don't see other drivers on Dell's site. I am also now out of PCI slots with the tuner and NIC, so "get a real card" is not an option. Use a different frontend GUI might be an option if I could get one to work. Also FYI this machine is running through a very old hardware KVM.

Having said all of that SD TV playback works fine, as does general menu surfing and all other configuration (see http://www.jpsdomain.org/jp/mythtv.txt for my raw diary of same and more details than you could possibly want). Ironically I had zero problems like this in a previous VMware test machine, everything was very snappy. And that is using the same KVM and monitor (analog Dell 2005FPW).

If I could just get it set, I could live with that menu's slowness since I won't need it again. (As noted, this all worked just fine under VMware, same monitor and KVM, different server hardware, different video card.) I tried poking the values I grabbed from a MySQL dump on the VM into a test instance of Mythbuntu, but that doesn't seem to have worked:

[mythtvuser@mythtv-be-01:T0:L1:C76:J0:2007-09-29_02:51:25_EDT]
/home/mythtvuser$ mysql -u mythtv -p
Enter password:
Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 92
Server version: 5.0.45-Debian_1ubuntu2-log Debian etch distribution

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql> use mythconverg
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A

Database changed
mysql> INSERT INTO `settings` (`value`, `data`, `hostname`) VALUES ('locale','USPA0311','mythtv-be-01'),('SIUnits','NO','mythtv-be-01'),('WeatherAggressiveLvl','8','mythtv-be-01');
Query OK, 3 rows affected (0.01 sec)
Records: 3 Duplicates: 0 Warnings: 0

mysql> quit
Bye

# ATI vid, Haupauge PVR-500 tuner
$ lspci
   00:00.0 Host bridge: Broadcom GCNB-LE Host Bridge (rev 32)
   00:00.1 Host bridge: Broadcom GCNB-LE Host Bridge
   00:03.0 PCI bridge: Pericom Semiconductor Unknown device 8140
>> 00:04.0 VGA compatible controller: ATI Technologies Inc Rage XL (rev 27)
   00:05.0 IDE interface: Silicon Image, Inc. PCI0680 Ultra ATA-133 Host Controller (rev 02)
   00:0f.0 Host bridge: Broadcom CSB6 South Bridge (rev a0)
   00:0f.1 IDE interface: Broadcom CSB6 RAID/IDE Controller (rev a0)
   00:0f.3 ISA bridge: Broadcom GCLE-2 Host Bridge
   00:10.0 Host bridge: Broadcom CIOB-E I/O Bridge with Gigabit Ethernet (rev 12)
   00:10.2 Host bridge: Broadcom CIOB-E I/O Bridge with Gigabit Ethernet (rev 12)
>> 01:08.0 Multimedia video controller: Internext Compression Inc iTVC16 (CX23416) MPEG-2 Encoder (rev 01)
>> 01:09.0 Multimedia video controller: Internext Compression Inc iTVC16 (CX23416) MPEG-2 Encoder (rev 01)
   02:03.0 Ethernet controller: Intel Corporation 82557/8/9 Ethernet Pro 100 (rev 0c)

JP Vossen (jp-jpsdomain) wrote :

Oh, I forgot, I did and apt-get update && apt-get dist-upgrade, then rebooted today before trying this again = no change.

JP Vossen schrieb:
> Public bug reported:
>
> The Weather Setup screen (Utilities / Setup; Setup; Info Center
> Settings; Weather Settings) is unusably slow on the GUI on my backend
> server.

Does it work when you run "mythtv-setup -O ThemePainter=qt"?

JP Vossen (jp-jpsdomain) wrote :

I don't know.

<hate to admit ignorance, but>
How do I run it that way from a machine with no other GUI ("no desktop")? I'm more of a Linux command line guy... I can CTRL-ALT-F1 to a console, and maybe good around with $DISPLAY to do that?
</hate to admit ignorance, but>

FWIW, Utilities / Setup; Setup; Appearance:
 Theme MythCenter
 Paint Engine: QT
 QT Style: Desktop Style

So maybe I'm already running it that way? O

PaintEngine options on my install are QT or OpenGL
QT style has a bunch of things.

Would trying other themes and/or settings be useful? I can do that...

JP Vossen (jp-jpsdomain) wrote :

Very interesting!

1) My DB insert did work. I was attempting to check if they worked or not via the weather setup screen, which as noted is essentially non-responsive. Since I never really got a display I guess I assumed the settings didn't work, but I never actually tried the regular weather screen. I also wasn't expecting it to work as a previous trial had failed, but now I think that was a user error on my part to change the hostname from the VMware test machine to my previous "live" test machine.

2) I switched the paint engine to OpenGL. The weather setup screen is much faster than it was, but still *very* slow and I still don't think it's usable. I literally put a paper-weight on the Pg-Dn key several minutes ago and I' not even out of the "Car…" section yet. Oh, just hit "Cas…". The ESC key works at almost real time though, where with QT it would take minutes to even exit the screen and the PG-Dn trick did basically nothing.

Using QT works when *viewing* weather (which I'd neglected to try, ID10T error), but it takes about 3 times longer to bring up the page. Once it's up, flipping screens of the weather display seems to work about the same. The program guide seems a bit snappier under OpenGL as well, so I'll keep that for a while.

So, I have achieved my goal of setting the correct location for weather info. Having said that, I'm happy to keep poking around and trying things if you want to t-shoot some more.

JP Vossen (jp-jpsdomain) wrote :

I just did another apt-get update && apt-get upgrade. Weather is now better, I'd say it's usable, but *just.* However, the menu screens are now doing some fade in/out thing which a) I find intensely irritating and b) now makes menu switching very, very slow. 35 seconds by stopwatch to go into the "TV Settings" menu now.

David Morris (dave-greenacre) wrote :

Superm1, this sounds as if the hardware isn't gutsy enough to cope. I have similar results with my p450 backend where it takes a while to navigate the menus. You think it's actually a bug with mythbuntu we should look into?

Changed in mythbuntu:
assignee: nobody → superm1

David Morris schrieb:
> Superm1, this sounds as if the hardware isn't gutsy enough to cope. I
> have similar results with my p450 backend where it takes a while to
> navigate the menus. You think it's actually a bug with mythbuntu we
> should look into?
>

I've meant to reply to this one for a long time.

I'm seeing performance issues on my ATI card as well. Interestingly
enough, it goes away once I disable 3d acceleration in the X server.

Can you try putting:

" Option "DRI" "false"
        Option "NoAccel" "true"
" in the Device section in your xorg.conf and restart X? If you don't
know how to do that, please request further advice.

That "fade in/out thing" you're seeing is likely caused by the OpenGL
painter...

Mario Limonciello (superm1) wrote :

Marking this bug as incomplete. If we don't hear back in 90 days or so, it will automatically expire.

Changed in mythbuntu:
status: New → Incomplete
assignee: superm1 → nobody
JP Vossen (jp-jpsdomain) wrote :

Sorry, lost track of this one. I tried the following but it didn't help:

Section "Device"
        Identifier "ATI Technologies Inc Rage XL"
        Driver "ati"
        BusID "PCI:0:4:0"
        # Per: https://bugs.launchpad.net/mythbuntu/+bug/146626
        Option "DRI" "false"
        #Option "NoAccel" "true"
        # end per: https://bugs.launchpad.net/mythbuntu/+bug/146626
EndSection

The NoAccel entry caused X not to start at all. The DRI line had no effect that I can tell. Did I put the right things in the right place?

The "fade in/out" thing is either gone or fast enough that it's not a problem.

As for the hardware not being good enough, the things I've recorded play with no problem... I would think if it can play live TV or recordings, it should be able to handle a simple menu, especially since the Weather location selector is the *only* place I see the problem...

Note I've done a bunch of updates since my last report, here is what I have now:

$ dpkg-query --show | perl -pe 's/^(.*?)\t(?:\d:)?(.*)$/$1_$2/;' | sort | grep -i myth
gtk2-engines-mythbuntu_0.3-0ubuntu1
libmyth-0.20_0.20.2+fixes15017-0ubuntu0~mythbuntu1
mytharchive_0.20.2+fixes15017-0ubuntu0~mythbuntu1
mytharchive-data_0.20.2+fixes15017-0ubuntu0~mythbuntu1
mythbrowser_0.20.2+fixes15017-0ubuntu0~mythbuntu1
mythbuntu-artwork-usplash_0.6-0ubuntu1
mythbuntu-control-centre_0.11-0ubuntu1~ppa1
mythbuntu-default-settings_0.63-0ubuntu1
mythbuntu-desktop_0.8
mythbuntu-gdm-theme_0.2-0ubuntu1
mythbuntu-lirc-generator_0.17-0ubuntu1~gutsy1
mythcontrols_0.20.2+fixes15017-0ubuntu0~mythbuntu1
mythdvd_0.20.2+fixes15017-0ubuntu0~mythbuntu1
mythflix_0.20.2+fixes15017-0ubuntu0~mythbuntu1
mythgallery_0.20.2+fixes15017-0ubuntu0~mythbuntu1
mythmusic_0.20.2+fixes15017-0ubuntu0~mythbuntu1
mythnews_0.20.2+fixes15017-0ubuntu0~mythbuntu1
mythstream_0.17.2-0ubuntu1
mythtv_0.20.2+fixes15017-0ubuntu0~mythbuntu1
mythtv-backend_0.20.2+fixes15017-0ubuntu0~mythbuntu1
mythtv-backend-master_0.20.2+fixes15017-0ubuntu0~mythbuntu1
mythtv-common_0.20.2+fixes15017-0ubuntu0~mythbuntu1
mythtv-database_0.20.2+fixes15017-0ubuntu0~mythbuntu1
mythtv-frontend_0.20.2+fixes15017-0ubuntu0~mythbuntu1
mythtv-themes_0.20-0.1ubuntu1
mythtv-transcode-utils_0.20.2+fixes15017-0ubuntu0~mythbuntu1
mythvideo_0.20.2+fixes15017-0ubuntu0~mythbuntu1
mythweather_0.20.2+fixes15017-0ubuntu0~mythbuntu1
mythweb_0.20.2+fixes15017-0ubuntu0~mythbuntu1
ubuntu-mythtv-frontend_0.20.2+fixes15017-0ubuntu0~mythbuntu1

laga (laga) wrote :

Ok,

I was messing with my xorg.conf the other day and noticed that setting EXA vs XAA made a big difference. Maybe you can try adding

Option "AccelMethod" "XAA"

to your device section in xorg.conf? There's a thread in the Ubuntu forums which helped me a lot: http://ubuntuforums.org/showthread.php?t=317545

I hope that helps.. and don't break anything :)

laga (laga) wrote :

MythTV 0.21 comes with a completely revamped MythWeather plugin whose settings screen most likely doesn't trigger this issue anymore. If it's still a problem, please reopen.

Changed in mythbuntu:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers